bap-server

BAP RPC server

Error log

The package failed to build. The error log from opam follows.

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for bap-server.0.2.0 & astring.0.8.5 & bap.1.4.0 & bap-abi.1.4.0 & bap-api.1.4.0 & bap-arm.1.4.0 & bap-beagle.1.4.0 & bap-byteweight.1.4.0 & bap-c.1.4.0 & bap-cache.1.4.0 & bap-callsites.1.4.0 & bap-cxxfilt.1.4.0 & bap-dead-code-elimination.1.4.0 & bap-demangle.1.4.0 & bap-dump-symbols.1.4.0 & bap-frontc.1.4.0 & bap-frontend.1.4.0 & bap-future.1.4.0 & bap-llvm.1.4.0 & bap-mc.1.4.0 & bap-microx.1.4.0 & bap-mips.1.4.0 & bap-objdump.1.4.0 & bap-powerpc.1.4.0 & bap-primus.1.4.0 & bap-primus-dictionary.1.4.0 & bap-primus-lisp.1.4.0 & bap-primus-region.1.4.0 & bap-primus-support.1.4.0 & bap-primus-test.1.4.0 & bap-primus-x86.1.4.0 & bap-print.1.4.0 & bap-relocatable.1.4.0 & bap-report.1.4.0 & bap-run.1.4.0 & bap-signatures.1.4.0 & bap-ssa.1.4.0 & bap-std.1.4.0 & bap-strings.1.4.0 & bap-symbol-reader.1.4.0 & bap-taint.1.4.0 & bap-taint-propagator.1.4.0 & bap-term-mapper.1.4.0 & bap-trace.1.4.0 & bap-traces.1.4.0 & bap-trivial-condition-form.1.4.0 & bap-warn-unused.1.4.0 & bap-x86.1.4.0 & bare.1.5.0 & base.v0.9.4 & base-bytes.base & base-num.base & base64.2.3.0 & bigarray-compat.1.1.0 & bin_prot.v0.9.2 & camlzip.1.10 & camomile.1.0.1 & cmdliner.1.0.4 & cohttp.1.0.2 & cohttp-lwt.1.0.2 & cohttp-lwt-unix.1.0.2 & conduit.1.3.0 & conduit-lwt.1.3.0 & conduit-lwt-unix.1.3.0 & conf-bap-llvm.1.2 & conf-binutils.0.2 & conf-clang.1 & conf-env-travis.1 & conf-gmp.4 & conf-pkg-config.2 & conf-which.1 & conf-zlib.1 & configurator.v0.9.1 & core-lwt.0.2.0 & core_kernel.v0.9.1 & cppo.1.6.8 & cppo_ocamlbuild.1.6.8 & cstruct.5.1.1 & dune.1.6.3 & ezjsonm.0.5.0 & FrontC.3.4.3-1 & fieldslib.v0.9.0 & fileutils.0.6.0 & fmt.0.8.9 & graphlib.1.5.0 & hex.1.4.0 & ipaddr.2.9.0 & jane-street-headers.v0.9.0 & jbuilder.transition & jsonm.1.0.1 & lambda-term.1.12.0 & logs.0.7.0 & lwt.3.3.0 & lwt_react.1.1.3 & magic-mime.1.3.0 & monads.1.5.0 & num.0 & oasis.0.4.7 & ocaml-compiler-libs.v0.9.0 & ocaml-migrate-parsetree.1.3.1 & ocamlbuild.0.14.2 & ocamlfind.1.9.5 & ocamlgraph.1.8.8 & ocamlify.0.0.1 & ocamlmod.0.0.9 & octavius.1.2.1 & ogre.1.5.0 & parsexp.v0.9.1 & ppx_assert.v0.9.0 & ppx_ast.v0.9.1 & ppx_base.v0.9.0 & ppx_bench.v0.9.1 & ppx_bin_prot.v0.9.0 & ppx_compare.v0.9.0 & ppx_core.v0.9.3 & ppx_custom_printf.v0.9.0 & ppx_derivers.1.2.1 & ppx_driver.v0.9.2 & ppx_enumerate.v0.9.0 & ppx_expect.v0.9.0 & ppx_fail.v0.9.0 & ppx_fields_conv.v0.9.0 & ppx_hash.v0.9.0 & ppx_here.v0.9.1 & ppx_inline_test.v0.9.2 & ppx_jane.v0.9.0 & ppx_js_style.v0.9.0 & ppx_let.v0.9.0 & ppx_metaquot.v0.9.0 & ppx_optcomp.v0.9.0 & ppx_optional.v0.9.0 & ppx_pipebang.v0.9.0 & ppx_sexp_conv.v0.9.0 & ppx_sexp_message.v0.9.0 & ppx_sexp_value.v0.9.0 & ppx_tools_versioned.5.2.2 & ppx_traverse.v0.9.0 & ppx_traverse_builtins.v0.9.0 & ppx_type_conv.v0.9.1 & ppx_typerep_conv.v0.9.0 & ppx_variants_conv.v0.9.0 & re.1.7.1 & react.1.2.1 & regular.1.5.0 & result.1.5 & seq.0.2.2 & sexplib.v0.9.3 & stdio.v0.9.1 & stdlib-shims.0.3.0 & stringext.1.6.0 & text-tags.1.5.0 & topkg.1.0.6 & typerep.v0.9.0 & uchar.0.0.2 & uri.1.9.6 & utop.1.19.3 & uuidm.0.9.7 & uutf.1.0.3 & variantslib.v0.9.0 & zarith.1.12 & zed.1.6:   * Missing dependency:
            - conf-bap-llvm = 1.2
            depends on the unavailable system package 'llvm-4.0-dev'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.


Command failed: opam --cli=2.1 list --readonly --external '--resolve=bap-server.0.2.0,astring.0.8.5,bap.1.4.0,bap-abi.1.4.0,bap-api.1.4.0,bap-arm.1.4.0,bap-beagle.1.4.0,bap-byteweight.1.4.0,bap-c.1.4.0,bap-cache.1.4.0,bap-callsites.1.4.0,bap-cxxfilt.1.4.0,bap-dead-code-elimination.1.4.0,bap-demangle.1.4.0,bap-dump-symbols.1.4.0,bap-frontc.1.4.0,bap-frontend.1.4.0,bap-future.1.4.0,bap-llvm.1.4.0,bap-mc.1.4.0,bap-microx.1.4.0,bap-mips.1.4.0,bap-objdump.1.4.0,bap-powerpc.1.4.0,bap-primus.1.4.0,bap-primus-dictionary.1.4.0,bap-primus-lisp.1.4.0,bap-primus-region.1.4.0,bap-primus-support.1.4.0,bap-primus-test.1.4.0,bap-primus-x86.1.4.0,bap-print.1.4.0,bap-relocatable.1.4.0,bap-report.1.4.0,bap-run.1.4.0,bap-signatures.1.4.0,bap-ssa.1.4.0,bap-std.1.4.0,bap-strings.1.4.0,bap-symbol-reader.1.4.0,bap-taint.1.4.0,bap-taint-propagator.1.4.0,bap-term-mapper.1.4.0,bap-trace.1.4.0,bap-traces.1.4.0,bap-trivial-condition-form.1.4.0,bap-warn-unused.1.4.0,bap-x86.1.4.0,bare.1.5.0,base.v0.9.4,base-bytes.base,base-num.base,base64.2.3.0,bigarray-compat.1.1.0,bin_prot.v0.9.2,camlzip.1.10,camomile.1.0.1,cmdliner.1.0.4,cohttp.1.0.2,cohttp-lwt.1.0.2,cohttp-lwt-unix.1.0.2,conduit.1.3.0,conduit-lwt.1.3.0,conduit-lwt-unix.1.3.0,conf-bap-llvm.1.2,conf-binutils.0.2,conf-clang.1,conf-env-travis.1,conf-gmp.4,conf-pkg-config.2,conf-which.1,conf-zlib.1,configurator.v0.9.1,core-lwt.0.2.0,core_kernel.v0.9.1,cppo.1.6.8,cppo_ocamlbuild.1.6.8,cstruct.5.1.1,dune.1.6.3,ezjsonm.0.5.0,FrontC.3.4.3-1,fieldslib.v0.9.0,fileutils.0.6.0,fmt.0.8.9,graphlib.1.5.0,hex.1.4.0,ipaddr.2.9.0,jane-street-headers.v0.9.0,jbuilder.transition,jsonm.1.0.1,lambda-term.1.12.0,logs.0.7.0,lwt.3.3.0,lwt_react.1.1.3,magic-mime.1.3.0,monads.1.5.0,num.0,oasis.0.4.7,ocaml-compiler-libs.v0.9.0,ocaml-migrate-parsetree.1.3.1,ocamlbuild.0.14.2,ocamlfind.1.9.5,ocamlgraph.1.8.8,ocamlify.0.0.1,ocamlmod.0.0.9,octavius.1.2.1,ogre.1.5.0,parsexp.v0.9.1,ppx_assert.v0.9.0,ppx_ast.v0.9.1,ppx_base.v0.9.0,ppx_bench.v0.9.1,ppx_bin_prot.v0.9.0,ppx_compare.v0.9.0,ppx_core.v0.9.3,ppx_custom_printf.v0.9.0,ppx_derivers.1.2.1,ppx_driver.v0.9.2,ppx_enumerate.v0.9.0,ppx_expect.v0.9.0,ppx_fail.v0.9.0,ppx_fields_conv.v0.9.0,ppx_hash.v0.9.0,ppx_here.v0.9.1,ppx_inline_test.v0.9.2,ppx_jane.v0.9.0,ppx_js_style.v0.9.0,ppx_let.v0.9.0,ppx_metaquot.v0.9.0,ppx_optcomp.v0.9.0,ppx_optional.v0.9.0,ppx_pipebang.v0.9.0,ppx_sexp_conv.v0.9.0,ppx_sexp_message.v0.9.0,ppx_sexp_value.v0.9.0,ppx_tools_versioned.5.2.2,ppx_traverse.v0.9.0,ppx_traverse_builtins.v0.9.0,ppx_type_conv.v0.9.1,ppx_typerep_conv.v0.9.0,ppx_variants_conv.v0.9.0,re.1.7.1,react.1.2.1,regular.1.5.0,result.1.5,seq.0.2.2,sexplib.v0.9.3,stdio.v0.9.1,stdlib-shims.0.3.0,stringext.1.6.0,text-tags.1.5.0,topkg.1.0.6,typerep.v0.9.0,uchar.0.0.2,uri.1.9.6,utop.1.19.3,uuidm.0.9.7,uutf.1.0.3,variantslib.v0.9.0,zarith.1.12,zed.1.6' returned 20