core_kernel

Industrial strength alternative to OCaml's standard library
Description

The Core suite of libraries is an industrial strength alternative to OCaml's standard library that was developed by Jane Street, the largest industrial user of OCaml.

Core_kernel is the system-independent part of Core.

Install
Published
14 Jul 2018
Authors
Maintainers
Sources
v0.11.1.tar.gz
md5=2946775ce7660e026996d55da9c10b83
Dependencies
ocaml-migrate-parsetree >= "1.0" & < "2.0.0"
jbuilder >= "1.0+beta18.1"
variantslib >= "v0.11" & < "v0.12"
typerep >= "v0.11" & < "v0.12"
stdio >= "v0.11" & < "v0.12"
splittable_random >= "v0.11" & < "v0.12"
sexplib >= "v0.11" & < "v0.12"
ppx_sexp_message >= "v0.11" & < "v0.12"
ppx_sexp_conv >= "v0.11" & < "v0.12"
ppx_jane >= "v0.11" & < "v0.12"
ppx_inline_test >= "v0.11" & < "v0.12"
ppx_hash >= "v0.11" & < "v0.12"
ppx_base >= "v0.11" & < "v0.12"
ppx_assert >= "v0.11" & < "v0.12"
jane-street-headers >= "v0.11" & < "v0.12"
fieldslib >= "v0.11" & < "v0.12"
configurator >= "v0.11" & < "v0.12"
bin_prot >= "v0.11" & < "v0.12"
base >= "v0.11" & < "v0.12"
ocaml >= "4.04.1" & < "4.12.0"
Reverse Dependencies
async_durable = "v0.11.0"
async_kernel >= "v0.11.0" & < "v0.12.0"
async_rpc_kernel = "v0.11.0"
aws-s3-async = "3.0.0"
bap-build < "2.1.0"
bap-bundle < "2.1.0"
bap-demangle >= "1.6.0" & < "2.1.0"
bap-frames >= "2.1.2"
bap-future >= "1.6.0" & < "2.1.0"
bap-ida >= "1.6.0" & < "2.1.0"
bap-mc = "2.0.0"
bap-plugins < "2.1.0"
bap-raw < "2.1.0"
bap-server >= "0.3.0"
bap-std >= "1.6.0" & < "2.1.0"
bap-strings >= "1.6.0" & < "2.1.0"
bap-veri >= "0.2.3" & < "0.2.5"
bare >= "1.6.0" & < "2.1.0"
bignum = "v0.11.0"
biocaml = "0.9.0"
capnp >= "3.0.0" & != "3.2.0" & < "3.3.0"
caqti-async >= "1.2.0" & < "1.9.0"
cfstream >= "1.3.0"
core >= "v0.11.0" & < "v0.12.0"
core-lwt >= "0.3.0"
core_extended = "v0.11.0"
cstruct-async >= "3.0.2" & < "6.1.0"
ecaml = "v0.11.0"
email_message = "v0.11.0"
flowtype >= "0.87.0"
git < "1.3.0"
graphlib >= "1.6.0" & < "2.1.0"
hack_parallel = "1.0.0"
incr_dom = "v0.11.0"
incr_map = "v0.11.0"
incr_select = "v0.11.0"
irmin < "0.9.0"
libsvm = "0.9.3" | >= "0.10.0"
mlt_parser = "v0.11.0"
mmseg < "transition"
monads >= "1.6.0" & < "2.1.0"
ogre >= "1.6.0" & < "2.1.0"
opium >= "0.12.0" & < "0.15.0"
patience_diff = "v0.11.0"
plotkicadsch >= "0.2.0" & < "0.8.0"
re2 = "v0.11.0"
record_builder = "v0.11.0"
regular >= "1.6.0" & < "2.1.0"
splay_tree = "v0.11.0"
text-tags >= "1.6.0" & < "2.1.0"
textutils_kernel = "v0.11.0"
tidy >= "1-4.9.30-0.1.1"
topology >= "0.4.0"
travesty < "0.3.0"
Conflicts
jbuilder = "1.0+beta19"