core_kernel

Industrial strength alternative to OCaml's standard library
Description

The Core suite of libraries is an industrial strength alternative to OCaml's standard library that was developed by Jane Street, the largest industrial user of OCaml.

Core_kernel is the system-independent part of Core.

Install
Published
03 Nov 2017
Authors
Maintainers
Sources
v0.9.1.tar.gz
md5=b29a45163eca682776ff115f75b0c54b
Dependencies
ocaml-migrate-parsetree >= "0.4" & < "2.0.0"
variantslib >= "v0.9" & < "v0.10"
typerep >= "v0.9" & < "v0.10"
stdio >= "v0.9.1" & < "v0.10"
sexplib >= "v0.9.3" & < "v0.10"
ppx_sexp_message >= "v0.9" & < "v0.10"
ppx_sexp_conv >= "v0.9" & < "v0.10"
ppx_jane >= "v0.9" & < "v0.10"
ppx_inline_test >= "v0.9" & < "v0.10"
ppx_hash >= "v0.9" & < "v0.10"
ppx_driver >= "v0.9.2" & < "v0.10"
ppx_base >= "v0.9" & < "v0.10"
ppx_assert >= "v0.9" & < "v0.10"
jbuilder >= "1.0+beta7"
jane-street-headers >= "v0.9" & < "v0.10"
fieldslib >= "v0.9" & < "v0.10"
configurator >= "v0.9" & < "v0.10"
bin_prot >= "v0.9.2" & < "v0.10"
base >= "v0.9.4" & < "v0.10"
ocaml >= "4.03.0" & < "4.12.0"
Reverse Dependencies
async_kernel = "v0.9.0"
aws-s3-async = "3.0.0"
bap-demangle >= "1.4.0" & < "1.6.0"
bap-frames = "2.1.1"
bap-future >= "1.4.0" & < "1.6.0"
bap-ida >= "1.4.0" & < "1.6.0"
bap-server = "0.2.0"
bap-std >= "1.4.0" & < "1.6.0"
bap-strings >= "1.4.0" & < "1.6.0"
bare < "1.6.0"
bignum = "v0.9.0"
biocaml = "0.8.0"
capnp >= "3.0.0" & < "3.2.0"
caqti-async >= "1.3.0" & < "1.9.0"
cfstream >= "1.1.2" & < "1.3.0"
core >= "v0.9.0" & < "v0.10.0"
core-lwt = "0.2.0"
core_extended >= "v0.9.0" & < "v0.10.0"
cstruct-async >= "3.0.2" & < "6.1.0"
git < "1.3.0"
graphlib >= "1.4.0" & < "1.6.0"
hack_parallel = "1.0.0"
incr_dom < "v0.10.0"
incr_map < "v0.10.0"
incr_select < "v0.10.0"
irmin < "0.9.0"
libsvm = "0.9.3" | >= "0.10.0"
mmseg < "transition"
monads >= "1.4.0" & < "1.6.0"
ogre >= "1.4.0" & < "1.6.0"
opium >= "0.12.0" & < "0.15.0"
patience_diff = "v0.9.0"
plotkicadsch >= "0.2.0" & < "0.8.0"
re2 >= "v0.9.0" & < "v0.10.0"
regular >= "1.4.0" & < "1.6.0"
text-tags >= "1.4.0" & < "1.6.0"
tidy < "5-0.2"
toplevel_expect_test >= "v0.9.1" & < "v0.10.0"
topological_sort < "v0.10.0"
topology >= "0.4.0"
trie < "1.0.0"
typerep_extended >= "v0.9.0"