lwt

A cooperative threads library for OCaml
Description

This library is part of the Ocsigen project. See:

http://ocsigen.org/lwt

Install
Published
15 Oct 2014
Authors
Maintainers
Sources
2.4.6.tar.gz
md5=46d7efc6326628cca3f4a28628920176
Dependencies
Reverse Dependencies
0install != "2.12.3"
amqp-client >= "0.9.0" & < "1.0.2" | >= "1.1.0"
arakoon < "1.8.6"
arp >= "2.3.1"
arp-mirage < "2.0.0" | >= "2.2.0"
aws < "1.0.0"
bap < "1.0.0"
bap-server < "0.2.0"
biocaml >= "0.3.0" & < "0.5.0"
bistro < "0.5.0"
brotli < "1.2.0"
bun >= "0.3.3"
camltc < "0.9.5"
capnp-rpc-unix >= "0.9.0"
caqti-lwt < "0.11.0"
charrua-unix >= "0.3" & < "0.9"
coclobas != "0.0.1"
cohttp = "0.11.1"
cohttp-lwt != "1.0.0" & < "2.0.0"
conduit-lwt = "3.0.0"
core-lwt < "0.2.0"
cowabloga != "0.1.0"
crunch >= "2.0.0"
cstruct-lwt < "3.0.0" | >= "3.0.2"
ctypes >= "0.6.0" & < "0.6.2"
curly < "0.2.0"
data-encoding < "0.1.1"
datakit < "0.9.0"
datakit-client = "0.11.0"
datakit-server < "0.11.0"
dht < "0.2.0"
distributed < "0.4.0"
dns < "0.5.0" | >= "0.6.1" & < "0.15.2" | >= "0.19.1" & < "1.0.0"
earlybird < "1.0.0"
eliom = "6.3.0"
ezjsonm >= "0.4.2" & < "0.5.0"
frenetic < "2.0.0"
git < "1.4.4" | >= "3.0.0"
git-unix = "1.11.1" | >= "3.0.0" & < "3.10.0"
github-unix >= "4.4.0"
hardcaml < "1.1.0"
hiredis = "0.4"
http-multipart-formdata >= "2.0.0" & < "3.0.0"
inotify >= "2.4"
inquire < "0.3.0"
iocaml-kernel >= "0.4.3"
irmin < "0.9.3"
irmin-bench < "2.7.0"
irmin-chunk < "2.7.0"
irmin-fs >= "2.3.0" & < "2.7.0"
irmin-git >= "2.3.0" & < "2.7.0"
irmin-graphql >= "2.3.0" & < "2.7.0"
irmin-http >= "2.3.0" & < "2.7.0"
irmin-layers < "2.7.0"
irmin-mem >= "2.3.0"
irmin-mirage-git >= "2.3.0" & < "2.7.0"
irmin-mirage-graphql >= "2.3.0" & < "2.7.0"
irmin-pack < "2.7.0"
irmin-test >= "2.3.0" & < "2.7.0"
irmin-unix >= "2.3.0" & < "2.7.0"
irmin-watcher = "0.2.0" | >= "0.4.0"
jupyter < "1.0.2"
KaSim >= "4.0.0"
kafka >= "0.3" & < "0.5"
ke >= "0.5"
lablqml < "0.6"
lambda-term < "1.11"
links < "0.7.3"
lwt-parallel < "0.1.2"
lwt_log < "1.1.0"
maki >= "0.1.1"
mariadb < "0.5.1"
markup = "0.7.6"
metrics-lwt >= "0.2.0" & < "0.4.0"
metrics-unix >= "0.2.0" & < "0.4.0"
mirage < "0.9.1" | >= "0.10.0" & < "2.7.0"
mirage-block < "1.0.0"
mirage-clock-unix >= "1.2.0" & < "3.0.0"
mirage-console >= "2.1.1" & < "2.2.0"
mirage-console-unix >= "2.3.5" & < "3.0.0"
mirage-dns < "3.0.0"
mirage-flow < "1.0.3"
mirage-fs-lwt != "1.2.0"
mirage-fs-unix != "1.2.1"
mirage-nat < "3.0.0"
mirage-os-shim >= "3.0.0"
mirage-unix < "3.0.0" | >= "3.0.8"
mirage-www >= "1.1.0"
mirage-xen < "3.0.0" | >= "3.0.6"
mpris = "0.1.1"
mqtt < "0.0.2"
mrmime >= "0.5.0"
multipart_form >= "0.2.0" & < "0.4.0"
nbd < "2.1.3" | = "3.0.0"
nocrypto >= "0.5.4"
nsq < "0.2.4"
obuilder < "0.4"
obus < "1.1.8"
ocaml-variants >= "4.00.1+mirage-unix" & < "4.00.1+open-types"
ocluster < "0.2"
ocsigen-start = "1.1.0"
odoc >= "2.0.0" & < "2.1.0"
ojs-base < "0.3.0"
opam-publish = "0.3.5"
openflow < "0.2.0"
opium >= "0.11.0" & < "0.19.0"
oskel >= "0.3.0"
ounit-lwt < "2.2.0"
ox < "1.1.0"
pcap-format >= "0.3.3" & < "0.5.0"
plotkicadsch < "0.2.0" | >= "0.4.0"
ppx_defer >= "0.4.0"
pvem_lwt_unix < "0.0.2"
qcow < "0.11.0"
qfs >= "0.5" & < "0.7"
redis-lwt < "0.5"
release < "1.1.1"
resp >= "0.10.0"
resp-mirage >= "0.10.0"
resp-unix >= "0.10.0"
river >= "0.2"
rpc >= "1.5.1" & < "7.1.0"
sanddb >= "0.3.0"
slacko < "0.13.0"
spin < "0.6.0"
syndic >= "1.4" & < "1.6.0"
tar-format >= "0.4.1"
tar-mirage < "2.2.0"
tezos-p2p >= "11.0" & < "13.0"
tlstunnel < "0.2.0"
tube < "4.0"
tuntap >= "1.0.0" & < "2.0.0"
usb < "1.3.1"
utop >= "1.4.0"
vchan >= "0.9.6" & < "2.0.3"
vhd-format < "0.9.1"
vhd-format-lwt < "0.12.0"
vpnkit < "0.1.1"
vue-jsoo < "0.3"
websocket < "0.9.1"
xen-evtchn != "1.0.7"
yurt = "0.4"
zmq-lwt < "5.1.4"
Conflicts
ssl >= "0.5.0"
react < "1.0.0"
ocaml-variants = "4.02.1+BER"