mirage-protocols

MirageOS signatures for network protocols
Description

mirage-protocols provides a set of module types which libraries intended to be used as MirageOS network implementations should implement.

The set of protocols defined is:

Mirage_protocols.ETHIF and Mirage_protocols_lwt.ETHIF Mirage_protocols.ARP and Mirage_protocols_lwt.ARP Mirage_protocols.IP and Mirage_protocols_lwt.IP, via Mirage_protocols_lwt.IPV4 and Mirage_protocols_lwt.IPV6 Mirage_protocols.ICMP and Mirage_protocols_lwt.ICMP, via Mirage_protocols_lwt.ICMPV4 Mirage_protocols.UDP and Mirage_protocols_lwt.UDP, via Mirage_protocols_lwt.UDPV4 and Mirage_protocols_lwt.UDPV6 Mirage_protocols.TCP and Mirage_protocols_lwt.TCP, via Mirage_protocols_lwt.TCPV4 and Mirage_protocols_lwt.TCPV6

mirage-protocols is distributed under the ISC license.

Install
Published
15 Sep 2018
Authors
Maintainers
Sources
mirage-protocols-1.4.0.tbz
md5=3557203aa8557aa5d3ffe7a0c7583925
Dependencies
mirage-flow >= "1.2.0" & < "2.0.0"
mirage-device >= "1.0.0" & < "2.0.0"
jbuilder >= "1.0+beta9"
ocaml >= "4.03.0"
Reverse Dependencies
dns >= "0.19.1" & < "1.0.0"
mirage-protocols-lwt >= "1.4.0" & < "2.0.0"
mirage-stack >= "1.3.0" & < "2.0.0"
mirage-types >= "3.2.0" & < "3.4.0"
tcpip >= "3.5.0" & < "3.7.1"
Conflicts
tcpip >= "7.0.0"