ocaml-top

The OCaml interactive editor for education

Error log

The package failed to build. The error log from opam follows.

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for ocaml-top.1.1.5 & base-bytes.base & cmdliner.1.1.1 & conf-gtk2.1 & conf-gtksourceview.2 & conf-pkg-config.2 & cppo.1.6.9 & dune.1.11.4 & jbuilder.transition & lablgtk.2.18.12 & ocamlfind.1.9.5 & ocp-indent.1.8.1 & ocp-index.1.3.3 & ocp-pp.1.99.19-beta & re.1.9.0 & seq.base:   * Missing dependency:
            - conf-gtksourceview
            depends on the unavailable system package 'libgtksourceview2.0-dev'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.


Command failed: opam --cli=2.1 list --readonly --external '--resolve=ocaml-top.1.1.5,base-bytes.base,cmdliner.1.1.1,conf-gtk2.1,conf-gtksourceview.2,conf-pkg-config.2,cppo.1.6.9,dune.1.11.4,jbuilder.transition,lablgtk.2.18.12,ocamlfind.1.9.5,ocp-indent.1.8.1,ocp-index.1.3.3,ocp-pp.1.99.19-beta,re.1.9.0,seq.base' returned 20