ocaml-version

Manipulate, parse and generate OCaml compiler version strings
README

This library provides facilities to parse version numbers of the OCaml
compiler, and enumerates the various official OCaml releases and configuration
variants.

OCaml version numbers are of the form major.minor.patch+extra, where the
patch and extra fields are optional. This library offers the following
functionality:

  • Functions to parse and serialise OCaml compiler version numbers.

  • Enumeration of official OCaml compiler version releases.

  • Test compiler versions for a particular feature (e.g. the bytes type)

  • opam compiler switch enumeration.

Browse the API documentation for more
details.

Further information

Contributions are very welcome. Please see the overall TODO list below, or
please get in touch with any particular comments you might have.

TODO

  • Complete the architecture set from the officially supported compilers.

  • Add more features to the opam variants list (such as Since.safe_string)

  • Generate the core opam compiler package set purely from this library, so that
    it remains in sync with the library description.

Install
Published
05 Oct 2021
Sources
ocaml-version-v3.4.0.tbz
sha256=d8c1beb5e8d8ebb7710b5f434ce66a3ec8b752b1e4d6ba87c4fe27452bdb8a25
sha512=215e5b0c4ea5fa5461cdc0fc81fbd84a2a319a246a19504d0a0abc8c891e252a9e41644356150a1dc25d56b3f7e084db7a0b15becab4e1339992e645fc3d8ef1
Dependencies
alcotest
with-test
dune
>= "1.0"
ocaml
>= "4.07.0"
Reverse Dependencies
dockerfile-opam
>= "6.0.0" & < "8.0.0"
mdx
>= "1.5.0"
ocamlformat
>= "0.16.0" & != "0.19.0"
ocamlformat-rpc
!= "0.19.0" & < "0.21.0"
odoc
>= "2.0.0" & < "2.1.0"