ocamlbuild

Build system distributed with the OCaml compiler since OCaml 3.10.0
Description
Install
Published
27 Oct 2015
Authors
Maintainers
Dependencies
Reverse Dependencies
0install < "2.14"
ago < "0.4"
aifad < "2.1.0"
alba < "0.4.1"
alcotest < "0.4.6" | >= "0.4.8" & < "0.8.0"
angstrom < "0.6.0"
ansi-parse < "0.4.0"
anycache < "0.7.4"
apron >= "20160108"
argon2 < "1.0.0"
arp < "1.0.0"
ascii85 < "0.4"
asl < "0.11"
asli < "0.2.0"
async < "v0.9.0"
async-zmq < "0.1.0"
async_extended < "v0.9.0"
async_extra < "v0.9.0"
async_find < "v0.9.0"
async_inotify < "v0.9.0"
async_kernel < "v0.9.0"
async_parallel < "v0.9.0"
async_shell < "v0.9.0"
async_smtp < "v0.9.0"
async_ssl < "v0.9.0"
async_unix < "v0.9.0"
aws < "1.0.0"
bap < "1.0.0"
base64 < "2.2.0"
batsh < "0.0.5"
beluga >= "0.8" & < "1.0"
benchmark < "1.5"
bencode < "2.0"
bignum < "v0.9.0"
bigstring < "0.2"
bin_prot < "v0.9.0"
bindlib >= "4.0.4" & < "6.0.0"
biocaml < "0.3.0"
bisect_ppx < "1.3.3"
bitmasks < "1.1.0"
brotli < "2.0.3"
c3 < "0.4.0"
cairo < "1.2.0"
cairo2 < "0.6"
callipyge < "0.2"
camlp4 >= "4.02+1" & != "4.02+system" & != "4.03+system" & != "4.04+system" & != "4.05+system" & != "4.06+system" & != "4.07+system" & != "4.08+system" & != "4.09+system" & != "4.10+system" & != "4.11+system" & != "4.12+system" & != "4.13+system"
camltc < "0.9.8"
cbor < "0.3"
cconv < "0.5"
certify = "0.2"
cfg < "2.1.0"
charrua-core < "0.3" | >= "0.5" & < "0.8"
choice < "0.4"
clangml < "4.0.0"
cmdliner < "1.0.3"
cmdtui < "0.4.3"
coccinelle < "1.0.7"
cohttp < "0.20.0" | = "0.20.2" | >= "0.21.1" & < "0.99.0"
combine < "0.42"
conduit < "1.0.0"
conex < "0.10.0"
containers < "2.0"
coq < "8.5.0~camlp4"
coq-serapi < "8.9.0+0.6.0"
coqide < "8.5.0"
core < "v0.9.0"
core_bench < "v0.9.0"
core_extended < "v0.9.0"
core_kernel < "v0.9.0"
core_profiler < "v0.9.0"
cow < "2.3.0"
cowabloga < "0.3.0"
cppo >= "0.9.4" & < "1.6.0"
cpuid >= "0.1.0" & < "0.1.2"
crc < "2.0.0"
crunch < "2.1.0"
crypt < "1.3"
cryptodbm < "0.84.2"
cryptokit < "1.16.1"
cstruct < "1.8.0" | >= "2.0.0" & < "3.0.0"
csv < "2.0"
csvprovider >= "1.2"
ctypes < "0.2.3"
cudf < "0.10"
DrawGrammar < "0.2.1"
d3 < "0.2.2"
datakit < "0.10.0"
datakit-client < "0.10.0"
datakit-github < "0.10.0"
datakit-server < "0.10.0"
datalog < "0.6"
decompress < "0.8"
dedukti < "2.7"
depyt < "0.2.0"
deriving >= "0.6.2" & < "0.7.1"
devkit < "1.0"
dht < "0.2.0"
digestif < "0.5"
dispatch < "0.4.0"
distributed = "0.4.0"
dlist < "0.0.3"
dns < "0.17.0" | >= "0.19.1" & < "1.0.0"
dns-forward < "0.9.0"
doc-ock < "1.1.0"
doc-ock-html < "1.1.0"
doc-ock-xml < "1.1.0"
docker-api < "0.2"
dockerfile < "1.2.0" | >= "1.3.0" & < "3.0.0"
dolmen < "0.4"
dolog < "4.0.0"
domain-name < "0.1.2"
dose3 < "6.1"
dropbox < "0.2"
dtoa < "0.3.0"
duration < "0.1.2"
earley < "2.0.0"
earley-ocaml >= "1.0.1"
edn < "0.1.2-1-g09b142a"
eigen < "0.1.0"
electrumAnalyzer < "0.3.5-2"
eliom >= "4.0.0" & < "5.0.0"
email_message < "v0.9.0"
exenum < "0.82.0"
extunix < "0.3.1"
ezjsonm < "0.5.0"
ezsqlite < "0.4"
ezxmlm < "1.0.2"
faraday < "0.3.0"
fat-filesystem < "0.12.1"
fd-send-recv < "1.0.5"
fieldslib < "v0.9.0"
fileutils < "0.6.1"
fix < "20181206"
flowtype >= "0.13.1"
frenetic >= "1.0.1" & < "5.0.0"
functoria >= "2.0.0" & < "2.1.0"
General < "0.4.0"
gammu < "0.9.4"
gapi-ocaml < "0.3.6"
gdal < "0.10.0"
gen < "0.5.1"
genspio < "0.0.1"
genspir < "1.0.0"
git < "1.7.2"
github != "1.1.0" & < "3.0.0"
github-hooks >= "0.1.1" & < "0.2.0"
gmap < "0.2.1"
gnuplot != "0.5.1" & < "0.5.3"
goblint < "1.1.1"
goblint-cil < "1.8.0"
gperftools < "0.4"
gpr < "1.3.0"
graphql_ppx < "0.7.1"
gsl < "1.20.0"
hardcaml < "v0.12.0"
hdf5 < "0.1.1"
herdtools7 < "7.54"
hex < "1.1.0"
higher >= "0.3.0"
hiredis < "0.8"
hkdf < "1.0.3"
hvsock < "1.0.0"
ISO8601 < "0.2.6"
i3ipc < "0.1.4"
imagelib < "20200929"
incremental < "v0.9.0"
inferno < "20190924"
inotify < "2.4"
integers < "0.3.0"
inuit < "0.4.1"
io-page < "2.0.0"
io-page-unix < "2.0.0"
io-page-xen < "2.0.0"
ipaddr < "2.8.0"
irc-client >= "0.1.2" & < "0.3.1" | >= "0.4.0" & < "0.6.0"
irmin < "0.11.0" | >= "0.12.0" & < "1.2.0"
irmin-chunk < "1.3.0"
irmin-git < "1.2.0"
irmin-http < "1.2.0"
irmin-mirage < "1.2.0"
irmin-unix >= "1.0.0" & < "1.2.0"
irmin-watcher < "0.3.0"
itv-tree < "2.2"
jekyll-format < "0.2.0"
jemalloc < "0.2"
jenga < "v0.9.0"
jhupllib < "0.2.2"
js_of_ocaml >= "2.0" & < "3.0"
jsoo_storage < "1.0.1"
junit < "1.0"
jupyter < "2.0.0"
KaSim >= "4.0.0"
kafka < "0.3"
ketrew >= "3.2.0"
key-parsers < "0.2.0"
kinetic-client < "0.0.11"
lablqml < "0.6"
lacaml < "10.0.1"
lambda-term < "1.11"
lambdapi < "2.0.0"
lambdasoup < "0.6.2"
launchd < "1.3"
lazy-trie < "1.2.0"
lbfgs < "0.9"
lens < "1.2.1"
libsvm < "0.9.4"
llvm < "3.9"
logs-syslog < "0.2.0"
lpd < "1.2.2"
lru < "0.3.0"
lua-ml < "0.9.3"
lustre-v6 < "6.103.3"
lutils >= "1.44" & < "1.51.2"
lutin < "2.71.10"
lwt < "3.1.0"
lwt-parallel < "1.0.0"
lwt_glib = "1.0.1"
lwt_ssl = "1.0.1"
lz4 != "1.1.0" & < "1.2.0"
macaque < "0.7.4"
magic-mime < "1.0.1"
markup < "0.7.6"
maxminddb < "0.4"
mbr-format < "1.0.0"
mechaml < "1.1.0"
menhir >= "20130911" & < "20200123"
merlin < "2.0.0"
mesh < "0.8.9"
milter < "1.0.4"
mindstorm < "0.8"
minisat < "0.2"
mirage < "2.7.0" | >= "3.0.0" & < "3.1.0"
mirage-block < "1.1.0"
mirage-block-solo5 >= "0.2.1" & < "0.6.0"
mirage-bootvar-solo5 >= "0.2.0" & < "0.6.0"
mirage-bootvar-xen < "0.3.1" | = "0.4.0"
mirage-clock < "1.3.0"
mirage-console-solo5 >= "0.2.0" & < "0.6.0"
mirage-console-unix >= "2.2.0" & < "2.3.2"
mirage-device < "1.1.0"
mirage-flow < "1.3.0"
mirage-fs < "1.1.1"
mirage-fs-lwt < "1.1.1"
mirage-fs-unix != "1.2.1" & < "1.4.0"
mirage-http < "3.2.0"
mirage-kv < "1.1.1"
mirage-kv-lwt < "1.1.0"
mirage-logs < "1.0.0"
mirage-net < "1.1.1"
mirage-net-fd < "0.2.1"
mirage-net-solo5 >= "0.2.0" & < "0.4.3"
mirage-net-xen != "1.5.0" & < "1.7.1"
mirage-random < "1.1.0"
mirage-solo5 < "0.6.2"
mirage-stack < "1.1.0"
mirage-time < "1.1.0"
mirage-types != "1.0.0" & < "3.0.5"
mirage-unix < "3.2.0"
mirage-vnetif < "0.4.0"
mirage-xen < "3.2.0"
mkaudio < "1.1.0"
mlbdd < "0.6"
mlpost < "0.9"
morbig < "0.10.3"
mparser < "1.3"
mpp < "0.3.4"
mpris < "0.2.0"
msat < "0.8"
msgpck < "1.3"
mstruct < "1.3.3"
murmur3 < "0.3"
mustache < "3.0.2"
named-pipe < "0.4.0"
nbd >= "1.0.1" & < "2.0.1"
netlink = "0.2.1"
nlopt-ocaml < "transition"
noCanren < "0.3.0~alpha1"
notty >= "0.2.0" & < "0.2.3"
npy < "0.0.5"
nunchaku < "0.5.1"
obelisk < "0.5.0"
objsize >= "0.17"
obus < "1.2.0"
ocaml-lua < "1.8"
ocaml-markdown < "transition"
ocaml-monadic < "0.4.0"
ocaml-protoc < "2.0.1"
ocaml-xdg-basedir < "transition"
ocaml_plugin < "v0.10.0"
ocamldap >= "2.2" & < "transition"
ocamlfuse = "2.7.1-cvs2"
ocamllint >= "0.3.0"
ocamlnet >= "3.7.5"
ocapic >= "3.3"
ocb-stubblr >= "0.0.2"
ocephes != "0.8"
oclaunch < "0.3.0-pre1"
ocp-indent != "0.6.0" & < "0.6.2"
octavius < "1.1.0"
odate < "0.6"
odds < "1.1"
odepack < "0.6.9"
odoc < "1.1.0"
olinq < "0.3"
omd < "1.3.2"
oml < "0.0.5" | >= "0.0.7"
opal < "0.1.1"
opam-lib < "1.3.0"
opam2web < "1.3.0"
opass < "1.0.0"
opasswd < "1.0.1"
opium < "0.14.0"
ordma < "0.0.5"
orm >= "0.7.1"
osc = "0.1.4"
otr < "0.3.6"
ott >= "0.32"
ounit < "2.1.2"
owl < "0.3.0"
ox >= "1.0.1"
pa_solution != "0.6"
papi < "0.1.1"
parany < "5.0.0"
parmap >= "1.0-rc1" & < "1.1.1"
parse-argv < "0.1.0"
patdiff < "v0.9.0"
patience_diff < "v0.9.0"
pbkdf < "0.3.0"
pcap-format < "0.5.1"
pcre >= "7.0.2" & < "7.3.0"
pgocaml >= "1.7" & < "4.0"
piqi < "0.7.0"
piqilib < "0.6.9"
pkcs11 < "0.18.0"
pla < "1.2"
plist >= "1.0.0"
plplot < "5.11.0-1"
podge < "0.7.0"
pomap < "4.0.0"
posix-getopt < "2.0.0"
posix-types < "2.0.0"
postgresql < "4.1.0"
pprint < "20200226"
ppx_assert < "v0.9.0"
ppx_bench < "v0.9.0"
ppx_bigarray < "3.0.0"
ppx_bin_prot < "v0.9.0"
ppx_bitstring < "2.0.0"
ppx_compare < "v0.9.0"
ppx_const < "2.0"
ppx_conv_func < "v0.9.0"
ppx_core < "v0.9.0"
ppx_csv_conv < "v0.9.0"
ppx_defer < "0.3.0"
ppx_deriving_yojson != "3.0" & < "3.3"
ppx_driver < "v0.10.0"
ppx_enumerate < "v0.9.0"
ppx_expect < "v0.9.0"
ppx_fail < "v0.9.0"
ppx_getenv < "1.2"
ppx_hardcaml < "1.3.0"
ppx_here < "v0.9.0"
ppx_import < "1.5-3-gbd627d5"
ppx_jane < "v0.9.0"
ppx_let < "v0.9.0"
ppx_monoid < "0.3.2"
ppx_optcomp < "v0.9.0"
ppx_pipebang < "v0.9.0"
ppx_relit < "0.2.0"
ppx_sexp_conv < "v0.9.0"
ppx_sexp_value < "v0.9.0"
ppx_type_conv < "v0.9.0"
ppx_xml_conv < "v0.9.0"
printbox < "0.2"
protocol-9p < "0.10.0"
proverif < "2.01"
psq < "0.1.1"
py < "1.1"
qbf < "0.3"
qcheck < "0.8"
qrencode < "0.2"
qtest < "2.9"
radare2 < "0.0.3"
randomconv < "0.1.1"
rawlink < "0.6"
rdbg != "1.65" & < "1.196.12"
re < "1.7.2"
re2 < "v0.9.0"
records < "0.7.0"
redis < "0.3.4"
res < "5.0.0"
rfc6287 < "1.0.4"
rfsm < "1.6-alpha-3"
river < "0.1.3"
rml < "1.09.06"
root1d < "0.5"
rope < "0.6"
rpc >= "1.5.0" & < "1.9.51"
rpc_parallel < "v0.9.0"
safepass < "3.0"
sail < "0.15"
salsa20 < "1.0.0"
salsa20-core < "1.0.0"
scrypt-kdf < "1.0.0"
secp256k1 < "0.2.5"
seq < "0.2"
sequence < "1.0"
session < "0.4.0"
sexplib < "v0.9.0"
sgf < "1.0.1"
shcaml >= "0.2.0"
sill != "1.3"
slacko < "0.13.0"
slap < "2.0.2"
smart-print < "0.3.0"
snappy < "0.1.2"
sodium >= "0.2.0"
spelll < "0.3"
spf < "2.0.2"
sqlexpr < "0.9.0"
sqlgg < "20200521"
sqlite3 < "4.2.0"
srs < "2.0.0"
stdint < "0.5.1"
stringext < "1.5.0"
sturgeon < "0.4.2"
syndic != "1.5" & < "1.6.0"
systemverilog < "0.0.2"
tar-format < "0.4.2" | >= "0.7.1"
tcpip < "2.7.0" | >= "3.0.0" & < "3.2.0"
tensorflow < "0.0.10"
terminal_size < "0.1.4"
textutils < "v0.9.0"
textwrap < "0.2.1"
thrift < "0.10.0"
tip-parser < "0.4"
tls < "0.11.0"
toml < "5.0.0"
touist < "3.5.0"
trakeva < "0.1.0"
travis-opam < "1.2.0"
tsdl-image < "0.1.1"
tuntap < "1.5.0"
typerep < "v0.9.0"
tyre < "0.4"
tyxml >= "3.0.0" & < "4.3.0"
uint < "2.0.1"
unix-errno < "0.6.0"
uri < "1.9.4"
usbmux >= "1.3.2"
utop < "2.0.0"
variantslib < "v0.9.0"
vchan < "2.1.0"
vector3 < "1.0.0"
vhd-format < "0.9.1"
vhd-tool >= "0.7.1" & < "0.12.0"
visitors < "20200207"
vmnet < "1.2.0"
vpnkit < "0.1.1"
wamp < "1.2"
weberizer < "0.7.8"
webmachine < "0.3.0"
websocket < "2.3"
webtest < "2.0.0"
win-error < "0.3"
x509 < "0.6.3"
xen-api-client < "0.9.14"
xen-disk >= "1.2.1"
xen-evtchn < "2.0.0"
xen-gnt < "3.0.0"
xenstore < "1.3.0"
yurt < "0.6"
zed < "1.5"
zero < "109.28.00"
zlib < "0.6"
zmq < "5.0.0"
zstd < "0.3"
zxcvbn < "2.3+2"