ppx_jane

Standard Jane Street ppx rewriters
Description

This package installs a ppx-jane executable, which is a ppx driver including all standard Jane Street ppx rewriters.

Install
Published
22 Mar 2017
Authors
Maintainers
Sources
ppx_jane-v0.9.0.tar.gz
md5=53cfdb362d443d676a3ac50c06abe1ec
Dependencies
ocaml-migrate-parsetree >= "0.4" & < "2.0.0"
ppx_variants_conv >= "v0.9" & < "v0.10"
ppx_typerep_conv >= "v0.9" & < "v0.10"
ppx_sexp_value >= "v0.9" & < "v0.10"
ppx_sexp_message >= "v0.9" & < "v0.10"
ppx_pipebang >= "v0.9" & < "v0.10"
ppx_optional >= "v0.9" & < "v0.10"
ppx_let >= "v0.9" & < "v0.10"
ppx_inline_test >= "v0.9" & < "v0.10"
ppx_here >= "v0.9" & < "v0.10"
ppx_fields_conv >= "v0.9" & < "v0.10"
ppx_fail >= "v0.9" & < "v0.10"
ppx_expect >= "v0.9" & < "v0.10"
ppx_driver >= "v0.9" & < "v0.10"
ppx_custom_printf >= "v0.9" & < "v0.10"
ppx_bin_prot >= "v0.9" & < "v0.10"
ppx_bench >= "v0.9" & < "v0.10"
ppx_base >= "v0.9" & < "v0.10"
ppx_assert >= "v0.9" & < "v0.10"
jbuilder >= "1.0+beta4"
ocaml >= "4.03.0"
Reverse Dependencies
async = "v0.9.0"
async_extended = "v0.9.0"
async_extra = "v0.9.0"
async_find = "v0.9.0"
async_inotify = "v0.9.0"
async_js < "v0.10.0"
async_kernel = "v0.9.0"
async_parallel >= "v0.9.0" & < "v0.10.0"
async_shell >= "v0.9.0" & < "v0.10.0"
async_smtp = "v0.9.0"
async_ssl >= "v0.9.0" & < "v0.10.0"
async_unix >= "v0.9.0" & < "v0.10.0"
bap-build < "2.2.0"
bap-bundle < "2.2.0"
bap-frames = "2.1.1"
bap-ida >= "1.4.0" & < "1.6.0"
bap-raw < "2.2.0"
bap-std >= "1.4.0" & < "1.6.0"
bignum = "v0.9.0"
bitcoinml >= "0.2.4" & < "0.4.1"
command_rpc < "v0.10.0"
core >= "v0.9.0" & < "v0.10.0"
core_bench = "v0.9.0"
core_extended >= "v0.9.0" & < "v0.10.0"
core_kernel >= "v0.9.0" & < "v0.10.0"
core_profiler = "v0.9.0"
csvfields < "v0.10.0"
ecaml < "v0.10.0"
email_message >= "v0.9.0" & < "v0.10.0"
graphlib >= "1.4.0" & < "1.6.0"
horned_worm = "0.3.1"
incr_dom < "v0.10.0"
incr_map < "v0.10.0"
incr_select < "v0.10.0"
incremental = "v0.9.0"
jenga = "v0.9.0"
line-up-words < "v0.11.0"
nsq = "0.5.2"
ocaml_plugin = "v0.9.0"
patdiff = "v0.9.0"
patience_diff = "v0.9.0"
pgx < "1.0"
pgx_async < "1.0"
pgx_lwt < "1.0"
pgx_unix < "1.0"
re2 >= "v0.9.0" & < "v0.10.0"
regular >= "1.4.0" & < "1.6.0"
rpc_parallel = "v0.9.0"
SZXX >= "2.0.0" & < "2.1.1"
shuttle_http >= "0.8.1"
textutils = "v0.9.0"
tldr < "0.3.0"
toplevel_expect_test >= "v0.9.1" & < "v0.10.0"
topological_sort < "v0.10.0"
travesty < "0.6.0"
typerep_extended >= "v0.9.0"
virtual_dom < "v0.10.0"