protocol_version_header

Protocol versioning
Description

This library offers a lightweight way for applications protocols to version themselves. The more protocols that add themselves to [Known_protocol], the nicer error messages we will get when connecting to a service while using the wrong protocol.

Install
Published
31 May 2020
Sources
protocol_version_header-v0.14.0.tar.gz
md5=b318922abe9d7b8c91523ff7ea767069
Dependencies
dune
>= "2.0.0"
ppx_jane
>= "v0.14" & < "v0.15"
core_kernel
>= "v0.14" & < "v0.15"
ocaml
>= "4.08.0"
Reverse Dependencies
async_rpc_kernel
= "v0.14.0"