toplevel_expect_test

Expectation tests for the OCaml toplevel
Description

Allows one to write both toplevel phrases and the expected output from the toplevel in the same file. This provides an easy way to test compilations errors as well as provide a nice alternative to using the toplevel in a terminal.

Install
Published
03 Nov 2017
Authors
Maintainers
Sources
v0.9.2.tar.gz
md5=abf99224e6ab5e82630ae5ea65b8988f
Dependencies
ocaml-migrate-parsetree >= "1.0" & < "2.0.0"
ppx_jane >= "v0.9" & < "v0.10"
ppx_here >= "v0.9" & < "v0.10"
ppx_expect >= "v0.9" & < "v0.10"
ppx_driver >= "v0.9.2" & < "v0.10"
ppx_core >= "v0.9.2" & < "v0.10"
ocaml-compiler-libs >= "v0.9" & < "v0.10"
jbuilder >= "1.0+beta8"
ocamlfind >= "1.7.2"
core_kernel >= "v0.9.1" & < "v0.10"
ocaml >= "4.03.0"
Reverse Dependencies