why3

Why3 environment for deductive program verification

Error log

The package failed to build. The error log from opam follows.

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for frama-c.25.0~beta & alt-ergo-free.2.2.0 & camlp-streams.5.0.1 & camlzip.1.11 & conf-autoconf.0.1 & conf-gmp.4 & conf-gnomecanvas.2 & conf-gtk2.1 & conf-gtksourceview.2 & conf-pkg-config.2 & conf-which.1 & conf-zlib.1 & cppo.1.6.9 & dune.3.6.1 & lablgtk.2.18.13 & menhir.20211128 & menhirLib.20211128 & menhirSdk.20211128 & num.1.4 & ocaml-compiler-libs.v0.12.4 & ocamlfind.1.9.5 & ocamlgraph.1.8.8 & ocplib-simplex.0.4 & ppx_derivers.1.2.1 & ppx_deriving.5.2.1 & ppx_import.1.10.0 & ppxlib.0.28.0 & psmt2-frontend.0.1 & result.1.5 & seq.base & sexplib0.v0.15.1 & stdlib-shims.0.3.0 & why3.1.5.1 & yojson.2.0.2 & zarith.1.12:   * Missing dependency:
            - conf-gtksourceview
            depends on the unavailable system package 'libgtksourceview2.0-dev'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.


Command failed: opam --cli=2.1 list --readonly --external '--resolve=frama-c.25.0~beta,alt-ergo-free.2.2.0,camlp-streams.5.0.1,camlzip.1.11,conf-autoconf.0.1,conf-gmp.4,conf-gnomecanvas.2,conf-gtk2.1,conf-gtksourceview.2,conf-pkg-config.2,conf-which.1,conf-zlib.1,cppo.1.6.9,dune.3.6.1,lablgtk.2.18.13,menhir.20211128,menhirLib.20211128,menhirSdk.20211128,num.1.4,ocaml-compiler-libs.v0.12.4,ocamlfind.1.9.5,ocamlgraph.1.8.8,ocplib-simplex.0.4,ppx_derivers.1.2.1,ppx_deriving.5.2.1,ppx_import.1.10.0,ppxlib.0.28.0,psmt2-frontend.0.1,result.1.5,seq.base,sexplib0.v0.15.1,stdlib-shims.0.3.0,why3.1.5.1,yojson.2.0.2,zarith.1.12' returned 20