package altgr-ergo

  1. Overview
  2. Docs
On This Page
  1. Error log

altgr-ergo 1.01

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (cached)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1
Done.

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy altgr-ergo.1.01 zarith.1.13 ocamlfind.1.9.6 num.1.5 lablgtk.2.18.13 dune.3.13.0 conf-pkg-config.3 conf-gtksourceview.2 conf-gtk2.1 conf-gmp.4 camlp-streams.5.0.1" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for altgr-ergo.1.01 & zarith.1.13 & ocamlfind.1.9.6 & num.1.5 & lablgtk.2.18.13 & dune.3.13.0 & conf-pkg-config.3 & conf-gtksourceview.2 & conf-gtk2.1 & conf-gmp.4 & camlp-streams.5.0.1:   * Missing dependency:
            - conf-gtksourceview
            depends on the unavailable system package 'libgtksourceview2.0-dev'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.


Command failed: opam --cli=2.1 list --readonly --external '--resolve=altgr-ergo.1.01,zarith.1.13,ocamlfind.1.9.6,num.1.5,lablgtk.2.18.13,dune.3.13.0,conf-pkg-config.3,conf-gtksourceview.2,conf-gtk2.1,conf-gmp.4,camlp-streams.5.0.1' returned 20
OCaml

Innovation. Community. Security.