package altgr-ergo

  1. Overview
  2. Docs
On This Page
  1. Error log

altgr-ergo 2.4.0

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (cached)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1
Done.

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy altgr-ergo.2.4.0 zarith.1.13 stdlib-shims.0.3.0 seq.base result.1.5 psmt2-frontend.0.4.0 ocplib-simplex.0.4.1 ocamlfind.1.9.6 num.1.5 menhirSdk.20231231 menhirLib.20231231 menhirCST.20231231 menhir.20231231 lablgtk.2.18.13 dune-configurator.2.9.3 dune.2.9.3 csexp.1.5.1 conf-zlib.1 conf-which.1 conf-pkg-config.3 conf-gtksourceview.2 conf-gtk2.1 conf-gmp.4 conf-autoconf.0.1 cmdliner.1.0.4 camlzip.1.11 camlp-streams.5.0.1 alt-ergo-parsers.2.4.0 alt-ergo-lib.2.4.0" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for altgr-ergo.2.4.0 & zarith.1.13 & stdlib-shims.0.3.0 & seq.base & result.1.5 & psmt2-frontend.0.4.0 & ocplib-simplex.0.4.1 & ocamlfind.1.9.6 & num.1.5 & menhirSdk.20231231 & menhirLib.20231231 & menhirCST.20231231 & menhir.20231231 & lablgtk.2.18.13 & dune-configurator.2.9.3 & dune.2.9.3 & csexp.1.5.1 & conf-zlib.1 & conf-which.1 & conf-pkg-config.3 & conf-gtksourceview.2 & conf-gtk2.1 & conf-gmp.4 & conf-autoconf.0.1 & cmdliner.1.0.4 & camlzip.1.11 & camlp-streams.5.0.1 & alt-ergo-parsers.2.4.0 & alt-ergo-lib.2.4.0:   * Missing dependency:
            - conf-gtksourceview
            depends on the unavailable system package 'libgtksourceview2.0-dev'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.


Command failed: opam --cli=2.1 list --readonly --external '--resolve=altgr-ergo.2.4.0,zarith.1.13,stdlib-shims.0.3.0,seq.base,result.1.5,psmt2-frontend.0.4.0,ocplib-simplex.0.4.1,ocamlfind.1.9.6,num.1.5,menhirSdk.20231231,menhirLib.20231231,menhirCST.20231231,menhir.20231231,lablgtk.2.18.13,dune-configurator.2.9.3,dune.2.9.3,csexp.1.5.1,conf-zlib.1,conf-which.1,conf-pkg-config.3,conf-gtksourceview.2,conf-gtk2.1,conf-gmp.4,conf-autoconf.0.1,cmdliner.1.0.4,camlzip.1.11,camlp-streams.5.0.1,alt-ergo-parsers.2.4.0,alt-ergo-lib.2.4.0' returned 20
OCaml

Innovation. Community. Security.