package current_examples

  1. Overview
  2. Docs

Description

OCurrent provides an OCaml eDSL for writing CI/CD pipelines.

This package provides some example pipelines. It exists mainly to test the integration of various OCurrent plugins.

Published: 07 Feb 2024

README

OCurrent

OCurrent allows you to specify a workflow / pipeline for keeping things up-to-date.

For example, the pipeline shown above fetches the head of a GitHub repository's master branch, builds it, runs the tests, and deploys the binary if the tests pass. When a new commit is pushed, it runs the pipeline again.

Another use might be to keep the GitHub build status of each PR in your Git repository showing the result of fetching, building and testing the PR's head commit. If the head commit changes, the result must be recalculated.

An OCurrent pipeline is written using an OCaml eDSL. When OCurrent evaluates it, it records the inputs used (e.g. the current set of open PRs and the head of each one), monitors them, and automatically recalculates when an input changes.

Larger uses of OCurrent include the OCaml Docker base image builder and ocaml-ci, which is the CI that tests this repository itself.

Documentation

The OCurrent docs contains user documentation and examples. In particular, you might like to start by reading about the example pipelines or how to write your own plugins.

For technical docs, see the API Documentation.

Licensing

OCurrent is licensed under the Apache License, Version 2.0. See LICENSE for the full license text.

Dependencies (29)

  1. yojson >= "1.7.0"
  2. uri >= "4.0.0"
  3. routes >= "2.0.0"
  4. result >= "1.5"
  5. prometheus-app >= "1.2"
  6. prometheus >= "0.7"
  7. ppx_deriving_yojson >= "3.6.1"
  8. ppx_deriving >= "5.1"
  9. lwt >= "5.6.1"
  10. logs >= "0.7.0"
  11. fpath >= "0.7.3"
  12. fmt >= "0.8.9"
  13. dockerfile >= "7.0.0"
  14. duration
  15. cmdliner >= "1.1.0"
  16. capnp-rpc-unix >= "1.2.3"
  17. capnp-rpc-net >= "1.2.3"
  18. capnp-rpc-lwt >= "1.2.3"
  19. capnp-rpc >= "1.2.3"
  20. ocaml >= "4.12.0"
  21. current_ssh = version
  22. current_web = version
  23. current_rpc = version
  24. current_gitlab = version
  25. current_github = version
  26. current_git = version
  27. current_docker = version
  28. current = version
  29. dune >= "3.3"

Dev Dependencies (2)

  1. odoc with-doc
  2. mdx with-test

Used by

None

Conflicts

None