package devkit

  1. Overview
  2. Docs
Development kit - general purpose library

Install

Dune Dependency

Authors

Maintainers

Sources

devkit-1.20210517.tbz
md5=00995ebead339d6ec1ba7859c3fc3a58
sha256=5ad39c7fa1a966a2f0a7f6dbb7e82c787439c73482f5f44b3c9fb54b040d36eb
sha512=8dd3f7d4aaabae9aa9ede13edee2b22214c0d2e2780bb08b2ca8ed588d74fc6d9b1908bb31dfee49c949c7cc425fb98897b8e0f11280070ebd99b965908ea133

Description

Published: 19 May 2021

README

devkit

General purpose OCaml library (development kit) Copyright (c) 2009 Ahrefs Released under the terms of LGPL-2.1 with OCaml linking exception.

opam install devkit

Development

Install OCaml dependencies :

opam install . --deps-only

External dependencies :

opam list -s -e --resolve=devkit

To update ragel-generated code :

aptitude install ragel make -B gen_ragel

To update metaocaml-generated code :

opam exec --switch=4.07.1+BER -- make gen_metaocaml

Dev Dependencies (1)

  1. odoc with-doc

Used by (2)

  1. elasticsearch-cli >= "0.5"
  2. monorobot

Conflicts (1)

  1. jemalloc < "0.2"