package gluten-eio

  1. Overview
  2. Docs
EIO runtime for gluten

Install

Dune Dependency

Authors

Maintainers

Sources

gluten-0.4.1.tbz
sha256=78e6f33ed55666c1127bd71cf012c6a5f8b794cf4072505d0c0fcdb105673db4
sha512=48434a3086309fb59239e75a64b06a8128323cd88802b69aebccc6de3ae41719ee4ae82554c4fc022c87242bbaea182b306faf19ed4b73833d79274ebc78ec59

Description

Published: 17 Mar 2023

README

gluten

gluten implements platform specific runtime code for driving network libraries based on state machines, such as http/af, h2 and websocketaf.

It also additionally provides a self-contained solution for upgrading a connection to a different protocol, which can easily be used to implement HTTP/1.1 upgrades to Websockets, or to start HTTP/2 communication over the h2c (HTTP/2 over plaintext TCP) upgrade mechanism.

License

gluten is distributed under the 3-Clause BSD License, see LICENSE.

This source distribution includes work based on http/af. http/af's license file is included in httpaf.LICENSE.

Dependencies (4)

  1. eio >= "0.7" & < "0.12"
  2. gluten = version
  3. ocaml >= "4.08.0"
  4. dune >= "2.0"

Dev Dependencies

None

Used by (1)

  1. h2-eio < "0.11.0"

Conflicts

None

OCaml

Innovation. Community. Security.