package letsencrypt-app

  1. Overview
  2. Docs
ACME implementation in OCaml

Install

Dune Dependency

Authors

Maintainers

Sources

letsencrypt-0.5.1.tbz
sha256=b90387a5dc8f839926b3e9de831a503317e1a30e9ab99d22a6de64b285d8a35c
sha512=cc2fb7aeba6469d8a3ae20d5bb6857c4035300059149d53ddaee802f125e99dd3078ef699e34a052105533622797194ff80ee9f6b84a7aae5fef0e5866cfada7

Description

An ACME client implementation of the ACME protocol (RFC 8555) for OCaml

Published: 14 Mar 2023

README

let's encrypt - an ACME implementation in OCaml

This package contains an implementation of the ACME protocol (mostly client side) purely in OCaml based on RFC 8555. The HTTP, DNS, and ALPN challenges are implemented.

Build with:

$ opam install letsencrypt
$ opam install letsencrypt-app #for oacmel, the LE client binary

Generate a new account key with:

$ openssl req -newkey rsa > csr.pem
$ openssl genrsa > account.pem

with OCaml version ≥ 4.07.0. Note: acme.ml is not tested, and should be considered yet to be implemented.

Dependencies (15)

  1. cstruct >= "6.0.0"
  2. randomconv
  3. fpath
  4. bos
  5. ptime
  6. mirage-crypto-rng >= "0.11.0"
  7. lwt >= "2.6.0"
  8. fmt >= "0.8.7"
  9. logs
  10. cohttp-lwt-unix >= "1.0.0"
  11. cmdliner >= "1.1.0"
  12. letsencrypt-dns = version
  13. letsencrypt = version
  14. dune >= "1.2.0"
  15. ocaml >= "4.08.0"

Dev Dependencies

None

Used by

None

Conflicts

None