package mirage-types-lwt

  1. Overview
  2. Docs
Lwt module type definitions for MirageOS applications

Install

Dune Dependency

Authors

Maintainers

Sources

mirage-v3.4.1.tbz
md5=1937ea6740613991532af1cc8eb06b36

Description

The purpose of this library is to provide concrete types for several that are left abstract in mirage-types:

  • type 'a io = 'a Lwt.t
  • type page_aligned_buffer = Io_page.t
  • type buffer = Cstruct.t
  • type macaddr = Macaddr.t
  • type ipv4addr = Ipaddr.V4.t

Tags

org:mirage org:xapi-project

Published: 06 Feb 2019

README

MirageOS

MirageOS is a library operating system that constructs unikernels for secure, high-performance network applications across a variety of cloud computing and mobile platforms. Code can be developed on a traditional OS such as Linux or MacOS X, and then compiled into a fully-standalone, specialised unikernel that runs under the Xen or KVM hypervisors as well as lightweight hypervisors like FreeBSD's BHyve, OpenBSD's VMM. Xen and KVM power many public clouds; MirageOS unikernels are currently running on Amazon's Elastic Compute Cloud and Google Compute Engine, and maybe others!

The most up-to-date documentation can be found at the homepage. The site is a Xen hosted unikernel. Simpler skeleton applications are also available online.

This repository

This repository includes:

  • a command-line tool to create and deploy applications with MirageOS; and

  • in types/, a library of type signatures that compliant applications use.

There are several diverse backends in MirageOS that require rather specialised build steps (from Xen to KVM unikernels), and this complexity is wrapped up in the tool.

To work with mirage, you'll need to either install prerequisites locally or use the Docker image.

Local install

You will need the following:

  • a working OCaml compiler (4.04.2 or higher).

  • the OPAM source package manager (2.0.0 or higher).

  • an x86_64 or armel Linux host to compile Xen kernels, or FreeBSD, OpenBSD or MacOS X for the solo5 and userlevel versions.

Docker image

There is a maintained Docker image at unikernel/mirage. You can also use the Dockerfile in this repository:

docker build -t mirage .
docker run -v <your-source>:/src opam config exec -- mirage

Using mirage

There are two stages to using mirage:

  • a configure phase where necessary code is generated and dependencies are determined.

  • an optional depends phase where OPAM package dependencies are satisfied.

  • a build phase where the compiler and any support scripts are run.

You can find documentation, walkthroughs and tutorials over on the MirageOS website. The install instructions are a good place to begin!

Dependencies (19)

  1. mirage-channel-lwt >= "3.1.0"
  2. mirage-kv-lwt >= "1.1.0" & < "2.0.0"
  3. mirage-fs-lwt >= "1.1.1"
  4. mirage-net-lwt >= "1.2.0" & < "2.0.0"
  5. mirage-block-lwt >= "1.1.0"
  6. mirage-console-lwt >= "2.3.5"
  7. mirage-stack-lwt >= "1.3.0"
  8. mirage-protocols-lwt >= "1.4.1" & < "2.0.0"
  9. mirage-flow-lwt >= "1.5.0"
  10. mirage-random >= "1.2.0" & < "2.0.0"
  11. mirage-time-lwt >= "1.1.0"
  12. mirage-clock-lwt >= "2.0.0"
  13. mirage-types >= "3.4.0" & < "3.7.0"
  14. ipaddr >= "3.0.0"
  15. io-page >= "2.0.1"
  16. cstruct >= "3.2.1"
  17. lwt
  18. dune >= "1.1.0"
  19. ocaml >= "4.04.2"

Dev Dependencies

None

Used by (17)

  1. charrua-client-lwt < "0.11.1"
  2. charrua-client-mirage >= "0.10" & < "0.11.1"
  3. conan
  4. conan-cli
  5. docteur-unix < "0.0.3"
  6. git = "1.4.10" | >= "1.5.0" & < "1.10.0"
  7. mirage-conduit < "1.3.0" | >= "2.3.0" & < "3.1.0"
  8. mirage-qubes >= "0.4" & < "0.7.0"
  9. mirage-qubes-ipv4 < "0.7.0"
  10. nbd >= "3.0.0" & < "6.0.0"
  11. protocol-9p = "0.8.0"
  12. qcow >= "0.8.1"
  13. qcow-tool
  14. shared-block-ring >= "2.3.0" & < "3.0.0"
  15. tar-format >= "0.4.1" & < "0.5.0" | >= "0.7.1"
  16. tar-mirage < "1.1.0"
  17. vhd-format-lwt < "0.12.1"

Conflicts

None

OCaml

Innovation. Community. Security.