package ocaml-version

  1. Overview
  2. Docs
Manipulate, parse and generate OCaml compiler version strings

Install

Dune Dependency

Authors

Maintainers

Sources

ocaml-version-3.6.2.tbz
sha256=5c9d31abbd59891dfda6140850b5c50cb1e88f71e7b712c8fafda0474069feb2
sha512=9d8c849bad6a9347508fedcc4f7afbfaff138264ab8e9066f2e6090491170964b9415e71028ea084501dd7009a88f18acb4bc913cab1ccd58921cbf16a19edbe

Description

This library provides facilities to parse version numbers of the OCaml compiler, and enumerates the various official OCaml releases and configuration variants.

OCaml version numbers are of the form major.minor.patch+extra, where the patch and extra fields are optional. This library offers the following functionality:

  • Functions to parse and serialise OCaml compiler version numbers.
  • Enumeration of official OCaml compiler version releases.
  • Test compiler versions for a particular feature (e.g. the bytes type)
  • opam compiler switch enumeration.

Further information

Tags

org:ocamllabs

Published: 18 Sep 2023

README

ocaml-version -- Manipulate, parse and generate OCaml compiler version strings

This library provides facilities to parse version numbers of the OCaml compiler, and enumerates the various official OCaml releases and configuration variants.

OCaml version numbers are of the form major.minor.patch+extra, where the patch and extra fields are optional. This library offers the following functionality:

  • Functions to parse and serialise OCaml compiler version numbers.

  • Enumeration of official OCaml compiler version releases.

  • Test compiler versions for a particular feature (e.g. the bytes type)

  • opam compiler switch enumeration.

Browse the API documentation for more details.

Further information

Contributions are very welcome. Please see the overall TODO list below, or please get in touch with any particular comments you might have.

TODO

  • Complete the architecture set from the officially supported compilers.

  • Add more features to the opam variants list (such as Since.safe_string)

  • Generate the core opam compiler package set purely from this library, so that it remains in sync with the library description.

Dependencies (2)

  1. ocaml >= "4.07.0"
  2. dune >= "3.6"

Dev Dependencies (2)

  1. odoc with-doc
  2. alcotest with-test

Used by (8)

  1. dockerfile-opam >= "6.0.0"
  2. domain-local-await >= "1.0.1"
  3. mdx >= "1.5.0"
  4. ocamlformat >= "0.16.0" & < "0.19.0"
  5. ocamlformat-lib
  6. ocamlformat-rpc != "0.19.0" & < "0.21.0"
  7. odoc >= "2.0.0" & < "2.1.0"
  8. opam-compiler >= "0.2.0"

Conflicts

None