package ounit2

  1. Overview
  2. Docs
OUnit testing framework

Install

Dune Dependency

Authors

Maintainers

Sources

ounit-2.2.7.tbz
sha256=90f6e63bd1240a51d8b9b2f722059bd79ce00b5276bdd6238b8f5c613c0e7388
sha512=53463e5b1b5a40f424e19f5f6a86338a544079600d1fd121ffc1a6fcaa239630194018faf91ccf360ba40b1b2a8b01cf491935e014c68d2947f6e027a2f0a0f9

Description

OUnit is a unit test framework for OCaml. It allows one to easily create unit-tests for OCaml code. It is loosely based on [HUnit], a unit testing framework for Haskell. It is similar to [JUnit], and other XUnit testing frameworks.

Published: 24 Mar 2023

README

OUnit - xUnit testing framework for OCaml

OUnit is a unit test framework for OCaml. It allows one to easily create unit-tests for OCaml code. It is loosely based on HUnit, a unit testing framework for Haskell. It is similar to JUnit, and other XUnit testing frameworks.

Features:

  • colored output

  • JUnit report generation

  • HTML report generation

Installation

The recommended way to install ounit is via the opam package manager:

$ opam install ounit2

Documentation

API documentation is available online.

Examples

Transition to ounit2

In the past OUnit used the ocamlfind package name "oUnit". It is uncommon to use uppercase letters in ocamlfind package name. It caused some problems during the transition to "dune". It was also not the same name as the OPAM package. As of version 2.2, the opam package ounit and the ocamlfind package oUnit are renamed to ounit2 (the same for both the ocamlfind and opam packages).

To do the transition for your own tests:

  • in OPAM, the library should now depends on "ounit2" or "ounit2-lwt"

  • in dune files/OASIS/Makefile/pkg.ml replace "oUnit" by "ounit2" and "ounit-lwt" to "ounit2-lwt".

We will keep OPAM packages "ounit"/"ounit-lwt" for the transition.

Dependencies (5)

  1. stdlib-shims
  2. seq
  3. base-unix
  4. ocaml >= "4.04.0"
  5. dune >= "3.0"

Dev Dependencies (1)

  1. odoc with-doc

  1. 0install >= "2.17"
  2. 0install-gtk >= "2.17"
  3. 0install-solver
  4. abella >= "2.0.8"
  5. arg-complete
  6. beluga >= "1.1"
  7. binsec >= "0.4.0"
  8. bisect_ppx >= "2.0.0" & < "2.6.0"
  9. camlp5 >= "8.00~alpha04" & < "8.00"
  10. camlrack
  11. capnp >= "3.6.0"
  12. charset
  13. cll
  14. clp_operations
  15. colibri2
  16. conjury >= "2.0.1"
  17. containers = "3.8"
  18. coq-core < "8.19.0"
  19. ctypes >= "0.21.1"
  20. ctypes-foreign >= "0.21.1"
  21. cudf >= "0.10"
  22. deadlock
  23. debian-formats >= "0.1.2"
  24. decoders-bencode >= "1.0.0"
  25. decoders-cbor >= "1.0.0"
  26. decoders-ezjsonm >= "1.0.0"
  27. decoders-jsonaf
  28. decoders-jsonm >= "1.0.0"
  29. decoders-msgpck >= "1.0.0"
  30. decoders-sexplib >= "1.0.0"
  31. decoders-yojson >= "1.0.0"
  32. devkit >= "1.20210120"
  33. dkml-c-probe >= "3.0.0"
  34. dtoa >= "0.3.3"
  35. dual
  36. edn >= "0.2.0"
  37. epictetus
  38. errpy
  39. extunix >= "0.3.1"
  40. fileutils >= "0.6.4"
  41. gapi-ocaml >= "0.4.3"
  42. gen >= "1.0"
  43. goblint >= "1.1.1"
  44. google-drive-ocamlfuse >= "0.7.29"
  45. inotify >= "2.4"
  46. iostream
  47. iostream-camlzip
  48. ipaddr >= "5.3.1"
  49. ipaddr-sexp >= "5.3.1"
  50. iter >= "1.6"
  51. jsonschema2atd
  52. jupyter >= "2.7.6"
  53. kind2
  54. lambdasoup >= "0.7.2"
  55. leveldb >= "1.3.0"
  56. lz4 >= "1.2.0"
  57. macaddr >= "5.3.1"
  58. macaddr-sexp >= "5.3.1"
  59. markdown
  60. markup >= "1.0.0"
  61. mirage-block-ccm >= "1.1.0"
  62. mirage-block-unix >= "2.13.0"
  63. mirage-crypto >= "0.10.6"
  64. mirage-crypto-pk >= "0.10.6"
  65. mirage-crypto-rng >= "0.10.6"
  66. mlbdd >= "0.7.2"
  67. mock-ounit >= "1.0.0"
  68. mustache = "3.2.0"
  69. mustache-cli
  70. mutaml
  71. mysql_protocol >= "3.0.1"
  72. ocolor >= "1.3.1"
  73. orsetto >= "1.0.3"
  74. otoml >= "0.9.2"
  75. ounit >= "2.2.7"
  76. ounit2-lwt >= "2.2.7"
  77. oxylc
  78. pa_ppx < "0.07"
  79. packstream
  80. pcre2 >= "7.5.2"
  81. plato
  82. posix-getopt >= "2.0.0"
  83. ppx_camlrack
  84. ppx_const >= "2.0"
  85. ppx_deriving >= "5.2"
  86. ppx_deriving_protobuf >= "3.0.0"
  87. ppx_deriving_yojson >= "3.7.0"
  88. ppx_getenv >= "2.0"
  89. ppx_make
  90. ppx_pyformat
  91. ppx_viewpattern
  92. qcheck-ounit >= "0.14"
  93. qmp >= "0.19.0"
  94. qtest >= "2.11.1"
  95. redis >= "0.7"
  96. redis-lwt >= "0.5"
  97. redis-sync >= "0.5"
  98. rtree
  99. sd_logic
  100. sha >= "1.15.1"
  101. shared-block-ring >= "3.0.0"
  102. sifun
  103. starpath
  104. tar-mirage >= "2.0.0" & < "2.4.0"
  105. tiny_httpd >= "0.8" & < "0.13"
  106. tls >= "0.13.0"
  107. toml >= "7.0.0"
  108. toml_cconv >= "7.0.0"
  109. uri >= "4.4.0"
  110. uri-re >= "4.4.0"
  111. uri-sexp >= "4.4.0"
  112. vec >= "0.2.0"
  113. vhd-format-lwt >= "0.12.3"
  114. vlq >= "0.2.1"
  115. xenstore >= "2.2.0"
  116. zmq >= "5.1.1"
  117. zmq-async >= "5.1.1"
  118. zmq-lwt >= "5.1.1"

Conflicts

None