package pa_ppx

  1. Overview
  2. Docs
PPX Rewriters for Ocaml, written using Camlp5

Install

Dune Dependency

Authors

Maintainers

Sources

0.10.tar.gz
sha512=3df9af96c89799be1caf818d3493c4b8923662f5aae88463f9cc5f15f765aa4c15c4acb9d15b27568f4ace452020ca5db8aa061bcf3f841513fc0de3f63c566f

Description

This is a collection of PPX rewriters, re-implementing those based on ppxlib and other libraries, but instead based on Camlp5. Included is also a collection of support libraries for writing new PPX rewriters. Included are:

pa_assert: ppx_assert pa_ppx.deriving, pa_ppx.deriving_plugins (enum, eq, fold, iter, make, map, ord, sexp, show, yojson): ppx_deriving, plugins, ppx_sexp_conv, ppx_deriving_yojson pa_ppx.expect_test: ppx_expect_test pa_ppx.here: ppx_here pa_ppx.import: ppx_import pa_ppx.inline_test: ppx_inline_test

pa_ppx.undo_deriving: pa_ppx.deriving expands [@@deriving ...] into code; this rewriter undoes that. pa_ppx.unmatched_vala: expands to match-cases (support library for camlp5-based PPX rewriters) pa_ppx.hashrecons: support for writing AST rewriters that automatically fills in hash-consing boilerplate pa_dock: implements doc-comment extraction for camlp5 preprocessors

Many of the reimplementations in fact offer significant enhanced function, described in the pa_ppx documentation. In addition, there is an extensive test-suite, much of it slightly modified versions of the tests for the respective PPX rewriters.

Published: 17 Dec 2022

Dependencies (13)

  1. ounit
  2. uint >= "2.0.1"
  3. bos >= "0.2.0"
  4. sexplib0
  5. yojson >= "1.7.0"
  6. result >= "1.5"
  7. pcre >= "7.4.3"
  8. not-ocamlfind >= "0.09"
  9. camlp5 >= "8.00.04" & < "8.01.00"
  10. conf-perl-string-shellquote
  11. conf-perl-ipc-system-simple
  12. conf-perl
  13. ocaml >= "4.10.0" & < "5.01.0"

Dev Dependencies (6)

  1. ppx_sexp_conv with-test & >= "v0.13.0"
  2. ppx_here with-test & >= "v0.13.0"
  3. ppx_deriving_yojson with-test & >= "3.5.2" & < "3.8.0"
  4. ppx_deriving with-test & < "6.0.2"
  5. ppx_import with-test & >= "1.7.1"
  6. sexplib with-test & >= "v0.14.0"

Used by (7)

  1. pa_ppx_ag < "0.08"
  2. pa_ppx_hashcons != "0.08" & < "0.10"
  3. pa_ppx_migrate < "0.08"
  4. pa_ppx_parsetree
  5. pa_ppx_q_ast != "0.08" & < "0.12"
  6. pa_ppx_string
  7. pa_ppx_unique != "0.08" & < "0.10"
OCaml

Innovation. Community. Security.