HTTP/AF and MirageOS

Description

A compatible layer for HTTP/AF and MirageOS.

Published: 12 Dec 2021

Dependencies (24)

  1. mirage-protocols >= "7.0.0"
  2. cstruct >= "6.0.0"
  3. tls >= "0.15.0"
  4. faraday >= "0.7.2"
  5. h2 >= "0.7.0" & < "0.9.0"
  6. httpaf >= "0.7.1"
  7. bigstringaf >= "0.7.0"
  8. alcotest-lwt with-test
  9. uri with-test
  10. ptime with-test
  11. mirage-time-unix with-test
  12. tcpip with-test & >= "6.0.0"
  13. mirage-crypto-rng with-test & < "0.11.0"
  14. fmt with-test
  15. logs with-test
  16. base-unix with-test
  17. lwt with-test
  18. ke >= "0.4"
  19. mimic
  20. tls-mirage >= "0.15.0"
  21. mirage-time >= "2.0.0"
  22. mirage-stack >= "3.0.0"
  23. dune >= "2.0.0"
  24. ocaml >= "4.08.0"

Reverse Dependencies (3)

  1. git-paf >= "3.5.0" & < "3.10.0"
  2. paf-cohttp = "0.0.7"
  3. paf-le = "0.0.7"

Conflicts

    None

Install

Authors

Maintainers

Sources

paf-0.0.7.tbz
sha256=ad2f045877bc2908083da0ccb0e7baaf2f120eb1f14f3945f6f309b803a65ce8
sha512=8fa8a6b9f0728e6bda58a03921cad1427ecf3ecb0b3863d3c9724f02ff40a344b89c6892b6a692faeb398d067d6aeb7c62bb54a6da42f918d55b9d4eb272bffd