package smtml

  1. Overview
  2. Docs
A Front-end library for SMT solvers in OCaml

Install

Dune Dependency

Authors

Maintainers

Sources

v0.2.2.tar.gz
md5=5b3b2c589abea4ab46ff9e30a322129d
sha512=f4d9dc1fe1f786c2c798a3ff1640ef79419f82c77ca57e5ea7c8753fe209dde948ac2342f56e0fc9c8047f3205331f92e1198b22a65f178cbfe51da7367f9940

Description

A Multi Back-end Front-end for SMT Solvers in OCaml.

Published: 20 Jul 2024

README

Smt.ml

Smt.ml is a Multi Back-end Front-end for SMT Solvers in OCaml. The primary objective of Smt.ml is to facilitate the effortless transition between different SMT solvers during program analysis, as certain SMT solvers may prove more efficient at handling specific logics and formulas. Presently, Smt.ml offers support for Z3, Colibri2, and Bitwuzla, and ongoing efforts are directed towards incorporating support for cvc5 and Alt-Ergo.

Installation

OPAM

  • Install opam.

  • Bootstrap the OCaml compiler:

opam init
opam switch create 5.1.0 5.1.0
  • And, then install encoding:

opam install smtml

Build from source

  • Install the library dependencies:

git clone https://github.com/formalsec/smtml.git
cd smtml
opam install . --deps-only
  • Build and test:

dune build
dune runtest
  • Install smtml on your path by running:

dune install

Code Coverage Reports

BISECT_FILE=`pwd`/bisect dune runtest --force --instrument-with bisect_ppx
bisect-ppx-report summary # Shell summary
bisect-ppx-report html    # Detailed Report in _coverage/index.html

Supported Solvers

Solver Status
Z3 Yes
Colibri2 Yes
Bitwuzla Yes
cvc5 Ongoing
Alt-Ergo Planned
Minisat Planned

About

Project Name

The name Smt.ml is a portmanteau of the terms SMT and OCaml. The .ml extension is a common file extension for OCaml source files. The library itself is named smtml and can be imported into OCaml programs using the following syntax:

open Smtml

Changelog

See CHANGES

Copyright

Smt.ml Copyright (C) 2023-2024 formalsec

This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program.  If not, see <https://www.gnu.org/licenses/>.

Dependencies (8)

  1. yojson >= "1.6.0"
  2. menhir build & >= "20220210"
  3. hc >= "0.3"
  4. zarith >= "1.5"
  5. cmdliner >= "1.2.0"
  6. ocaml_intrinsics
  7. ocaml >= "4.14.0"
  8. dune >= "3.14"

Dev Dependencies (2)

  1. bisect_ppx with-test & >= "2.5.0"
  2. odoc with-doc

Used by (1)

  1. owi >= "0.2"

Conflicts (2)

  1. bitwuzla-cxx < "0.4.0"
  2. z3 < "4.12.2" | >= "4.14"
OCaml

Innovation. Community. Security.