package x509

  1. Overview
  2. Docs
Public Key Infrastructure (RFC 5280, PKCS) purely in OCaml

Install

Dune Dependency

Authors

Maintainers

Sources

x509-v0.14.1.tbz
sha256=d91eb4f2790f9d098713c71cc4b5d12706aedb1795666b5e6d667fe5c262f9c3
sha512=aaf0b7bfe23fa02028d6cde0a83a189ce7dccba7cf64d475c27ea66e8b7801b17f8776abcaca5d15cc33a0e396fdda4695f5c56eef9ed24a66bd066a37cc8954

Description

X.509 is a public key infrastructure used mostly on the Internet. It consists of certificates which include public keys and identifiers, signed by an authority. Authorities must be exchanged over a second channel to establish the trust relationship. This library implements most parts of RFC5280 and RFC6125. The Public Key Cryptography Standards (PKCS) defines encoding and decoding (in ASN.1 DER and PEM format), which is also implemented by this library - namely PKCS 1, PKCS 5, PKCS 7, PKCS 8, PKCS 9, PKCS 10, and PKCS 12.

Tags

org:mirage

Published: 05 Aug 2021

README

X.509 - Public Key Infrastructure purely in OCaml

v0.14.1 X.509 is a public key infrastructure used mostly on the Internet. It consists of certificates which include public keys and identifiers, signed by an authority. Authorities must be exchanged over a second channel to establish the trust relationship. This library implements most parts of RFC5280 and RFC6125. The Public Key Cryptography Standards (PKCS) defines encoding and decoding in ASN.1 DER and PEM format, which is also implemented by this library - namely PKCS 1, PKCS 7, PKCS 8, PKCS 9 and PKCS 10.

Read further and our Usenix Security 2015 paper.

Documentation

API documentation

Installation

opam install x509 will install this library.

Dependencies (16)

  1. pbkdf
  2. logs
  3. domain-name >= "0.3.0"
  4. gmap >= "0.3.0"
  5. fmt >= "0.8.7"
  6. rresult
  7. mirage-crypto-rng
  8. mirage-crypto-ec >= "0.10.0"
  9. mirage-crypto-pk
  10. mirage-crypto
  11. base64 >= "3.1.0"
  12. ptime
  13. asn1-combinators >= "0.2.0" & < "0.3.0"
  14. cstruct >= "6.0.0"
  15. dune >= "1.2"
  16. ocaml >= "4.08.0"

Dev Dependencies (3)

  1. cstruct-unix with-test & >= "3.0.0"
  2. alcotest with-test
  3. mirage-crypto-rng with-test & < "0.11.0"

Used by (26)

  1. albatross >= "1.1.1"
  2. awa >= "0.0.2" & < "0.0.5"
  3. ca-certs >= "0.2.1"
  4. ca-certs-nss >= "3.64.0.1" & < "3.71.0.1"
  5. capnp-rpc-net >= "1.1" & < "1.2.1"
  6. caqti >= "2.1.1"
  7. castore >= "0.0.2"
  8. certify >= "0.3.3"
  9. current_github >= "0.5"
  10. dkim >= "0.3.0"
  11. dns-certify >= "4.4.0" & != "4.6.3" & < "7.0.0"
  12. dns-cli >= "4.4.0"
  13. git-mirage >= "3.7.0" & < "3.10.0"
  14. irc-client-tls >= "0.7.0"
  15. jose < "0.5.0" | >= "0.6.0"
  16. letsencrypt >= "0.2.5"
  17. letters
  18. paf = "0.0.3"
  19. paf-le >= "0.0.6"
  20. sendmail-lwt
  21. tls >= "0.13.0" & < "0.15.0"
  22. tls-async
  23. tls-mirage < "0.12.6" | >= "0.13.0"
  24. tlstunnel < "0.2.0"
  25. u2f
  26. webauthn

Conflicts

None

OCaml

Innovation. Community. Security.