bonsai

A library for building dynamic webapps, using Js_of_ocaml
Description

Bonsai is a library for building reusable UI components inside an Incremental-style UI framework such as Incr_dom or React.

Install
Published
21 Mar 2022
Authors
Maintainers
Sources
bonsai-v0.15.0.tar.gz
sha256=24c4c3149280abd639034ce3acf60e475a772202099e965be8bd8902524573ef
Dependencies
re >= "1.8.0"
ocaml-embed-file >= "v0.15" & < "v0.16"
js_of_ocaml-ppx >= "3.9.0" & < "4.0.0"
js_of_ocaml >= "3.9.0" & < "4.0.0"
gen_js_api >= "1.0.8"
dune >= "2.0.0"
cohttp-async >= "2.5.6" & < "3.0.0" | >= "5.0.0"
virtual_dom >= "v0.15" & < "v0.16"
textutils >= "v0.15" & < "v0.16"
profunctor >= "v0.15" & < "v0.16"
ppx_typed_fields >= "v0.15" & < "v0.16"
ppx_pattern_bind >= "v0.15" & < "v0.16"
ppx_jane >= "v0.15" & < "v0.16"
ppx_css >= "v0.15" & < "v0.16"
patdiff >= "v0.15" & < "v0.16"
incr_map >= "v0.15" & < "v0.16"
incr_dom >= "v0.15" & < "v0.16"
fuzzy_match >= "v0.15" & < "v0.16"
expect_test_helpers_core >= "v0.15" & < "v0.16"
core_unix >= "v0.15" & < "v0.16"
core_kernel >= "v0.15" & < "v0.16"
core_bench >= "v0.15" & < "v0.16"
core >= "v0.15" & < "v0.16"
async_rpc_websocket >= "v0.15" & < "v0.16"
async_rpc_kernel >= "v0.15" & < "v0.16"
async_kernel >= "v0.15" & < "v0.16"
async_js >= "v0.15" & < "v0.16"
async_extra >= "v0.15" & < "v0.16"
async >= "v0.15" & < "v0.16"
ocaml >= "4.08.0"
Reverse Dependencies
memtrace_viewer >= "v0.15.0"