dockerfile-opam

Dockerfile eDSL -- opam support
Description

This library provides a typed OCaml interface to generating Dockerfiles programmatically without having to resort to lots of shell scripting and awk/sed-style assembly.

The opam subpackage provides opam and Linux-specific distribution support for generating dockerfiles.

Install
Published
27 Jul 2022
Authors
Maintainers
Sources
dockerfile-8.0.0.tbz
sha256=e97e49621489fde147dd5ebc9e8c7f742f2b9d9df766391063a2f65e5ade5d01 sha512=645abd32db85b7e1867b258cce0aa1702d0b78a08949040e3be2b9af50593591ddfd1fb09a7569746901d0b5534eac1d58130f9be5cbab001048f73605b8d0fc
Dependencies
fmt >= "0.8.7"
ppx_sexp_conv >= "v0.9.0"
ocaml-version >= "3.5.0"
dockerfile = version
dune >= "2.0.0"
ocaml >= "4.02.3"
Reverse Dependencies
dockerfile-cmd < "6.6.0" | = "8.0.0"