monomorphic

A small library used to shadow polymorphic operators (and functions) contained in the stdlib
README

ocaml-monomorphic is a small library used to shadow polymorphic operators (and functions) contained in Stdlib.
It can be useful to avoid some mistakes and runtime errors due to OCaml's polymorphic comparison functions.

Requirements

This library only requires:

  • OCaml >= 4.08

  • Dune >= 2.7

Usage

Using dune, a simple usage would be:

(library
  (public_name your-lib)
  (libraries monomorphic)
  (flags :standard -open Monomorphic.Int))

Install
Published
29 Sep 2020
Sources
monomorphic-2.0.tbz
sha256=23fc4e79f003082de925e8a520d96573a709495645dc7a184e3527eae217a02c
sha512=9bf91b6102e8b33c7dff2a242248271ba4b1124b00fc75490864d01df0ac1e86e78824d6628394c1c99ec92684de66aae33bae315525c4ec1a123d662b7a70cb
Dependencies
odoc
with-doc
ocaml
>= "4.08" & < "5.0"
dune
>= "2.7"
Reverse Dependencies
hamt
< "1.0.0"