package ocaml-r

  1. Overview
  2. Docs
On This Page
  1. Error log

ocaml-r 0.4.0

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (cached)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1
Done.

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy ocaml-r.0.4.0 stdio.v0.16.0 sexplib0.v0.16.0 dune-configurator.3.15.2 dune.3.15.2 csexp.1.5.2 conf-r-mathlib.1 conf-r.1.0.0 conf-pkg-config.3 conf-bash.1 base.v0.16.3" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
# The following system packages are needed:
pkg-config
r-base-core
r-mathlib
[NOTE] Package dune is already installed (current version is 3.15.2).
The following actions will be performed:
  - install conf-r            1.0.0
  - install csexp             1.5.2
  - install conf-pkg-config   3
  - install conf-bash         1
  - install sexplib0          v0.16.0
  - install dune-configurator 3.15.2
  - install conf-r-mathlib    1
  - install base              v0.16.3
  - install stdio             v0.16.0
  - install ocaml-r           0.4.0
===== 10 to install =====

The following system packages will first need to be installed:
    pkg-config r-base-core r-mathlib

<><> Handling external dependencies <><><><><><><><><><><><><><><><><><><><><><>
Let opam run your package manager to install the required system packages?
(answer 'n' for other options) [Y/n] y
+ /usr/bin/sudo "apt-get" "install" "-qq" "-yy" "pkg-config" "r-base-core" "r-mathlib"
- debconf: delaying package configuration, since apt-utils is not installed
- Selecting previously unselected package libdbus-1-3:amd64.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 18766 files and directories currently installed.)
- Preparing to unpack .../000-libdbus-1-3_1.14.10-1~deb12u1_amd64.deb ...
- Unpacking libdbus-1-3:amd64 (1.14.10-1~deb12u1) ...
- Selecting previously unselected package dbus-bin.
- Preparing to unpack .../001-dbus-bin_1.14.10-1~deb12u1_amd64.deb ...
- Unpacking dbus-bin (1.14.10-1~deb12u1) ...
- Selecting previously unselected package dbus-session-bus-common.
- Preparing to unpack .../002-dbus-session-bus-common_1.14.10-1~deb12u1_all.deb ...
- Unpacking dbus-session-bus-common (1.14.10-1~deb12u1) ...
- Selecting previously unselected package libapparmor1:amd64.
- Preparing to unpack .../003-libapparmor1_3.0.8-3_amd64.deb ...
- Unpacking libapparmor1:amd64 (3.0.8-3) ...
- Selecting previously unselected package dbus-daemon.
- Preparing to unpack .../004-dbus-daemon_1.14.10-1~deb12u1_amd64.deb ...
- Unpacking dbus-daemon (1.14.10-1~deb12u1) ...
- Selecting previously unselected package dbus-system-bus-common.
- Preparing to unpack .../005-dbus-system-bus-common_1.14.10-1~deb12u1_all.deb ...
- Unpacking dbus-system-bus-common (1.14.10-1~deb12u1) ...
- Selecting previously unselected package dbus.
- Preparing to unpack .../006-dbus_1.14.10-1~deb12u1_amd64.deb ...
- Unpacking dbus (1.14.10-1~deb12u1) ...
- Selecting previously unselected package sensible-utils.
- Preparing to unpack .../007-sensible-utils_0.0.17+nmu1_all.deb ...
- Unpacking sensible-utils (0.0.17+nmu1) ...
- Selecting previously unselected package ucf.
- Preparing to unpack .../008-ucf_3.0043+nmu1_all.deb ...
- Moving old data out of the way
- Unpacking ucf (3.0043+nmu1) ...
- Selecting previously unselected package bzip2-doc.
- Preparing to unpack .../009-bzip2-doc_1.0.8-5_all.deb ...
- Unpacking bzip2-doc (1.0.8-5) ...
- Selecting previously unselected package fontconfig.
- Preparing to unpack .../010-fontconfig_2.14.1-4_amd64.deb ...
- Unpacking fontconfig (2.14.1-4) ...
- Selecting previously unselected package libgfortran5:amd64.
- Preparing to unpack .../011-libgfortran5_12.2.0-14_amd64.deb ...
- Unpacking libgfortran5:amd64 (12.2.0-14) ...
- Selecting previously unselected package libgfortran-12-dev:amd64.
- Preparing to unpack .../012-libgfortran-12-dev_12.2.0-14_amd64.deb ...
- Unpacking libgfortran-12-dev:amd64 (12.2.0-14) ...
- Selecting previously unselected package gfortran-12.
- Preparing to unpack .../013-gfortran-12_12.2.0-14_amd64.deb ...
- Unpacking gfortran-12 (12.2.0-14) ...
- Selecting previously unselected package gfortran.
- Preparing to unpack .../014-gfortran_4%3a12.2.0-3_amd64.deb ...
- Unpacking gfortran (4:12.2.0-3) ...
- Selecting previously unselected package libicu72:amd64.
- Preparing to unpack .../015-libicu72_72.1-3_amd64.deb ...
- Unpacking libicu72:amd64 (72.1-3) ...
- Selecting previously unselected package icu-devtools.
- Preparing to unpack .../016-icu-devtools_72.1-3_amd64.deb ...
- Unpacking icu-devtools (72.1-3) ...
- Selecting previously unselected package libauthen-sasl-perl.
- Preparing to unpack .../017-libauthen-sasl-perl_2.1600-3_all.deb ...
- Unpacking libauthen-sasl-perl (2.1600-3) ...
- Selecting previously unselected package libblas3:amd64.
- Preparing to unpack .../018-libblas3_3.11.0-2_amd64.deb ...
- Unpacking libblas3:amd64 (3.11.0-2) ...
- Selecting previously unselected package libblas-dev:amd64.
- Preparing to unpack .../019-libblas-dev_3.11.0-2_amd64.deb ...
- Unpacking libblas-dev:amd64 (3.11.0-2) ...
- Selecting previously unselected package libbz2-dev:amd64.
- Preparing to unpack .../020-libbz2-dev_1.0.8-5+b1_amd64.deb ...
- Unpacking libbz2-dev:amd64 (1.0.8-5+b1) ...
- Selecting previously unselected package libpixman-1-0:amd64.
- Preparing to unpack .../021-libpixman-1-0_0.42.2-1_amd64.deb ...
- Unpacking libpixman-1-0:amd64 (0.42.2-1) ...
- Selecting previously unselected package libxcb-render0:amd64.
- Preparing to unpack .../022-libxcb-render0_1.15-1_amd64.deb ...
- Unpacking libxcb-render0:amd64 (1.15-1) ...
- Selecting previously unselected package libxcb-shm0:amd64.
- Preparing to unpack .../023-libxcb-shm0_1.15-1_amd64.deb ...
- Unpacking libxcb-shm0:amd64 (1.15-1) ...
- Selecting previously unselected package libxrender1:amd64.
- Preparing to unpack .../024-libxrender1_1%3a0.9.10-1.1_amd64.deb ...
- Unpacking libxrender1:amd64 (1:0.9.10-1.1) ...
- Selecting previously unselected package libcairo2:amd64.
- Preparing to unpack .../025-libcairo2_1.16.0-7_amd64.deb ...
- Unpacking libcairo2:amd64 (1.16.0-7) ...
- Selecting previously unselected package libclone-perl:amd64.
- Preparing to unpack .../026-libclone-perl_0.46-1_amd64.deb ...
- Unpacking libclone-perl:amd64 (0.46-1) ...
- Selecting previously unselected package libdata-dump-perl.
- Preparing to unpack .../027-libdata-dump-perl_1.25-1_all.deb ...
- Unpacking libdata-dump-perl (1.25-1) ...
- Selecting previously unselected package libdatrie1:amd64.
- Preparing to unpack .../028-libdatrie1_0.2.13-2+b1_amd64.deb ...
- Unpacking libdatrie1:amd64 (0.2.13-2+b1) ...
- Selecting previously unselected package libdrm-common.
- Preparing to unpack .../029-libdrm-common_2.4.114-1_all.deb ...
- Unpacking libdrm-common (2.4.114-1) ...
- Selecting previously unselected package libdrm2:amd64.
- Preparing to unpack .../030-libdrm2_2.4.114-1+b1_amd64.deb ...
- Unpacking libdrm2:amd64 (2.4.114-1+b1) ...
- Selecting previously unselected package libdrm-amdgpu1:amd64.
- Preparing to unpack .../031-libdrm-amdgpu1_2.4.114-1+b1_amd64.deb ...
- Unpacking libdrm-amdgpu1:amd64 (2.4.114-1+b1) ...
- Selecting previously unselected package libpciaccess0:amd64.
- Preparing to unpack .../032-libpciaccess0_0.17-2_amd64.deb ...
- Unpacking libpciaccess0:amd64 (0.17-2) ...
- Selecting previously unselected package libdrm-intel1:amd64.
- Preparing to unpack .../033-libdrm-intel1_2.4.114-1+b1_amd64.deb ...
- Unpacking libdrm-intel1:amd64 (2.4.114-1+b1) ...
- Selecting previously unselected package libdrm-nouveau2:amd64.
- Preparing to unpack .../034-libdrm-nouveau2_2.4.114-1+b1_amd64.deb ...
- Unpacking libdrm-nouveau2:amd64 (2.4.114-1+b1) ...
- Selecting previously unselected package libdrm-radeon1:amd64.
- Preparing to unpack .../035-libdrm-radeon1_2.4.114-1+b1_amd64.deb ...
- Unpacking libdrm-radeon1:amd64 (2.4.114-1+b1) ...
- Selecting previously unselected package libwayland-server0:amd64.
- Preparing to unpack .../036-libwayland-server0_1.21.0-1_amd64.deb ...
- Unpacking libwayland-server0:amd64 (1.21.0-1) ...
- Selecting previously unselected package libgbm1:amd64.
- Preparing to unpack .../037-libgbm1_22.3.6-1+deb12u1_amd64.deb ...
- Unpacking libgbm1:amd64 (22.3.6-1+deb12u1) ...
- Selecting previously unselected package libglapi-mesa:amd64.
- Preparing to unpack .../038-libglapi-mesa_22.3.6-1+deb12u1_amd64.deb ...
- Unpacking libglapi-mesa:amd64 (22.3.6-1+deb12u1) ...
- Selecting previously unselected package libwayland-client0:amd64.
- Preparing to unpack .../039-libwayland-client0_1.21.0-1_amd64.deb ...
- Unpacking libwayland-client0:amd64 (1.21.0-1) ...
- Selecting previously unselected package libx11-xcb1:amd64.
- Preparing to unpack .../040-libx11-xcb1_2%3a1.8.4-2+deb12u2_amd64.deb ...
- Unpacking libx11-xcb1:amd64 (2:1.8.4-2+deb12u2) ...
- Selecting previously unselected package libxcb-dri2-0:amd64.
- Preparing to unpack .../041-libxcb-dri2-0_1.15-1_amd64.deb ...
- Unpacking libxcb-dri2-0:amd64 (1.15-1) ...
- Selecting previously unselected package libxcb-dri3-0:amd64.
- Preparing to unpack .../042-libxcb-dri3-0_1.15-1_amd64.deb ...
- Unpacking libxcb-dri3-0:amd64 (1.15-1) ...
- Selecting previously unselected package libxcb-present0:amd64.
- Preparing to unpack .../043-libxcb-present0_1.15-1_amd64.deb ...
- Unpacking libxcb-present0:amd64 (1.15-1) ...
- Selecting previously unselected package libxcb-randr0:amd64.
- Preparing to unpack .../044-libxcb-randr0_1.15-1_amd64.deb ...
- Unpacking libxcb-randr0:amd64 (1.15-1) ...
- Selecting previously unselected package libxcb-sync1:amd64.
- Preparing to unpack .../045-libxcb-sync1_1.15-1_amd64.deb ...
- Unpacking libxcb-sync1:amd64 (1.15-1) ...
- Selecting previously unselected package libxcb-xfixes0:amd64.
- Preparing to unpack .../046-libxcb-xfixes0_1.15-1_amd64.deb ...
- Unpacking libxcb-xfixes0:amd64 (1.15-1) ...
- Selecting previously unselected package libxshmfence1:amd64.
- Preparing to unpack .../047-libxshmfence1_1.3-1_amd64.deb ...
- Unpacking libxshmfence1:amd64 (1.3-1) ...
- Selecting previously unselected package libegl-mesa0:amd64.
- Preparing to unpack .../048-libegl-mesa0_22.3.6-1+deb12u1_amd64.deb ...
- Unpacking libegl-mesa0:amd64 (22.3.6-1+deb12u1) ...
- Selecting previously unselected package libelf1:amd64.
- Preparing to unpack .../049-libelf1_0.188-2.1_amd64.deb ...
- Unpacking libelf1:amd64 (0.188-2.1) ...
- Selecting previously unselected package libencode-locale-perl.
- Preparing to unpack .../050-libencode-locale-perl_1.05-3_all.deb ...
- Unpacking libencode-locale-perl (1.05-3) ...
- Selecting previously unselected package libipc-system-simple-perl.
- Preparing to unpack .../051-libipc-system-simple-perl_1.30-2_all.deb ...
- Unpacking libipc-system-simple-perl (1.30-2) ...
- Selecting previously unselected package libfile-basedir-perl.
- Preparing to unpack .../052-libfile-basedir-perl_0.09-2_all.deb ...
- Unpacking libfile-basedir-perl (0.09-2) ...
- Selecting previously unselected package libregexp-ipv6-perl.
- Preparing to unpack .../053-libregexp-ipv6-perl_0.03-3_all.deb ...
- Unpacking libregexp-ipv6-perl (0.03-3) ...
- Selecting previously unselected package liburi-perl.
- Preparing to unpack .../054-liburi-perl_5.17-1_all.deb ...
- Unpacking liburi-perl (5.17-1) ...
- Selecting previously unselected package libfile-desktopentry-perl.
- Preparing to unpack .../055-libfile-desktopentry-perl_0.22-3_all.deb ...
- Unpacking libfile-desktopentry-perl (0.22-3) ...
- Selecting previously unselected package libtimedate-perl.
- Preparing to unpack .../056-libtimedate-perl_2.3300-2_all.deb ...
- Unpacking libtimedate-perl (2.3300-2) ...
- Selecting previously unselected package libhttp-date-perl.
- Preparing to unpack .../057-libhttp-date-perl_6.05-2_all.deb ...
- Unpacking libhttp-date-perl (6.05-2) ...
- Selecting previously unselected package libfile-listing-perl.
- Preparing to unpack .../058-libfile-listing-perl_6.15-1_all.deb ...
- Unpacking libfile-listing-perl (6.15-1) ...
- Selecting previously unselected package libglib2.0-0:amd64.
- Preparing to unpack .../059-libglib2.0-0_2.74.6-2+deb12u2_amd64.deb ...
- Unpacking libglib2.0-0:amd64 (2.74.6-2+deb12u2) ...
- Selecting previously unselected package libxml2:amd64.
- Preparing to unpack .../060-libxml2_2.9.14+dfsg-1.3~deb12u1_amd64.deb ...
- Unpacking libxml2:amd64 (2.9.14+dfsg-1.3~deb12u1) ...
- Selecting previously unselected package shared-mime-info.
- Preparing to unpack .../061-shared-mime-info_2.2-1_amd64.deb ...
- Unpacking shared-mime-info (2.2-1) ...
- Selecting previously unselected package libfile-mimeinfo-perl.
- Preparing to unpack .../062-libfile-mimeinfo-perl_0.33-1_all.deb ...
- Unpacking libfile-mimeinfo-perl (0.33-1) ...
- Selecting previously unselected package libfont-afm-perl.
- Preparing to unpack .../063-libfont-afm-perl_1.20-4_all.deb ...
- Unpacking libfont-afm-perl (1.20-4) ...
- Selecting previously unselected package libfontenc1:amd64.
- Preparing to unpack .../064-libfontenc1_1%3a1.1.4-1_amd64.deb ...
- Unpacking libfontenc1:amd64 (1:1.1.4-1) ...
- Selecting previously unselected package libfribidi0:amd64.
- Preparing to unpack .../065-libfribidi0_1.0.8-2.1_amd64.deb ...
- Unpacking libfribidi0:amd64 (1.0.8-2.1) ...
- Selecting previously unselected package libglvnd0:amd64.
- Preparing to unpack .../066-libglvnd0_1.6.0-1_amd64.deb ...
- Unpacking libglvnd0:amd64 (1.6.0-1) ...
- Selecting previously unselected package libxcb-glx0:amd64.
- Preparing to unpack .../067-libxcb-glx0_1.15-1_amd64.deb ...
- Unpacking libxcb-glx0:amd64 (1.15-1) ...
- Selecting previously unselected package libxfixes3:amd64.
- Preparing to unpack .../068-libxfixes3_1%3a6.0.0-2_amd64.deb ...
- Unpacking libxfixes3:amd64 (1:6.0.0-2) ...
- Selecting previously unselected package libxxf86vm1:amd64.
- Preparing to unpack .../069-libxxf86vm1_1%3a1.1.4-1+b2_amd64.deb ...
- Unpacking libxxf86vm1:amd64 (1:1.1.4-1+b2) ...
- Selecting previously unselected package libz3-4:amd64.
- Preparing to unpack .../070-libz3-4_4.8.12-3.1_amd64.deb ...
- Unpacking libz3-4:amd64 (4.8.12-3.1) ...
- Selecting previously unselected package libllvm15:amd64.
- Preparing to unpack .../071-libllvm15_1%3a15.0.6-4+b1_amd64.deb ...
- Unpacking libllvm15:amd64 (1:15.0.6-4+b1) ...
- Selecting previously unselected package libsensors-config.
- Preparing to unpack .../072-libsensors-config_1%3a3.6.0-7.1_all.deb ...
- Unpacking libsensors-config (1:3.6.0-7.1) ...
- Selecting previously unselected package libsensors5:amd64.
- Preparing to unpack .../073-libsensors5_1%3a3.6.0-7.1_amd64.deb ...
- Unpacking libsensors5:amd64 (1:3.6.0-7.1) ...
- Selecting previously unselected package libgl1-mesa-dri:amd64.
- Preparing to unpack .../074-libgl1-mesa-dri_22.3.6-1+deb12u1_amd64.deb ...
- Unpacking libgl1-mesa-dri:amd64 (22.3.6-1+deb12u1) ...
- Selecting previously unselected package libglx-mesa0:amd64.
- Preparing to unpack .../075-libglx-mesa0_22.3.6-1+deb12u1_amd64.deb ...
- Unpacking libglx-mesa0:amd64 (22.3.6-1+deb12u1) ...
- Selecting previously unselected package libglx0:amd64.
- Preparing to unpack .../076-libglx0_1.6.0-1_amd64.deb ...
- Unpacking libglx0:amd64 (1.6.0-1) ...
- Selecting previously unselected package libgl1:amd64.
- Preparing to unpack .../077-libgl1_1.6.0-1_amd64.deb ...
- Unpacking libgl1:amd64 (1.6.0-1) ...
- Selecting previously unselected package libgles2:amd64.
- Preparing to unpack .../078-libgles2_1.6.0-1_amd64.deb ...
- Unpacking libgles2:amd64 (1.6.0-1) ...
- Selecting previously unselected package libglib2.0-data.
- Preparing to unpack .../079-libglib2.0-data_2.74.6-2+deb12u2_all.deb ...
- Unpacking libglib2.0-data (2.74.6-2+deb12u2) ...
- Selecting previously unselected package libgraphite2-3:amd64.
- Preparing to unpack .../080-libgraphite2-3_1.3.14-1_amd64.deb ...
- Unpacking libgraphite2-3:amd64 (1.3.14-1) ...
- Selecting previously unselected package libharfbuzz0b:amd64.
- Preparing to unpack .../081-libharfbuzz0b_6.0.0+dfsg-3_amd64.deb ...
- Unpacking libharfbuzz0b:amd64 (6.0.0+dfsg-3) ...
- Selecting previously unselected package libhtml-tagset-perl.
- Preparing to unpack .../082-libhtml-tagset-perl_3.20-6_all.deb ...
- Unpacking libhtml-tagset-perl (3.20-6) ...
- Selecting previously unselected package libhtml-parser-perl:amd64.
- Preparing to unpack .../083-libhtml-parser-perl_3.81-1_amd64.deb ...
- Unpacking libhtml-parser-perl:amd64 (3.81-1) ...
- Selecting previously unselected package libio-html-perl.
- Preparing to unpack .../084-libio-html-perl_1.004-3_all.deb ...
- Unpacking libio-html-perl (1.004-3) ...
- Selecting previously unselected package liblwp-mediatypes-perl.
- Preparing to unpack .../085-liblwp-mediatypes-perl_6.04-2_all.deb ...
- Unpacking liblwp-mediatypes-perl (6.04-2) ...
- Selecting previously unselected package libhttp-message-perl.
- Preparing to unpack .../086-libhttp-message-perl_6.44-1_all.deb ...
- Unpacking libhttp-message-perl (6.44-1) ...
- Selecting previously unselected package libhtml-form-perl.
- Preparing to unpack .../087-libhtml-form-perl_6.11-1_all.deb ...
- Unpacking libhtml-form-perl (6.11-1) ...
- Selecting previously unselected package libhtml-tree-perl.
- Preparing to unpack .../088-libhtml-tree-perl_5.07-3_all.deb ...
- Unpacking libhtml-tree-perl (5.07-3) ...
- Selecting previously unselected package libhtml-format-perl.
- Preparing to unpack .../089-libhtml-format-perl_2.16-2_all.deb ...
- Unpacking libhtml-format-perl (2.16-2) ...
- Selecting previously unselected package libhttp-cookies-perl.
- Preparing to unpack .../090-libhttp-cookies-perl_6.10-1_all.deb ...
- Unpacking libhttp-cookies-perl (6.10-1) ...
- Selecting previously unselected package libhttp-daemon-perl.
- Preparing to unpack .../091-libhttp-daemon-perl_6.16-1_all.deb ...
- Unpacking libhttp-daemon-perl (6.16-1) ...
- Selecting previously unselected package libhttp-negotiate-perl.
- Preparing to unpack .../092-libhttp-negotiate-perl_6.01-2_all.deb ...
- Unpacking libhttp-negotiate-perl (6.01-2) ...
- Selecting previously unselected package x11-common.
- Preparing to unpack .../093-x11-common_1%3a7.7+23_all.deb ...
- Unpacking x11-common (1:7.7+23) ...
- Selecting previously unselected package libice6:amd64.
- Preparing to unpack .../094-libice6_2%3a1.0.10-1_amd64.deb ...
- Unpacking libice6:amd64 (2:1.0.10-1) ...
- Selecting previously unselected package libicu-dev:amd64.
- Preparing to unpack .../095-libicu-dev_72.1-3_amd64.deb ...
- Unpacking libicu-dev:amd64 (72.1-3) ...
- Selecting previously unselected package perl-openssl-defaults:amd64.
- Preparing to unpack .../096-perl-openssl-defaults_7+b1_amd64.deb ...
- Unpacking perl-openssl-defaults:amd64 (7+b1) ...
- Selecting previously unselected package libnet-ssleay-perl:amd64.
- Preparing to unpack .../097-libnet-ssleay-perl_1.92-2+b1_amd64.deb ...
- Unpacking libnet-ssleay-perl:amd64 (1.92-2+b1) ...
- Selecting previously unselected package libio-socket-ssl-perl.
- Preparing to unpack .../098-libio-socket-ssl-perl_2.081-2_all.deb ...
- Unpacking libio-socket-ssl-perl (2.081-2) ...
- Selecting previously unselected package libio-stringy-perl.
- Preparing to unpack .../099-libio-stringy-perl_2.111-3_all.deb ...
- Unpacking libio-stringy-perl (2.111-3) ...
- Selecting previously unselected package libjpeg62-turbo-dev:amd64.
- Preparing to unpack .../100-libjpeg62-turbo-dev_1%3a2.1.5-2_amd64.deb ...
- Unpacking libjpeg62-turbo-dev:amd64 (1:2.1.5-2) ...
- Selecting previously unselected package libjpeg-dev:amd64.
- Preparing to unpack .../101-libjpeg-dev_1%3a2.1.5-2_amd64.deb ...
- Unpacking libjpeg-dev:amd64 (1:2.1.5-2) ...
- Selecting previously unselected package liblapack3:amd64.
- Preparing to unpack .../102-liblapack3_3.11.0-2_amd64.deb ...
- Unpacking liblapack3:amd64 (3.11.0-2) ...
- Selecting previously unselected package liblapack-dev:amd64.
- Preparing to unpack .../103-liblapack-dev_3.11.0-2_amd64.deb ...
- Unpacking liblapack-dev:amd64 (3.11.0-2) ...
- Selecting previously unselected package libnet-http-perl.
- Preparing to unpack .../104-libnet-http-perl_6.22-1_all.deb ...
- Unpacking libnet-http-perl (6.22-1) ...
- Selecting previously unselected package libtry-tiny-perl.
- Preparing to unpack .../105-libtry-tiny-perl_0.31-2_all.deb ...
- Unpacking libtry-tiny-perl (0.31-2) ...
- Selecting previously unselected package libwww-robotrules-perl.
- Preparing to unpack .../106-libwww-robotrules-perl_6.02-1_all.deb ...
- Unpacking libwww-robotrules-perl (6.02-1) ...
- Selecting previously unselected package libwww-perl.
- Preparing to unpack .../107-libwww-perl_6.68-1_all.deb ...
- Unpacking libwww-perl (6.68-1) ...
- Selecting previously unselected package liblwp-protocol-https-perl.
- Preparing to unpack .../108-liblwp-protocol-https-perl_6.10-1_all.deb ...
- Unpacking liblwp-protocol-https-perl (6.10-1) ...
- Selecting previously unselected package liblzma-dev:amd64.
- Preparing to unpack .../109-liblzma-dev_5.4.1-0.2_amd64.deb ...
- Unpacking liblzma-dev:amd64 (5.4.1-0.2) ...
- Selecting previously unselected package libnet-smtp-ssl-perl.
- Preparing to unpack .../110-libnet-smtp-ssl-perl_1.04-2_all.deb ...
- Unpacking libnet-smtp-ssl-perl (1.04-2) ...
- Selecting previously unselected package libmailtools-perl.
- Preparing to unpack .../111-libmailtools-perl_2.21-2_all.deb ...
- Unpacking libmailtools-perl (2.21-2) ...
- Selecting previously unselected package libncurses6:amd64.
- Preparing to unpack .../112-libncurses6_6.4-4_amd64.deb ...
- Unpacking libncurses6:amd64 (6.4-4) ...
- Selecting previously unselected package libncurses-dev:amd64.
- Preparing to unpack .../113-libncurses-dev_6.4-4_amd64.deb ...
- Unpacking libncurses-dev:amd64 (6.4-4) ...
- Selecting previously unselected package libncurses5-dev:amd64.
- Preparing to unpack .../114-libncurses5-dev_6.4-4_amd64.deb ...
- Unpacking libncurses5-dev:amd64 (6.4-4) ...
- Selecting previously unselected package libxml-parser-perl.
- Preparing to unpack .../115-libxml-parser-perl_2.46-4_amd64.deb ...
- Unpacking libxml-parser-perl (2.46-4) ...
- Selecting previously unselected package libxml-twig-perl.
- Preparing to unpack .../116-libxml-twig-perl_1%3a3.52-2_all.deb ...
- Unpacking libxml-twig-perl (1:3.52-2) ...
- Selecting previously unselected package libnet-dbus-perl.
- Preparing to unpack .../117-libnet-dbus-perl_1.2.0-2_amd64.deb ...
- Unpacking libnet-dbus-perl (1.2.0-2) ...
- Selecting previously unselected package libthai-data.
- Preparing to unpack .../118-libthai-data_0.1.29-1_all.deb ...
- Unpacking libthai-data (0.1.29-1) ...
- Selecting previously unselected package libthai0:amd64.
- Preparing to unpack .../119-libthai0_0.1.29-1_amd64.deb ...
- Unpacking libthai0:amd64 (0.1.29-1) ...
- Selecting previously unselected package libpango-1.0-0:amd64.
- Preparing to unpack .../120-libpango-1.0-0_1.50.12+ds-1_amd64.deb ...
- Unpacking libpango-1.0-0:amd64 (1.50.12+ds-1) ...
- Selecting previously unselected package libpangoft2-1.0-0:amd64.
- Preparing to unpack .../121-libpangoft2-1.0-0_1.50.12+ds-1_amd64.deb ...
- Unpacking libpangoft2-1.0-0:amd64 (1.50.12+ds-1) ...
- Selecting previously unselected package libpangocairo-1.0-0:amd64.
- Preparing to unpack .../122-libpangocairo-1.0-0_1.50.12+ds-1_amd64.deb ...
- Unpacking libpangocairo-1.0-0:amd64 (1.50.12+ds-1) ...
- Selecting previously unselected package libpaper1:amd64.
- Preparing to unpack .../123-libpaper1_1.1.29_amd64.deb ...
- Unpacking libpaper1:amd64 (1.1.29) ...
- Selecting previously unselected package libpaper-utils.
- Preparing to unpack .../124-libpaper-utils_1.1.29_amd64.deb ...
- Unpacking libpaper-utils (1.1.29) ...
- Selecting previously unselected package libpcre16-3:amd64.
- Preparing to unpack .../125-libpcre16-3_2%3a8.39-15_amd64.deb ...
- Unpacking libpcre16-3:amd64 (2:8.39-15) ...
- Selecting previously unselected package libpcre2-16-0:amd64.
- Preparing to unpack .../126-libpcre2-16-0_10.42-1_amd64.deb ...
- Unpacking libpcre2-16-0:amd64 (10.42-1) ...
- Selecting previously unselected package libpcre2-32-0:amd64.
- Preparing to unpack .../127-libpcre2-32-0_10.42-1_amd64.deb ...
- Unpacking libpcre2-32-0:amd64 (10.42-1) ...
- Selecting previously unselected package libpcre2-posix3:amd64.
- Preparing to unpack .../128-libpcre2-posix3_10.42-1_amd64.deb ...
- Unpacking libpcre2-posix3:amd64 (10.42-1) ...
- Selecting previously unselected package libpcre2-dev:amd64.
- Preparing to unpack .../129-libpcre2-dev_10.42-1_amd64.deb ...
- Unpacking libpcre2-dev:amd64 (10.42-1) ...
- Selecting previously unselected package libpcre3:amd64.
- Preparing to unpack .../130-libpcre3_2%3a8.39-15_amd64.deb ...
- Unpacking libpcre3:amd64 (2:8.39-15) ...
- Selecting previously unselected package libpcre32-3:amd64.
- Preparing to unpack .../131-libpcre32-3_2%3a8.39-15_amd64.deb ...
- Unpacking libpcre32-3:amd64 (2:8.39-15) ...
- Selecting previously unselected package libpcrecpp0v5:amd64.
- Preparing to unpack .../132-libpcrecpp0v5_2%3a8.39-15_amd64.deb ...
- Unpacking libpcrecpp0v5:amd64 (2:8.39-15) ...
- Selecting previously unselected package libpcre3-dev:amd64.
- Preparing to unpack .../133-libpcre3-dev_2%3a8.39-15_amd64.deb ...
- Unpacking libpcre3-dev:amd64 (2:8.39-15) ...
- Selecting previously unselected package libpkgconf3:amd64.
- Preparing to unpack .../134-libpkgconf3_1.8.1-1_amd64.deb ...
- Unpacking libpkgconf3:amd64 (1.8.1-1) ...
- Selecting previously unselected package zlib1g-dev:amd64.
- Preparing to unpack .../135-zlib1g-dev_1%3a1.2.13.dfsg-1_amd64.deb ...
- Unpacking zlib1g-dev:amd64 (1:1.2.13.dfsg-1) ...
- Selecting previously unselected package libpng-dev:amd64.
- Preparing to unpack .../136-libpng-dev_1.6.39-2_amd64.deb ...
- Unpacking libpng-dev:amd64 (1.6.39-2) ...
- Selecting previously unselected package libpng-tools.
- Preparing to unpack .../137-libpng-tools_1.6.39-2_amd64.deb ...
- Unpacking libpng-tools (1.6.39-2) ...
- Selecting previously unselected package libreadline-dev:amd64.
- Preparing to unpack .../138-libreadline-dev_8.2-1.3_amd64.deb ...
- Unpacking libreadline-dev:amd64 (8.2-1.3) ...
- Selecting previously unselected package libsm6:amd64.
- Preparing to unpack .../139-libsm6_2%3a1.2.3-1_amd64.deb ...
- Unpacking libsm6:amd64 (2:1.2.3-1) ...
- Selecting previously unselected package libtcl8.6:amd64.
- Preparing to unpack .../140-libtcl8.6_8.6.13+dfsg-2_amd64.deb ...
- Unpacking libtcl8.6:amd64 (8.6.13+dfsg-2) ...
- Selecting previously unselected package libtext-iconv-perl:amd64.
- Preparing to unpack .../141-libtext-iconv-perl_1.7-8_amd64.deb ...
- Unpacking libtext-iconv-perl:amd64 (1.7-8) ...
- Selecting previously unselected package libtie-ixhash-perl.
- Preparing to unpack .../142-libtie-ixhash-perl_1.23-4_all.deb ...
- Unpacking libtie-ixhash-perl (1.23-4) ...
- Selecting previously unselected package libxft2:amd64.
- Preparing to unpack .../143-libxft2_2.3.6-1_amd64.deb ...
- Unpacking libxft2:amd64 (2.3.6-1) ...
- Selecting previously unselected package libxss1:amd64.
- Preparing to unpack .../144-libxss1_1%3a1.2.3-1_amd64.deb ...
- Unpacking libxss1:amd64 (1:1.2.3-1) ...
- Selecting previously unselected package libtk8.6:amd64.
- Preparing to unpack .../145-libtk8.6_8.6.13-2_amd64.deb ...
- Unpacking libtk8.6:amd64 (8.6.13-2) ...
- Selecting previously unselected package libx11-protocol-perl.
- Preparing to unpack .../146-libx11-protocol-perl_0.56-9_all.deb ...
- Unpacking libx11-protocol-perl (0.56-9) ...
- Selecting previously unselected package libxt6:amd64.
- Preparing to unpack .../147-libxt6_1%3a1.2.1-1.1_amd64.deb ...
- Unpacking libxt6:amd64 (1:1.2.1-1.1) ...
- Selecting previously unselected package libxmu6:amd64.
- Preparing to unpack .../148-libxmu6_2%3a1.1.3-3_amd64.deb ...
- Unpacking libxmu6:amd64 (2:1.1.3-3) ...
- Selecting previously unselected package libxaw7:amd64.
- Preparing to unpack .../149-libxaw7_2%3a1.0.14-1_amd64.deb ...
- Unpacking libxaw7:amd64 (2:1.0.14-1) ...
- Selecting previously unselected package libxcb-shape0:amd64.
- Preparing to unpack .../150-libxcb-shape0_1.15-1_amd64.deb ...
- Unpacking libxcb-shape0:amd64 (1.15-1) ...
- Selecting previously unselected package libxcomposite1:amd64.
- Preparing to unpack .../151-libxcomposite1_1%3a0.4.5-1_amd64.deb ...
- Unpacking libxcomposite1:amd64 (1:0.4.5-1) ...
- Selecting previously unselected package libxcursor1:amd64.
- Preparing to unpack .../152-libxcursor1_1%3a1.2.1-1_amd64.deb ...
- Unpacking libxcursor1:amd64 (1:1.2.1-1) ...
- Selecting previously unselected package libxi6:amd64.
- Preparing to unpack .../153-libxi6_2%3a1.8-1+b1_amd64.deb ...
- Unpacking libxi6:amd64 (2:1.8-1+b1) ...
- Selecting previously unselected package libxinerama1:amd64.
- Preparing to unpack .../154-libxinerama1_2%3a1.1.4-3_amd64.deb ...
- Unpacking libxinerama1:amd64 (2:1.1.4-3) ...
- Selecting previously unselected package libxkbfile1:amd64.
- Preparing to unpack .../155-libxkbfile1_1%3a1.1.0-1_amd64.deb ...
- Unpacking libxkbfile1:amd64 (1:1.1.0-1) ...
- Selecting previously unselected package libxml-xpathengine-perl.
- Preparing to unpack .../156-libxml-xpathengine-perl_0.14-2_all.deb ...
- Unpacking libxml-xpathengine-perl (0.14-2) ...
- Selecting previously unselected package libxrandr2:amd64.
- Preparing to unpack .../157-libxrandr2_2%3a1.5.2-2+b1_amd64.deb ...
- Unpacking libxrandr2:amd64 (2:1.5.2-2+b1) ...
- Selecting previously unselected package libxtst6:amd64.
- Preparing to unpack .../158-libxtst6_2%3a1.2.3-1.1_amd64.deb ...
- Unpacking libxtst6:amd64 (2:1.2.3-1.1) ...
- Selecting previously unselected package libxv1:amd64.
- Preparing to unpack .../159-libxv1_2%3a1.0.11-1.1_amd64.deb ...
- Unpacking libxv1:amd64 (2:1.0.11-1.1) ...
- Selecting previously unselected package libxxf86dga1:amd64.
- Preparing to unpack .../160-libxxf86dga1_2%3a1.1.5-1_amd64.deb ...
- Unpacking libxxf86dga1:amd64 (2:1.1.5-1) ...
- Selecting previously unselected package pkgconf-bin.
- Preparing to unpack .../161-pkgconf-bin_1.8.1-1_amd64.deb ...
- Unpacking pkgconf-bin (1.8.1-1) ...
- Selecting previously unselected package pkgconf:amd64.
- Preparing to unpack .../162-pkgconf_1.8.1-1_amd64.deb ...
- Unpacking pkgconf:amd64 (1.8.1-1) ...
- Selecting previously unselected package pkg-config:amd64.
- Preparing to unpack .../163-pkg-config_1.8.1-1_amd64.deb ...
- Unpacking pkg-config:amd64 (1.8.1-1) ...
- Selecting previously unselected package zip.
- Preparing to unpack .../164-zip_3.0-13_amd64.deb ...
- Unpacking zip (3.0-13) ...
- Selecting previously unselected package xdg-utils.
- Preparing to unpack .../165-xdg-utils_1.1.3-4.1_all.deb ...
- Unpacking xdg-utils (1.1.3-4.1) ...
- Selecting previously unselected package r-base-core.
- Preparing to unpack .../166-r-base-core_4.2.2.20221110-2_amd64.deb ...
- Unpacking r-base-core (4.2.2.20221110-2) ...
- Selecting previously unselected package r-base-dev.
- Preparing to unpack .../167-r-base-dev_4.2.2.20221110-2_all.deb ...
- Unpacking r-base-dev (4.2.2.20221110-2) ...
- Selecting previously unselected package r-cran-boot.
- Preparing to unpack .../168-r-cran-boot_1.3-28.1-1_all.deb ...
- Unpacking r-cran-boot (1.3-28.1-1) ...
- Selecting previously unselected package r-cran-mass.
- Preparing to unpack .../169-r-cran-mass_7.3-58.2-1_amd64.deb ...
- Unpacking r-cran-mass (7.3-58.2-1) ...
- Selecting previously unselected package r-cran-class.
- Preparing to unpack .../170-r-cran-class_7.3-21-1_amd64.deb ...
- Unpacking r-cran-class (7.3-21-1) ...
- Selecting previously unselected package r-cran-cluster.
- Preparing to unpack .../171-r-cran-cluster_2.1.4-1_amd64.deb ...
- Unpacking r-cran-cluster (2.1.4-1) ...
- Selecting previously unselected package r-cran-codetools.
- Preparing to unpack .../172-r-cran-codetools_0.2-19-1_all.deb ...
- Unpacking r-cran-codetools (0.2-19-1) ...
- Selecting previously unselected package r-cran-foreign.
- Preparing to unpack .../173-r-cran-foreign_0.8.84-1_amd64.deb ...
- Unpacking r-cran-foreign (0.8.84-1) ...
- Selecting previously unselected package r-cran-kernsmooth.
- Preparing to unpack .../174-r-cran-kernsmooth_2.23-20-1_amd64.deb ...
- Unpacking r-cran-kernsmooth (2.23-20-1) ...
- Selecting previously unselected package r-cran-lattice.
- Preparing to unpack .../175-r-cran-lattice_0.20-45-3_amd64.deb ...
- Unpacking r-cran-lattice (0.20-45-3) ...
- Selecting previously unselected package r-cran-matrix.
- Preparing to unpack .../176-r-cran-matrix_1.5-3-1_amd64.deb ...
- Unpacking r-cran-matrix (1.5-3-1) ...
- Selecting previously unselected package r-cran-nlme.
- Preparing to unpack .../177-r-cran-nlme_3.1.162-1_amd64.deb ...
- Unpacking r-cran-nlme (3.1.162-1) ...
- Selecting previously unselected package r-cran-mgcv.
- Preparing to unpack .../178-r-cran-mgcv_1.8-41-1_amd64.deb ...
- Unpacking r-cran-mgcv (1.8-41-1) ...
- Selecting previously unselected package r-cran-nnet.
- Preparing to unpack .../179-r-cran-nnet_7.3-18-1_amd64.deb ...
- Unpacking r-cran-nnet (7.3-18-1) ...
- Selecting previously unselected package r-cran-survival.
- Preparing to unpack .../180-r-cran-survival_3.5-3-1_amd64.deb ...
- Unpacking r-cran-survival (3.5-3-1) ...
- Selecting previously unselected package r-cran-rpart.
- Preparing to unpack .../181-r-cran-rpart_4.1.19-1_amd64.deb ...
- Unpacking r-cran-rpart (4.1.19-1) ...
- Selecting previously unselected package r-cran-spatial.
- Preparing to unpack .../182-r-cran-spatial_7.3-16-1_amd64.deb ...
- Unpacking r-cran-spatial (7.3-16-1) ...
- Selecting previously unselected package r-doc-html.
- Preparing to unpack .../183-r-doc-html_4.2.2.20221110-2_all.deb ...
- Unpacking r-doc-html (4.2.2.20221110-2) ...
- Selecting previously unselected package r-mathlib.
- Preparing to unpack .../184-r-mathlib_4.2.2.20221110-2_amd64.deb ...
- Unpacking r-mathlib (4.2.2.20221110-2) ...
- Selecting previously unselected package r-recommended.
- Preparing to unpack .../185-r-recommended_4.2.2.20221110-2_all.deb ...
- Unpacking r-recommended (4.2.2.20221110-2) ...
- Selecting previously unselected package x11-utils.
- Preparing to unpack .../186-x11-utils_7.7+5_amd64.deb ...
- Unpacking x11-utils (7.7+5) ...
- Selecting previously unselected package x11-xserver-utils.
- Preparing to unpack .../187-x11-xserver-utils_7.7+9+b1_amd64.deb ...
- Unpacking x11-xserver-utils (7.7+9+b1) ...
- Selecting previously unselected package xdg-user-dirs.
- Preparing to unpack .../188-xdg-user-dirs_0.18-1_amd64.deb ...
- Unpacking xdg-user-dirs (0.18-1) ...
- Selecting previously unselected package libegl1:amd64.
- Preparing to unpack .../189-libegl1_1.6.0-1_amd64.deb ...
- Unpacking libegl1:amd64 (1.6.0-1) ...
- Selecting previously unselected package zutty.
- Preparing to unpack .../190-zutty_0.14.0.20230218+dfsg1-1_amd64.deb ...
- Unpacking zutty (0.14.0.20230218+dfsg1-1) ...
- Setting up libtext-iconv-perl:amd64 (1.7-8) ...
- Setting up libgraphite2-3:amd64 (1.3.14-1) ...
- Setting up libxcb-dri3-0:amd64 (1.15-1) ...
- Setting up libpixman-1-0:amd64 (0.42.2-1) ...
- Setting up bzip2-doc (1.0.8-5) ...
- Setting up libwayland-server0:amd64 (1.21.0-1) ...
- Setting up libx11-xcb1:amd64 (2:1.8.4-2+deb12u2) ...
- Setting up libpciaccess0:amd64 (0.17-2) ...
- Setting up fontconfig (2.14.1-4) ...
- Regenerating fonts cache... 
- done.
- Setting up libapparmor1:amd64 (3.0.8-3) ...
- Setting up libtie-ixhash-perl (1.23-4) ...
- Setting up libicu72:amd64 (72.1-3) ...
- Setting up libxcb-xfixes0:amd64 (1.15-1) ...
- Setting up r-doc-html (4.2.2.20221110-2) ...
- Setting up libpcre16-3:amd64 (2:8.39-15) ...
- Setting up libxi6:amd64 (2:1.8-1+b1) ...
- Setting up libfont-afm-perl (1.20-4) ...
- Setting up libxrender1:amd64 (1:0.9.10-1.1) ...
- Setting up libdatrie1:amd64 (0.2.13-2+b1) ...
- Setting up xdg-user-dirs (0.18-1) ...
- Setting up libpng-tools (1.6.39-2) ...
- Setting up libxcb-render0:amd64 (1.15-1) ...
- Setting up libclone-perl:amd64 (0.46-1) ...
- Setting up libglib2.0-0:amd64 (2.74.6-2+deb12u2) ...
- No schema files found: doing nothing.
- Setting up libglvnd0:amd64 (1.6.0-1) ...
- Setting up libio-stringy-perl (2.111-3) ...
- Setting up libhtml-tagset-perl (3.20-6) ...
- Setting up libauthen-sasl-perl (2.1600-3) ...
- Setting up libxcb-glx0:amd64 (1.15-1) ...
- Setting up liblwp-mediatypes-perl (6.04-2) ...
- Setting up libxcb-shape0:amd64 (1.15-1) ...
- Setting up x11-common (1:7.7+23) ...
- invoke-rc.d: could not determine current runlevel
- invoke-rc.d: policy-rc.d denied execution of restart.
- Setting up libtry-tiny-perl (0.31-2) ...
- Setting up libsensors-config (1:3.6.0-7.1) ...
- Setting up libxxf86dga1:amd64 (2:1.1.5-1) ...
- Setting up perl-openssl-defaults:amd64 (7+b1) ...
- Setting up libencode-locale-perl (1.05-3) ...
- Setting up libxcb-shm0:amd64 (1.15-1) ...
- Setting up libcairo2:amd64 (1.16.0-7) ...
- Setting up libpcre2-16-0:amd64 (10.42-1) ...
- Setting up libxxf86vm1:amd64 (1:1.1.4-1+b2) ...
- Setting up libxcb-present0:amd64 (1.15-1) ...
- Setting up libpcre3:amd64 (2:8.39-15) ...
- Setting up zip (3.0-13) ...
- Setting up libfontenc1:amd64 (1:1.1.4-1) ...
- Setting up libz3-4:amd64 (4.8.12-3.1) ...
- Setting up libpcre2-32-0:amd64 (10.42-1) ...
- Setting up libblas3:amd64 (3.11.0-2) ...
- update-alternatives: using /usr/lib/x86_64-linux-gnu/blas/libblas.so.3 to provide /usr/lib/x86_64-linux-gnu/libblas.so.3 (libblas.so.3-x86_64-linux-gnu) in auto mode
- Setting up libglib2.0-data (2.74.6-2+deb12u2) ...
- Setting up libpkgconf3:amd64 (1.8.1-1) ...
- Setting up libgles2:amd64 (1.6.0-1) ...
- Setting up libdata-dump-perl (1.25-1) ...
- Setting up libjpeg62-turbo-dev:amd64 (1:2.1.5-2) ...
- Setting up libxfixes3:amd64 (1:6.0.0-2) ...
- Setting up libxcb-sync1:amd64 (1.15-1) ...
- Setting up libipc-system-simple-perl (1.30-2) ...
- Setting up libxml-xpathengine-perl (0.14-2) ...
- Setting up libncurses6:amd64 (6.4-4) ...
- Setting up libdbus-1-3:amd64 (1.14.10-1~deb12u1) ...
- Setting up libfribidi0:amd64 (1.0.8-2.1) ...
- Setting up libxinerama1:amd64 (2:1.1.4-3) ...
- Setting up libxv1:amd64 (2:1.0.11-1.1) ...
- Setting up libpcre32-3:amd64 (2:8.39-15) ...
- Setting up libio-html-perl (1.004-3) ...
- Setting up libxrandr2:amd64 (2:1.5.2-2+b1) ...
- Setting up libtcl8.6:amd64 (8.6.13+dfsg-2) ...
- Setting up icu-devtools (72.1-3) ...
- Setting up pkgconf-bin (1.8.1-1) ...
- Setting up libsensors5:amd64 (1:3.6.0-7.1) ...
- Setting up libglapi-mesa:amd64 (22.3.6-1+deb12u1) ...
- Setting up libgfortran5:amd64 (12.2.0-14) ...
- Setting up libtimedate-perl (2.3300-2) ...
- Setting up libregexp-ipv6-perl (0.03-3) ...
- Setting up liblzma-dev:amd64 (5.4.1-0.2) ...
- Setting up libxcb-dri2-0:amd64 (1.15-1) ...
- Setting up zlib1g-dev:amd64 (1:1.2.13.dfsg-1) ...
- Setting up libpcre2-posix3:amd64 (10.42-1) ...
- Setting up sensible-utils (0.0.17+nmu1) ...
- Setting up libxshmfence1:amd64 (1.3-1) ...
- Setting up libxcb-randr0:amd64 (1.15-1) ...
- Setting up dbus-session-bus-common (1.14.10-1~deb12u1) ...
- Setting up r-mathlib (4.2.2.20221110-2) ...
- Setting up libharfbuzz0b:amd64 (6.0.0+dfsg-3) ...
- Setting up libthai-data (0.1.29-1) ...
- Setting up libxss1:amd64 (1:1.2.3-1) ...
- Setting up libxkbfile1:amd64 (1:1.1.0-1) ...
- Setting up dbus-system-bus-common (1.14.10-1~deb12u1) ...
- Setting up libdrm-common (2.4.114-1) ...
- Setting up libelf1:amd64 (0.188-2.1) ...
- Setting up libxcomposite1:amd64 (1:0.4.5-1) ...
- Setting up libicu-dev:amd64 (72.1-3) ...
- Setting up libxml2:amd64 (2.9.14+dfsg-1.3~deb12u1) ...
- Setting up xdg-utils (1.1.3-4.1) ...
- update-alternatives: using /usr/bin/xdg-open to provide /usr/bin/open (open) in auto mode
- Setting up liburi-perl (5.17-1) ...
- Setting up dbus-bin (1.14.10-1~deb12u1) ...
- Setting up libx11-protocol-perl (0.56-9) ...
- Setting up libblas-dev:amd64 (3.11.0-2) ...
- update-alternatives: using /usr/lib/x86_64-linux-gnu/blas/libblas.so to provide /usr/lib/x86_64-linux-gnu/libblas.so (libblas.so-x86_64-linux-gnu) in auto mode
- Setting up libbz2-dev:amd64 (1.0.8-5+b1) ...
- Setting up libwayland-client0:amd64 (1.21.0-1) ...
- Setting up libnet-ssleay-perl:amd64 (1.92-2+b1) ...
- Setting up libpcrecpp0v5:amd64 (2:8.39-15) ...
- Setting up libice6:amd64 (2:1.0.10-1) ...
- Setting up libhttp-date-perl (6.05-2) ...
- Setting up liblapack3:amd64 (3.11.0-2) ...
- update-alternatives: using /usr/lib/x86_64-linux-gnu/lapack/liblapack.so.3 to provide /usr/lib/x86_64-linux-gnu/liblapack.so.3 (liblapack.so.3-x86_64-linux-gnu) in auto mode
- Setting up libxft2:amd64 (2.3.6-1) ...
- Setting up libncurses-dev:amd64 (6.4-4) ...
- Setting up libfile-basedir-perl (0.09-2) ...
- Setting up libfile-listing-perl (6.15-1) ...
- Setting up libpcre2-dev:amd64 (10.42-1) ...
- Setting up libpcre3-dev:amd64 (2:8.39-15) ...
- Setting up libxtst6:amd64 (2:1.2.3-1.1) ...
- Setting up libtk8.6:amd64 (8.6.13-2) ...
- Setting up libxcursor1:amd64 (1:1.2.1-1) ...
- Setting up libpng-dev:amd64 (1.6.39-2) ...
- Setting up libjpeg-dev:amd64 (1:2.1.5-2) ...
- Setting up libnet-http-perl (6.22-1) ...
- Setting up libgfortran-12-dev:amd64 (12.2.0-14) ...
- Setting up dbus-daemon (1.14.10-1~deb12u1) ...
- Setting up libreadline-dev:amd64 (8.2-1.3) ...
- Setting up pkgconf:amd64 (1.8.1-1) ...
- Setting up libthai0:amd64 (0.1.29-1) ...
- Setting up gfortran-12 (12.2.0-14) ...
- Setting up dbus (1.14.10-1~deb12u1) ...
- invoke-rc.d: could not determine current runlevel
- invoke-rc.d: policy-rc.d denied execution of start.
- Setting up shared-mime-info (2.2-1) ...
- Setting up liblapack-dev:amd64 (3.11.0-2) ...
- update-alternatives: using /usr/lib/x86_64-linux-gnu/lapack/liblapack.so to provide /usr/lib/x86_64-linux-gnu/liblapack.so (liblapack.so-x86_64-linux-gnu) in auto mode
- Setting up pkg-config:amd64 (1.8.1-1) ...
- Setting up ucf (3.0043+nmu1) ...
- Setting up libfile-desktopentry-perl (0.22-3) ...
- Setting up libwww-robotrules-perl (6.02-1) ...
- Setting up libdrm2:amd64 (2.4.114-1+b1) ...
- Setting up libhtml-parser-perl:amd64 (3.81-1) ...
- Setting up libllvm15:amd64 (1:15.0.6-4+b1) ...
- Setting up libncurses5-dev:amd64 (6.4-4) ...
- Setting up libsm6:amd64 (2:1.2.3-1) ...
- Setting up libio-socket-ssl-perl (2.081-2) ...
- Setting up libhttp-message-perl (6.44-1) ...
- Setting up libdrm-amdgpu1:amd64 (2.4.114-1+b1) ...
- Setting up libhtml-form-perl (6.11-1) ...
- Setting up libfile-mimeinfo-perl (0.33-1) ...
- Setting up libpaper1:amd64 (1.1.29) ...
- 
- Creating config file /etc/papersize with new version
- Setting up libhttp-negotiate-perl (6.01-2) ...
- Setting up libdrm-nouveau2:amd64 (2.4.114-1+b1) ...
- Setting up libgbm1:amd64 (22.3.6-1+deb12u1) ...
- Setting up libhttp-cookies-perl (6.10-1) ...
- Setting up libdrm-radeon1:amd64 (2.4.114-1+b1) ...
- Setting up libhtml-tree-perl (5.07-3) ...
- Setting up libpango-1.0-0:amd64 (1.50.12+ds-1) ...
- Setting up libdrm-intel1:amd64 (2.4.114-1+b1) ...
- Setting up libgl1-mesa-dri:amd64 (22.3.6-1+deb12u1) ...
- Setting up libhtml-format-perl (2.16-2) ...
- Setting up libpaper-utils (1.1.29) ...
- Setting up gfortran (4:12.2.0-3) ...
- update-alternatives: using /usr/bin/gfortran to provide /usr/bin/f95 (f95) in auto mode
- update-alternatives: using /usr/bin/gfortran to provide /usr/bin/f77 (f77) in auto mode
- Setting up libegl-mesa0:amd64 (22.3.6-1+deb12u1) ...
- Setting up libnet-smtp-ssl-perl (1.04-2) ...
- Setting up libmailtools-perl (2.21-2) ...
- Setting up libxt6:amd64 (1:1.2.1-1.1) ...
- Setting up libhttp-daemon-perl (6.16-1) ...
- Setting up libegl1:amd64 (1.6.0-1) ...
- Setting up libpangoft2-1.0-0:amd64 (1.50.12+ds-1) ...
- Setting up libpangocairo-1.0-0:amd64 (1.50.12+ds-1) ...
- Setting up libxmu6:amd64 (2:1.1.3-3) ...
- Setting up libglx-mesa0:amd64 (22.3.6-1+deb12u1) ...
- Setting up libglx0:amd64 (1.6.0-1) ...
- Setting up libxaw7:amd64 (2:1.0.14-1) ...
- Setting up x11-xserver-utils (7.7+9+b1) ...
- Setting up libgl1:amd64 (1.6.0-1) ...
- Setting up r-base-core (4.2.2.20221110-2) ...
- 
- Creating config file /etc/R/Renviron with new version
- Setting up r-cran-lattice (0.20-45-3) ...
- Setting up r-cran-nlme (3.1.162-1) ...
- Setting up zutty (0.14.0.20230218+dfsg1-1) ...
- update-alternatives: using /usr/bin/zutty to provide /usr/bin/x-terminal-emulator (x-terminal-emulator) in auto mode
- Setting up r-cran-cluster (2.1.4-1) ...
- Setting up x11-utils (7.7+5) ...
- Setting up r-cran-nnet (7.3-18-1) ...
- Setting up r-cran-codetools (0.2-19-1) ...
- Setting up r-cran-boot (1.3-28.1-1) ...
- Setting up r-base-dev (4.2.2.20221110-2) ...
- Setting up r-cran-spatial (7.3-16-1) ...
- Setting up r-cran-mass (7.3-58.2-1) ...
- Setting up r-cran-foreign (0.8.84-1) ...
- Setting up r-cran-matrix (1.5-3-1) ...
- Setting up r-cran-kernsmooth (2.23-20-1) ...
- Setting up r-cran-mgcv (1.8-41-1) ...
- Setting up r-cran-class (7.3-21-1) ...
- Setting up r-cran-survival (3.5-3-1) ...
- Setting up r-cran-rpart (4.1.19-1) ...
- Setting up r-recommended (4.2.2.20221110-2) ...
- Setting up liblwp-protocol-https-perl (6.10-1) ...
- Setting up libwww-perl (6.68-1) ...
- Setting up libxml-parser-perl (2.46-4) ...
- Setting up libxml-twig-perl (1:3.52-2) ...
- Setting up libnet-dbus-perl (1.2.0-2) ...
- Processing triggers for libc-bin (2.36-9+deb12u7) ...

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/30:
Processing  2/30:
Processing  3/30:
Processing  4/30:
Processing  5/30:
Processing  6/30:
Processing  7/30:
Processing  8/30: [conf-bash: bash]
Processing  9/30: [conf-bash: bash] [conf-pkg-config: pkg-config]
Processing 10/30: [conf-bash: bash] [conf-pkg-config: pkg-config] [conf-r: R CMD]
-> retrieved base.v0.16.3  (cached)
Processing 11/30: [conf-bash: bash] [conf-pkg-config: pkg-config] [conf-r: R CMD]
-> retrieved csexp.1.5.2  (cached)
Processing 12/30: [conf-bash: bash] [conf-pkg-config: pkg-config] [conf-r: R CMD]
Processing 13/30: [conf-bash: bash] [conf-pkg-config: pkg-config] [conf-r: R CMD] [csexp: dune build]
-> retrieved dune-configurator.3.15.2  (cached)
Processing 14/30: [conf-bash: bash] [conf-pkg-config: pkg-config] [conf-r: R CMD] [csexp: dune build]
- GNU bash, version 5.2.15(1)-release (x86_64-pc-linux-gnu)
- Copyright (C) 2022 Free Software Foundation, Inc.
- License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
- 
- This is free software; you are free to change and redistribute it.
- There is NO WARRANTY, to the extent permitted by law.
-> compiled  conf-bash.1
Processing 14/30: [conf-pkg-config: pkg-config] [conf-r: R CMD] [csexp: dune build]
-> installed conf-bash.1
Processing 15/30: [conf-pkg-config: pkg-config] [conf-r: R CMD] [csexp: dune build]
- usage: pkgconf [OPTIONS] [LIBRARIES]
- 
- basic options:
- 
-   --help                            this message
-   --about                           print pkgconf version and license to stdout
-   --version                         print supported pkg-config version to stdout
-   --atleast-pkgconfig-version       check whether or not pkgconf is compatible
-                                     with a specified pkg-config version
-   --errors-to-stdout                print all errors on stdout instead of stderr
-   --print-errors                    ensure all errors are printed
-   --short-errors                    be less verbose about some errors
-   --silence-errors                  explicitly be silent about errors
-   --list-all                        list all known packages
-   --list-package-names              list all known package names
-   --simulate                        simulate walking the calculated dependency graph
-   --no-cache                        do not cache already seen packages when
-                                     walking the dependency graph
-   --log-file=filename               write an audit log to a specified file
-   --with-path=path                  adds a directory to the search path
-   --define-prefix                   override the prefix variable with one that is guessed based on
-                                     the location of the .pc file
-   --dont-define-prefix              do not override the prefix variable under any circumstances
-   --prefix-variable=varname         sets the name of the variable that pkgconf considers
-                                     to be the package prefix
-   --relocate=path                   relocates a path and exits (mostly for testsuite)
-   --dont-relocate-paths             disables path relocation support
- 
- cross-compilation personality support:
- 
-   --personality=triplet|filename    sets the personality to 'triplet' or a file named 'filename'
-   --dump-personality                dumps details concerning selected personality
- 
- checking specific pkg-config database entries:
- 
-   --atleast-version                 require a specific version of a module
-   --exact-version                   require an exact version of a module
-   --max-version                     require a maximum version of a module
-   --exists                          check whether or not a module exists
-   --uninstalled                     check whether or not an uninstalled module will be used
-   --no-uninstalled                  never use uninstalled modules when satisfying dependencies
-   --no-provides                     do not use 'provides' rules to resolve dependencies
-   --maximum-traverse-depth          maximum allowed depth for dependency graph
-   --static                          be more aggressive when computing dependency graph
-                                     (for static linking)
-   --shared                          use a simplified dependency graph (usually default)
-   --pure                            optimize a static dependency graph as if it were a normal
-                                     dependency graph
-   --env-only                        look only for package entries in PKG_CONFIG_PATH
-   --ignore-conflicts                ignore 'conflicts' rules in modules
-   --validate                        validate specific .pc files for correctness
- 
- querying specific pkg-config database fields:
- 
-   --define-variable=varname=value   define variable 'varname' as 'value'
-   --variable=varname                print specified variable entry to stdout
-   --cflags                          print required CFLAGS to stdout
-   --cflags-only-I                   print required include-dir CFLAGS to stdout
-   --cflags-only-other               print required non-include-dir CFLAGS to stdout
-   --libs                            print required linker flags to stdout
-   --libs-only-L                     print required LDPATH linker flags to stdout
-   --libs-only-l                     print required LIBNAME linker flags to stdout
-   --libs-only-other                 print required other linker flags to stdout
-   --print-requires                  print required dependency frameworks to stdout
-   --print-requires-private          print required dependency frameworks for static
-                                     linking to stdout
-   --print-provides                  print provided dependencies to stdout
-   --print-variables                 print all known variables in module to stdout
-   --digraph                         print entire dependency graph in graphviz 'dot' format
-   --keep-system-cflags              keep -I/usr/include entries in cflags output
-   --keep-system-libs                keep -L/lib:/lib/i386-linux-gnu:/lib/x86_64-linux-gnu:/lib/x86_64-linux-gnux32:/lib32:/libx32:/usr/lib:/usr/lib/i386-linux-gnu:/usr/lib/x86_64-linux-gnu:/usr/lib/x86_64-linux-gnux32:/usr/lib32:/usr/libx32 entries in libs output
-   --path                            show the exact filenames for any matching .pc files
-   --modversion                      print the specified module's version to stdout
-   --internal-cflags                 do not filter 'internal' cflags from output
- 
- filtering output:
- 
-   --msvc-syntax                     print translatable fragments in MSVC syntax
-   --fragment-filter=types           filter output fragments to the specified types
- 
- report bugs to <https://github.com/pkgconf/pkgconf/issues/new>.
-> compiled  conf-pkg-config.3
Processing 15/30: [conf-r: R CMD] [csexp: dune build]
-> installed conf-pkg-config.3
Processing 16/30: [conf-r: R CMD] [csexp: dune build]
Processing 17/30: [conf-r: R CMD] [conf-r-mathlib: pkg-config libRmath] [csexp: dune build]
-> compiled  conf-r.1.0.0
Processing 17/30: [conf-r-mathlib: pkg-config libRmath] [csexp: dune build]
-> installed conf-r.1.0.0
Processing 18/30: [conf-r-mathlib: pkg-config libRmath] [csexp: dune build]
-> retrieved ocaml-r.0.4.0  (cached)
-> retrieved sexplib0.v0.16.0  (cached)
Processing 19/30: [conf-r-mathlib: pkg-config libRmath] [csexp: dune build] [sexplib0: dune build]
-> compiled  csexp.1.5.2
Processing 19/30: [conf-r-mathlib: pkg-config libRmath] [sexplib0: dune build]
-> installed csexp.1.5.2
Processing 20/30: [conf-r-mathlib: pkg-config libRmath] [sexplib0: dune build]
Processing 21/30: [conf-r-mathlib: pkg-config libRmath] [dune-configurator: rm] [sexplib0: dune build]
-> retrieved stdio.v0.16.0  (cached)
-> compiled  conf-r-mathlib.1
Processing 21/30: [dune-configurator: rm] [sexplib0: dune build]
-> installed conf-r-mathlib.1
Processing 22/30: [dune-configurator: rm] [sexplib0: dune build]
Processing 22/30: [dune-configurator: dune build] [sexplib0: dune build]
-> compiled  sexplib0.v0.16.0
Processing 22/30: [dune-configurator: dune build]
-> installed sexplib0.v0.16.0
Processing 23/30: [dune-configurator: dune build]
+ /home/opam/.opam/5.1/bin/dune "build" "-p" "dune-configurator" "-j" "31" "@install" (CWD=/home/opam/.opam/5.1/.opam-switch/build/dune-configurator.3.15.2)
-> compiled  dune-configurator.3.15.2
-> installed dune-configurator.3.15.2
Processing 25/30: [base: dune build]
+ /home/opam/.opam/5.1/bin/dune "build" "-p" "base" "-j" "31" (CWD=/home/opam/.opam/5.1/.opam-switch/build/base.v0.16.3)
-> compiled  base.v0.16.3
-> installed base.v0.16.3
Processing 27/30: [stdio: dune build]
+ /home/opam/.opam/5.1/bin/dune "build" "-p" "stdio" "-j" "31" (CWD=/home/opam/.opam/5.1/.opam-switch/build/stdio.v0.16.0)
-> compiled  stdio.v0.16.0
-> installed stdio.v0.16.0
Processing 29/30: [ocaml-r: dune build]
+ /home/opam/.opam/5.1/bin/dune "build" "-p" "ocaml-r" "-j" "31" "@install" (CWD=/home/opam/.opam/5.1/.opam-switch/build/ocaml-r.0.4.0)
- (cd _build/default && /home/opam/.opam/5.1/bin/ocamlc.opt -w -40 -g -bin-annot -I stubgen/.stubgen.eobjs/byte -I /home/opam/.opam/5.1/lib/base -I /home/opam/.opam/5.1/lib/base/base_internalhash_types -I /home/opam/.opam/5.1/lib/base/caml -I /home/opam/.opam/5.1/lib/base/shadow_stdlib -I /home/opam/.opam/5.1/lib/ocaml/unix -I /home/opam/.opam/5.1/lib/sexplib0 -I lib/.OCamlR.objs/public_cmi -I lib/interpreter/.OCamlR_interpreter.objs/byte -no-alias-deps -o stubgen/.stubgen.eobjs/byte/dune__exe__Stubgen.cmo -c -impl stubgen/stubgen.ml)
- File "stubgen/stubgen.ml", line 43, characters 23-33:
- 43 |     if List.mem ~equal:Caml.( = ) keywords n then n ^ "_"
-                             ^^^^^^^^^^
- Alert deprecated: module Caml
- [since v0.16] use Stdlib instead of Caml
- 
- File "stubgen/stubgen.ml", line 106, characters 2-20:
- 106 |   Caml.print_endline "open OCamlR" ;
-         ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Caml
- [since v0.16] use Stdlib instead of Caml
- 
- File "stubgen/stubgen.ml", line 107, characters 2-20:
- 107 |   Caml.print_endline (
-         ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Caml
- [since v0.16] use Stdlib instead of Caml
- 
- File "stubgen/stubgen.ml", line 116, characters 11-29:
- 116 |         |> Caml.print_endline
-                  ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Caml
- [since v0.16] use Stdlib instead of Caml
- 
- File "stubgen/stubgen.ml", line 120, characters 31-44:
- 120 |   generate_stub_ml_for_package Caml.Sys.argv.(1)
-                                      ^^^^^^^^^^^^^
- Alert deprecated: module Caml
- [since v0.16] use Stdlib instead of Caml
- File "lib/dune", line 12, characters 20-38:
- 12 |                     read_internal_stub
-                          ^^^^^^^^^^^^^^^^^^
- (cd _build/default/lib && /usr/bin/gcc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC -D_FILE_OFFSET_BITS=64 -I/usr/share/R/include -g -I /home/opam/.opam/5.1/lib/ocaml -I /home/opam/.opam/5.1/lib/ocaml/unix -o read_internal_stub.o -c read_internal_stub.c)
- In file included from read_internal_stub.c:32:
- read_internal_stub.c: In function 'ocamlr_inspect_primsxp_offset':
- read_internal_stub.c:108:32: error: invalid use of undefined type 'struct SEXPREC'
-   108 |   return(Val_int(Sexp_val(sexp)->u.primsxp.offset));
-       |                                ^~
- /home/opam/.opam/5.1/lib/ocaml/caml/mlvalues.h:77:47: note: in definition of macro 'Val_long'
-    77 | #define Val_long(x)     ((intnat) (((uintnat)(x) << 1)) + 1)
-       |                                               ^
- read_internal_stub.c:108:10: note: in expansion of macro 'Val_int'
-   108 |   return(Val_int(Sexp_val(sexp)->u.primsxp.offset));
-       |          ^~~~~~~
- read_internal_stub.c: In function 'ocamlr_inspect_promsxp_value':
- read_internal_stub.c:241:33: error: invalid use of undefined type 'struct SEXPREC'
-   241 |   return(Val_sexp(Sexp_val(sexp)->u.promsxp.value));
-       |                                 ^~
- read_internal_stub.c: In function 'ocamlr_inspect_promsxp_expr':
- read_internal_stub.c:254:33: error: invalid use of undefined type 'struct SEXPREC'
-   254 |   return(Val_sexp(Sexp_val(sexp)->u.promsxp.expr));
-       |                                 ^~
- read_internal_stub.c: In function 'ocamlr_inspect_promsxp_env':
- read_internal_stub.c:267:33: error: invalid use of undefined type 'struct SEXPREC'
-   267 |   return(Val_sexp(Sexp_val(sexp)->u.promsxp.env));
-       |                                 ^~
- File "lib/dune", line 13, characters 20-39:
- 13 |                     write_internal_stub
-                          ^^^^^^^^^^^^^^^^^^^
- (cd _build/default/lib && /usr/bin/gcc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC -D_FILE_OFFSET_BITS=64 -I/usr/share/R/include -g -I /home/opam/.opam/5.1/lib/ocaml -I /home/opam/.opam/5.1/lib/ocaml/unix -o write_internal_stub.o -c write_internal_stub.c)
- write_internal_stub.c: In function 'ocamlr_write_lisplist_carval':
- write_internal_stub.c:50:21: error: invalid use of undefined type 'struct SEXPREC'
-    50 |   Sexp_val(lisplist)->u.listsxp.carval = Sexp_val(elmnt);
-       |                     ^~
- write_internal_stub.c: In function 'ocamlr_write_lisplist_tagval':
- write_internal_stub.c:55:21: error: invalid use of undefined type 'struct SEXPREC'
-    55 |   Sexp_val(lisplist)->u.listsxp.tagval = Sexp_val(tag);
-       |                     ^~
- (cd _build/default && /home/opam/.opam/5.1/bin/ocamlopt.opt -w -40 -g -I stubgen/.stubgen.eobjs/byte -I stubgen/.stubgen.eobjs/native -I /home/opam/.opam/5.1/lib/base -I /home/opam/.opam/5.1/lib/base/base_internalhash_types -I /home/opam/.opam/5.1/lib/base/caml -I /home/opam/.opam/5.1/lib/base/shadow_stdlib -I /home/opam/.opam/5.1/lib/ocaml/unix -I /home/opam/.opam/5.1/lib/sexplib0 -I lib/.OCamlR.objs/native -I lib/.OCamlR.objs/public_cmi -I lib/interpreter/.OCamlR_interpreter.objs/byte -I lib/interpreter/.OCamlR_interpreter.objs/native -intf-suffix .ml -no-alias-deps -o stubgen/.stubgen.eobjs/native/dune__exe__Stubgen.cmx -c -impl stubgen/stubgen.ml)
- File "stubgen/stubgen.ml", line 43, characters 23-33:
- 43 |     if List.mem ~equal:Caml.( = ) keywords n then n ^ "_"
-                             ^^^^^^^^^^
- Alert deprecated: module Caml
- [since v0.16] use Stdlib instead of Caml
- 
- File "stubgen/stubgen.ml", line 106, characters 2-20:
- 106 |   Caml.print_endline "open OCamlR" ;
-         ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Caml
- [since v0.16] use Stdlib instead of Caml
- 
- File "stubgen/stubgen.ml", line 107, characters 2-20:
- 107 |   Caml.print_endline (
-         ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Caml
- [since v0.16] use Stdlib instead of Caml
- 
- File "stubgen/stubgen.ml", line 116, characters 11-29:
- 116 |         |> Caml.print_endline
-                  ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Caml
- [since v0.16] use Stdlib instead of Caml
- 
- File "stubgen/stubgen.ml", line 120, characters 31-44:
- 120 |   generate_stub_ml_for_package Caml.Sys.argv.(1)
-                                      ^^^^^^^^^^^^^
- Alert deprecated: module Caml
- [since v0.16] use Stdlib instead of Caml
[ERROR] The compilation of ocaml-r.0.4.0 failed at "dune build -p ocaml-r -j 31 @install".

#=== ERROR while compiling ocaml-r.0.4.0 ======================================#
# context              2.1.5 | linux/x86_64 | ocaml-base-compiler.5.1.1 | file:///src
# path                 ~/.opam/5.1/.opam-switch/build/ocaml-r.0.4.0
# command              ~/.opam/5.1/bin/dune build -p ocaml-r -j 31 @install
# exit-code            1
# env-file             ~/.opam/log/ocaml-r-113-0849fc.env
# output-file          ~/.opam/log/ocaml-r-113-0849fc.out
### output ###
# (cd _build/default && /home/opam/.opam/5.1/bin/ocamlc.opt -w -40 -g -bin-annot -I stubgen/.stubgen.eobjs/byte -I /home/opam/.opam/5.1/lib/base -I /home/opam/.opam/5.1/lib/base/base_internalhash_types -I /home/opam/.opam/5.1/lib/base/caml -I /home/opam/.opam/5.1/lib/base/shadow_stdlib -I /home/opam/.opam/5.1/lib/ocaml/unix -I /home/opam/.opam/5.1/lib/sexplib0 -I lib/.OCamlR.objs/public_cmi -I lib/interpreter/.OCamlR_interpreter.objs/byte -no-alias-deps -o stubgen/.stubgen.eobjs/byte/dune__exe__Stubgen.cmo -c -impl stubgen/stubgen.ml)
# File "stubgen/stubgen.ml", line 43, characters 23-33:
# 43 |     if List.mem ~equal:Caml.( = ) keywords n then n ^ "_"
#                             ^^^^^^^^^^
# Alert deprecated: module Caml
# [since v0.16] use Stdlib instead of Caml
# 
# File "stubgen/stubgen.ml", line 106, characters 2-20:
# 106 |   Caml.print_endline "open OCamlR" ;
#         ^^^^^^^^^^^^^^^^^^
# Alert deprecated: module Caml
# [since v0.16] use Stdlib instead of Caml
# 
# File "stubgen/stubgen.ml", line 107, characters 2-20:
# 107 |   Caml.print_endline (
#         ^^^^^^^^^^^^^^^^^^
# Alert deprecated: module Caml
# [since v0.16] use Stdlib instead of Caml
# 
# File "stubgen/stubgen.ml", line 116, characters 11-29:
# 116 |         |> Caml.print_endline
#                  ^^^^^^^^^^^^^^^^^^
# Alert deprecated: module Caml
# [since v0.16] use Stdlib instead of Caml
# 
# File "stubgen/stubgen.ml", line 120, characters 31-44:
# 120 |   generate_stub_ml_for_package Caml.Sys.argv.(1)
#                                      ^^^^^^^^^^^^^
# Alert deprecated: module Caml
# [since v0.16] use Stdlib instead of Caml
# File "lib/dune", line 12, characters 20-38:
# 12 |                     read_internal_stub
#                          ^^^^^^^^^^^^^^^^^^
# (cd _build/default/lib && /usr/bin/gcc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC -D_FILE_OFFSET_BITS=64 -I/usr/share/R/include -g -I /home/opam/.opam/5.1/lib/ocaml -I /home/opam/.opam/5.1/lib/ocaml/unix -o read_internal_stub.o -c read_internal_stub.c)
# In file included from read_internal_stub.c:32:
# read_internal_stub.c: In function 'ocamlr_inspect_primsxp_offset':
# read_internal_stub.c:108:32: error: invalid use of undefined type 'struct SEXPREC'
#   108 |   return(Val_int(Sexp_val(sexp)->u.primsxp.offset));
#       |                                ^~
# /home/opam/.opam/5.1/lib/ocaml/caml/mlvalues.h:77:47: note: in definition of macro 'Val_long'
#    77 | #define Val_long(x)     ((intnat) (((uintnat)(x) << 1)) + 1)
#       |                                               ^
# read_internal_stub.c:108:10: note: in expansion of macro 'Val_int'
#   108 |   return(Val_int(Sexp_val(sexp)->u.primsxp.offset));
#       |          ^~~~~~~
# read_internal_stub.c: In function 'ocamlr_inspect_promsxp_value':
# read_internal_stub.c:241:33: error: invalid use of undefined type 'struct SEXPREC'
#   241 |   return(Val_sexp(Sexp_val(sexp)->u.promsxp.value));
#       |                                 ^~
# read_internal_stub.c: In function 'ocamlr_inspect_promsxp_expr':
# read_internal_stub.c:254:33: error: invalid use of undefined type 'struct SEXPREC'
#   254 |   return(Val_sexp(Sexp_val(sexp)->u.promsxp.expr));
#       |                                 ^~
# read_internal_stub.c: In function 'ocamlr_inspect_promsxp_env':
# read_internal_stub.c:267:33: error: invalid use of undefined type 'struct SEXPREC'
#   267 |   return(Val_sexp(Sexp_val(sexp)->u.promsxp.env));
#       |                                 ^~
# File "lib/dune", line 13, characters 20-39:
# 13 |                     write_internal_stub
#                          ^^^^^^^^^^^^^^^^^^^
# (cd _build/default/lib && /usr/bin/gcc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC -D_FILE_OFFSET_BITS=64 -I/usr/share/R/include -g -I /home/opam/.opam/5.1/lib/ocaml -I /home/opam/.opam/5.1/lib/ocaml/unix -o write_internal_stub.o -c write_internal_stub.c)
# write_internal_stub.c: In function 'ocamlr_write_lisplist_carval':
# write_internal_stub.c:50:21: error: invalid use of undefined type 'struct SEXPREC'
#    50 |   Sexp_val(lisplist)->u.listsxp.carval = Sexp_val(elmnt);
#       |                     ^~
# write_internal_stub.c: In function 'ocamlr_write_lisplist_tagval':
# write_internal_stub.c:55:21: error: invalid use of undefined type 'struct SEXPREC'
#    55 |   Sexp_val(lisplist)->u.listsxp.tagval = Sexp_val(tag);
#       |                     ^~
# (cd _build/default && /home/opam/.opam/5.1/bin/ocamlopt.opt -w -40 -g -I stubgen/.stubgen.eobjs/byte -I stubgen/.stubgen.eobjs/native -I /home/opam/.opam/5.1/lib/base -I /home/opam/.opam/5.1/lib/base/base_internalhash_types -I /home/opam/.opam/5.1/lib/base/caml -I /home/opam/.opam/5.1/lib/base/shadow_stdlib -I /home/opam/.opam/5.1/lib/ocaml/unix -I /home/opam/.opam/5.1/lib/sexplib0 -I lib/.OCamlR.objs/native -I lib/.OCamlR.objs/public_cmi -I lib/interpreter/.OCamlR_interpreter.objs/byte -I lib/interpreter/.OCamlR_interpreter.objs/native -intf-suffix .ml -no-alias-deps -o stubgen/.stubgen.eobjs/native/dune__exe__Stubgen.cmx -c -impl stubgen/stubgen.ml)
# File "stubgen/stubgen.ml", line 43, characters 23-33:
# 43 |     if List.mem ~equal:Caml.( = ) keywords n then n ^ "_"
#                             ^^^^^^^^^^
# Alert deprecated: module Caml
# [since v0.16] use Stdlib instead of Caml
# 
# File "stubgen/stubgen.ml", line 106, characters 2-20:
# 106 |   Caml.print_endline "open OCamlR" ;
#         ^^^^^^^^^^^^^^^^^^
# Alert deprecated: module Caml
# [since v0.16] use Stdlib instead of Caml
# 
# File "stubgen/stubgen.ml", line 107, characters 2-20:
# 107 |   Caml.print_endline (
#         ^^^^^^^^^^^^^^^^^^
# Alert deprecated: module Caml
# [since v0.16] use Stdlib instead of Caml
# 
# File "stubgen/stubgen.ml", line 116, characters 11-29:
# 116 |         |> Caml.print_endline
#                  ^^^^^^^^^^^^^^^^^^
# Alert deprecated: module Caml
# [since v0.16] use Stdlib instead of Caml
# 
# File "stubgen/stubgen.ml", line 120, characters 31-44:
# 120 |   generate_stub_ml_for_package Caml.Sys.argv.(1)
#                                      ^^^^^^^^^^^^^
# Alert deprecated: module Caml
# [since v0.16] use Stdlib instead of Caml



<><> Error report <><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
+- The following actions failed
| - build ocaml-r 0.4.0
+- 
+- The following changes have been performed
| - install base              v0.16.3
| - install conf-bash         1
| - install conf-pkg-config   3
| - install conf-r            1.0.0
| - install conf-r-mathlib    1
| - install csexp             1.5.2
| - install dune-configurator 3.15.2
| - install sexplib0          v0.16.0
| - install stdio             v0.16.0
+- 
# Run eval $(opam env) to update the current shell environment

The former state can be restored with:
    /usr/bin/opam switch import "/home/opam/.opam/5.1/.opam-switch/backup/state-20240517135237.export"
'opam --cli=2.1 install ocaml-r.0.4.0 stdio.v0.16.0 sexplib0.v0.16.0 dune-configurator.3.15.2 dune.3.15.2 csexp.1.5.2 conf-r-mathlib.1 conf-r.1.0.0 conf-pkg-config.3 conf-bash.1 base.v0.16.3 --verbose --yes --confirm-level=unsafe-yes' failed.
OCaml

Innovation. Community. Security.