On This Page
  1. Error log

ppx_tools 5.0

Error log

The package failed to build. The error log from opam follows.

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for jsoo_storage.1.0 & base-bytes.base & base64.2.3.0 & camlp4.4.04+1 & cmdliner.1.0.4 & cppo.1.6.8 & dune.1.6.3 & jbuilder.transition & js_of_ocaml.2.8.4 & lwt.3.3.0 & menhir.20190924 & ocaml-migrate-parsetree.1.3.1 & ocamlbuild.0.14.1 & ocamlfind.1.9.5 & ppx_derivers.1.2.1 & ppx_tools.5.0 & ppx_tools_versioned.5.2.2 & result.1.5 & seq.0.2.2 & uchar.0.0.2 & yojson.2.0.0:   * Incompatible packages:
            - (invariant) -> ocaml-base-compiler = 4.04.2
            - jsoo_storage < 1.0.1 -> ocaml < 4.04.1 -> ocaml-system >= 3.09.1
            You can temporarily relax the switch invariant with `--update-invariant'
          * Missing dependency:
            - jsoo_storage < 1.0.1 -> ocaml < 4.04.1 -> ocaml-base-compiler < 3.07+1 | ocaml-system < 3.07+1 | ocaml-variants < 3.8~
            not available because the package is pinned to version 4.04.2
            unmet availability conditions: 'sys-ocaml-version = "3.07"'
            no matching version
          * Missing dependency:
            - jsoo_storage < 1.0.1 -> ocaml < 4.04.1 -> ocaml-base-compiler = 3.07+1 | ocaml-system = 3.07+1 | ocaml-variants < 3.8~
            not available because the package is pinned to version 4.04.2
            unmet availability conditions: 'sys-ocaml-version = "3.07+1"'
            no matching version
          * Missing dependency:
            - jsoo_storage < 1.0.1 -> ocaml < 4.04.1 -> ocaml-base-compiler = 3.07+2 | ocaml-system = 3.07+2 | ocaml-variants < 3.8~
            not available because the package is pinned to version 4.04.2
            unmet availability conditions: 'sys-ocaml-version = "3.07+2"'
            no matching version
          * Missing dependency:
            - jsoo_storage < 1.0.1 -> ocaml < 4.04.1 -> ocaml-base-compiler = 3.08.0 | ocaml-system < 3.08.1~ | ocaml-variants < 3.08.1~
            not available because the package is pinned to version 4.04.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.0"'
            no matching version
          * Missing dependency:
            - jsoo_storage < 1.0.1 -> ocaml < 4.04.1 -> ocaml-base-compiler = 3.08.1 | ocaml-system < 3.08.2~ | ocaml-variants < 3.08.2~
            not available because the package is pinned to version 4.04.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.1"'
            no matching version
          * Missing dependency:
            - jsoo_storage < 1.0.1 -> ocaml < 4.04.1 -> ocaml-base-compiler = 3.08.2 | ocaml-system < 3.08.3~ | ocaml-variants < 3.08.3~
            not available because the package is pinned to version 4.04.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.2"'
            no matching version
          * Missing dependency:
            - jsoo_storage < 1.0.1 -> ocaml < 4.04.1 -> ocaml-base-compiler = 3.08.3 | ocaml-system < 3.08.4~ | ocaml-variants < 3.08.4~
            not available because the package is pinned to version 4.04.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.3"'
            no matching version
          * Missing dependency:
            - jsoo_storage < 1.0.1 -> ocaml < 4.04.1 -> ocaml-base-compiler = 3.08.4 | ocaml-system < 3.08.5~ | ocaml-variants < 3.08.5~
            not available because the package is pinned to version 4.04.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.4"'
            no matching version
          * Missing dependency:
            - jsoo_storage < 1.0.1 -> ocaml < 4.04.1 -> ocaml-base-compiler = 3.09.0 | ocaml-system < 3.09.1~ | ocaml-variants < 3.09.1~
            not available because the package is pinned to version 4.04.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.09.0"'
            no matching version
          * Missing dependency:
            - jsoo_storage < 1.0.1 -> ocaml < 4.04.1 -> ocaml-variants -> ocaml-beta
            unmet availability conditions: 'enable-ocaml-beta-repository'


Command failed: opam --cli=2.1 list --readonly --external '--resolve=jsoo_storage.1.0,base-bytes.base,base64.2.3.0,camlp4.4.04+1,cmdliner.1.0.4,cppo.1.6.8,dune.1.6.3,jbuilder.transition,js_of_ocaml.2.8.4,lwt.3.3.0,menhir.20190924,ocaml-migrate-parsetree.1.3.1,ocamlbuild.0.14.1,ocamlfind.1.9.5,ppx_derivers.1.2.1,ppx_tools.5.0,ppx_tools_versioned.5.2.2,result.1.5,seq.0.2.2,uchar.0.0.2,yojson.2.0.0' returned 20