result

Compatibility Result module
Description

Projects that want to use the new result type defined in OCaml >= 4.03 while staying compatible with older version of OCaml should use the Result module defined in this library.

Install
Published
26 Feb 2020
Authors
Maintainers
Sources
result-1.5.tbz
md5=1b82dec78849680b49ae9a8a365b831b
Dependencies
Reverse Dependencies
alcotest >= "0.4.6" & < "0.8.0"
arp < "0.2.1"
asn1-combinators >= "0.1.3" & < "0.2.2"
assimp >= "0.3"
bap-std >= "2.1.0"
bechamel-js = "0.2.0"
calculon < "0.6"
capnp >= "3.1.0"
cohttp-mirage < "2.1.1"
conduit >= "0.15.0" & < "1.5.0"
containers >= "0.16" & < "1.0"
coq-of-ocaml >= "2.5.0"
core_kernel >= "113.33.00" & < "v0.9.0"
cpuid < "0.1.2"
csexp >= "1.1.0" & < "1.5.1"
current >= "0.4"
current_git >= "0.4"
current_rpc >= "0.4"
current_web >= "0.4"
datakit-client = "0.11.0"
datakit-github >= "0.9.0"
depyt < "0.2.0"
diet < "0.3"
dispatch-js < "0.5.0"
dns >= "0.19.1" & < "4.0.0"
dream < "1.0.0~alpha3"
dune-configurator >= "2.7.1" & < "3.0.2"
dune-rpc-lwt != "3.0.3"
fat-filesystem >= "0.12.0" & < "0.13.0"
fmt >= "0.8.0" & < "0.8.6"
fpath < "0.7.3"
functoria >= "4.0.0~beta1"
git >= "3.0.0"
git-mirage < "2.0.0" | >= "3.0.0"
git-unix >= "3.0.0"
graphql_ppx < "1.0.1"
irc-client >= "0.4.0"
irmin = "2.7.0"
irmin-graphql = "2.7.0"
irmin-mirage < "2.0.0"
jose >= "0.3.1" & < "0.7.0"
jsonrpc < "1.6.0"
key-parsers >= "0.3.0"
launchd < "1.3"
linenoise >= "1.1.0"
links >= "0.9"
logs < "0.6.2"
logs-syslog < "0.1.0"
lsp >= "1.6.0" & < "1.10.0"
lwt >= "2.6.0" & < "5.6.0"
mdx >= "1.2.0" & < "2.2.0"
merlin >= "3.4.0" & < "4.5-411"
mimic < "0.0.4"
mirage-block >= "1.0.0" & < "1.2.0"
mirage-block-unix >= "2.5.0" & < "2.8.3"
mirage-flow >= "1.2.0" & < "1.5.0"
mirage-fs = "1.0.0"
mirage-fs-unix >= "1.3.0" & < "1.4.1"
mirage-http >= "3.0.0"
mirage-kv < "1.1.1"
mirage-net = "1.0.0"
mirage-net-unix >= "2.3.0" & < "2.5.0"
mirage-net-xen >= "1.5.0" & < "1.7.1"
mirage-vnetif >= "0.3.1"
mrt-format >= "0.3.0"
multipart_form >= "0.2.0" & < "0.4.1"
nbd >= "3.0.0" & < "6.0.0"
netchannel < "1.8.1" | >= "2.1.0"
notty < "0.2.0"
ocaml-version >= "2.4.0" & < "3.0.0"
ometrics < "0.2.0"
omigrate >= "0.3.0"
otfm = "0.3.0"
otr >= "0.3.2" & < "0.3.4"
pa_ppx >= "0.07"
parse-argv >= "0.0.2" & < "0.2.0"
ppx_implicits = "0.2.0"
promise >= "1.1.0"
protocol-9p < "1.0.0"
ptime < "0.8.6"
reason >= "3.2.0"
records >= "0.6.0"
rpclib >= "8.1.1"
rresult >= "0.3.0" & < "0.7.0"
sequence >= "1.0"
session < "0.5.0"
stb_image >= "0.3"
sturgeon >= "0.2"
tar < "1.1.0"
tar-format >= "0.6.0"
tar-mirage < "1.1.0"
tar-unix < "1.1.0"
tcpip >= "2.8.0" & < "3.2.0" | >= "4.1.0" & < "6.0.0"
tgls >= "0.8.4" & < "0.8.6"
timedesc >= "0.8.0"
tiny_httpd >= "0.12"
topkg < "1.0.1"
topkg-care < "1.0.1"
tsdl = "0.9.0"
tsdl-image = "0.1.2"
tsdl-mixer < "0.3.0"
tsdl-ttf < "0.3"
tuntap >= "1.5.0" & < "1.6.1"
unix-errno >= "0.3.0"
uwt >= "0.0.3"
vchan >= "2.2.0" & < "5.0.0"
vchan-unix < "5.0.0"
vchan-xen < "5.0.0"
vg >= "0.9.0" & < "0.9.3"
visitors >= "20170404"
x509 >= "0.6.0" & < "0.6.2"
zed >= "3.2.0"