swhid_core

OCaml library to work with swhids
README

swhid_core is an OCaml library to work with persistent identifiers used by Software Heritage, also known as swhid. This is the core library, for most use cases you should use the swhid library instead.

Installation

swhid_core can be installed with opam:

opam install swhid_core

If you don't have opam, you can install it following the how to install opam guide.

If you can't or don't want to use opam, consult the opam file for build instructions.

Quickstart

Have a look at the example folder or at the documentation.

About

Install
Published
20 Jun 2022
Sources
0.1.tar.gz
sha256=8718b4eb97c9f0acd6d9162a9efa2f6af82474a0bd186f622fda3294f773bccf
sha512=ec72cc946c662dc8230f4ef8c85bb41df56c3f46bc49276feca434199cd482f11901be902fc5c243244866d4a167474f18245f83ad0b0cf46eb35406ad1f1b5c
Dependencies
odoc
with-doc
dune
>= "1.11"
ocaml
>= "4.03"
Reverse Dependencies
swhid
>= "0.2"