topkg

The transitory OCaml software packager
Description

Topkg is a packager for distributing OCaml software. It provides an API to describe the files a package installs in a given build configuration and to specify information about the package's distribution, creation and publication procedures.

The optional topkg-care package provides the topkg command line tool which helps with various aspects of a package's life cycle: creating and linting a distribution, releasing it on the WWW, publish its documentation, add it to the OCaml opam repository, etc.

Topkg is distributed under the ISC license and has no dependencies. This is what your packages will need as a build dependency.

Topkg-care is distributed under the ISC license it depends on fmt, logs, bos, cmdliner, webbrowser and opam-format.

Home page: http://erratique.ch/software/topkg

Install
Published
06 Oct 2021
Authors
Maintainers
Sources
topkg-1.0.4.tbz
sha512=5baa1bf0105397589b741acd0195069823548b2051e453dffd641e5d00536b7a5f41b38d005b2b063f9e7cfb9a3b627bec3e6ad48e56769cc35a71f97a897f1b
Dependencies
ocamlfind build & >= "1.6.1"
ocaml >= "4.03.0" & < "5.0"
Reverse Dependencies
alcotest >= "0.5.0" & < "0.8.0"
ansi-parse < "0.4.0"
anycache < "0.7.4"
arp < "1.0.0"
asn1-combinators >= "0.1.3" & < "0.2.2"
astring >= "0.8.2"
base64 = "2.1.2"
brr < "0.0.2"
certify = "0.2"
channel >= "1.1.1"
charrua-core >= "0.5" & < "0.8"
cmdliner >= "1.0.0" & < "1.0.3"
cmdtui < "0.4.3"
conex < "0.10.0"
cow = "2.2.0"
cpuid < "0.1.2"
crunch = "2.0.0"
datakit < "0.10.0"
datakit-client < "0.10.0"
datakit-github < "0.10.0"
datakit-server < "0.10.0"
decompress >= "0.5" & < "0.8"
depyt < "0.2.0"
digestif < "0.6.1"
dns >= "0.19.1" & < "1.0.0"
dns-forward < "0.9.0"
doc-ock < "1.1.0"
doc-ock-html < "1.1.0"
doc-ock-xml < "1.1.0"
dockerfile >= "1.7.2" & < "3.0.0"
dog >= "0.2.1"
domain-name < "0.1.2"
dtoa < "0.3.0"
duration < "0.1.2"
edn >= "0.1.2-1-g09b142a" & < "0.1.6-1-gff9db95"
enumerators >= "0.2.0"
ezsqlite < "0.4"
fat-filesystem = "0.12.0"
fmt >= "0.8.0"
functoria >= "2.0.0" & < "2.1.0"
gg >= "0.9.2"
git-unix >= "1.10.0" & < "1.11.1"
github-hooks < "0.2.0"
gmap < "0.2.1"
hardcaml = "1.2.0"
hardcaml-vpi >= "0.3.0"
higher >= "0.3.1"
hiredis < "0.8"
hkdf = "1.0.2"
hmap >= "0.8.1"
integers < "0.3.0"
inuit < "0.4.1"
ipaddr >= "2.7.1" & < "2.8.0"
irmin >= "0.12.0" & < "1.2.0"
irmin-git < "1.2.0"
irmin-http < "1.2.0"
irmin-mirage < "1.2.0"
irmin-unix >= "1.0.0" & < "1.2.0"
irmin-watcher < "0.3.0"
jekyll-format < "0.2.0"
jsonm >= "1.0.0"
key-parsers >= "0.6.0" & < "0.10.0"
libudev >= "0.2.1"
logs >= "0.6.0"
logs-syslog < "0.2.0"
lru < "0.3.0"
mirage >= "3.0.0" & < "3.0.5"
mirage-block = "1.0.0"
mirage-block-solo5 >= "0.2.1" & < "0.6.0"
mirage-bootvar-solo5 >= "0.2.0" & < "0.6.0"
mirage-clock < "1.3.0"
mirage-console-solo5 >= "0.2.0" & < "0.6.0"
mirage-console-unix >= "2.2.0" & < "2.3.2"
mirage-device < "1.1.0"
mirage-flow = "1.2.0"
mirage-fs = "1.0.0"
mirage-fs-lwt < "1.1.1"
mirage-http >= "2.5.3" & < "3.2.0"
mirage-kv < "1.1.1"
mirage-kv-lwt < "1.1.0"
mirage-logs = "0.3.0"
mirage-net = "1.0.0"
mirage-net-fd < "0.2.1"
mirage-net-macosx >= "1.2.0" & < "1.4.0"
mirage-net-solo5 >= "0.2.0" & < "0.4.3"
mirage-net-unix >= "2.3.0" & < "2.4.1"
mirage-random < "1.1.0"
mirage-solo5 >= "0.2.0" & < "0.6.2"
mirage-stack < "1.1.0"
mirage-time < "1.1.0"
mirage-types = "3.0.0"
mirage-unix >= "3.0.8" & < "3.2.0"
mirage-vnetif = "0.3.1"
mirage-xen >= "3.0.6" & < "3.2.0"
msgpck < "1.3"
mtime >= "0.8.4"
named-pipe >= "0.4.0"
nocrypto >= "0.5.4"
notty >= "0.2.0" & < "0.2.3"
ocb-stubblr >= "0.1.0"
octavius < "1.1.0"
odds < "1.1"
odoc < "1.1.0"
oml >= "0.0.7"
osx-cf >= "0.1.1"
otfm >= "0.3.0"
otr >= "0.3.3" & < "0.3.6"
papi < "0.1.1"
parse-argv < "0.1.0"
pbkdf = "0.2.0"
pcap-format = "0.5.0"
pkcs11 < "0.18.0"
ppx_compose < "0.0.4"
protocol-9p >= "0.7.2" & < "0.10.0"
psq < "0.1.1"
ptime >= "0.8.1"
py < "1.1"
qcow < "0.10.0"
randomconv < "0.1.1"
rawlink >= "0.5" & < "1.0"
react >= "1.2.1"
reason = "1.13.7" | = "3.0.0"
records >= "0.7.0"
rfc6287 >= "1.0.2" & < "1.0.4"
rresult >= "0.4.0"
salsa20 < "1.0.0"
salsa20-core < "1.0.0"
scrypt-kdf >= "0.2.0" & < "1.0.0"
shcaml >= "0.2.0"
simple-diff >= "0.2.1"
sturgeon < "0.4.2"
systemverilog < "0.0.2"
tar-format >= "0.7.1"
terminal_size < "0.1.4"
tgls >= "0.8.4"
tls >= "0.8.0" & < "0.11.0"
tlstunnel >= "0.2.0"
topkg-care = "1.0.4"
tsdl >= "0.9.1"
tuntap = "1.4.1"
uucd >= "4.0.0"
uucp >= "2.0.0"
uuidm >= "0.9.6"
uunf >= "2.0.0"
uuseg >= "1.0.0"
uutf >= "1.0.0"
vg >= "0.9.0"
wamp < "1.2"
x509 >= "0.6.0" & < "0.6.3"
xmlm >= "1.3.0"
yurt < "0.6"
zlist < "0.4.0"
zxcvbn < "2.3+2"