HTTP library for Lwt, Async and Mirage
Description

There are several optional dependencies which activate functionality:

  • Lwt: opam install lwt cohttp
  • Lwt and SSL: opam install lwt ssl cohttp
  • Async: opam install async cohttp
  • Async and SSL: opam install async_ssl cohttp
Install
Last Published
09 Nov 2014
Authors
Maintainers
Sources
v0.12.0.tar.gz
md5=318788d5e43569935e21cc39d455aa34
Dependencies
conduit >= "0.6.0" & < "0.16.0"
sexplib >= "109.53.00" & < "113.01.00"
fieldslib >= "109.20.00" & < "113.01.00"
uri >= "1.5.0" & < "2.0.0"
ocaml < "5.0"
Reverse Dependencies
aws-s3 < "1.1.0" | >= "2.0.0" & < "4.0.0"
cca >= "0.6.2"
cohttp-async >= "1.1.1" & < "2.2.0"
cohttp-mirage >= "2.0.0" & != "2.1.1" & < "2.5.5"
cohttp-top >= "1.1.0" & < "2.2.0"
cowabloga = "0.0.8" | >= "0.4.0"
datakit < "0.10.0"
dog < "0.2.1"
frenetic >= "3.3.0" & < "5.0.5"
git = "1.4.10" | >= "1.5.0" & < "1.10.0"
git-paf < "3.5.0"
git-unix < "1.10.0" | = "1.11.1"
github >= "0.8.2" & < "0.9.4"
github-hooks < "0.2.0"
iocaml < "0.4.7"
irmin >= "0.9.0" & != "0.11.1" & < "1.0.0"
irmin-graphql >= "2.3.0"
irmin-http >= "2.3.0"
irmin-mirage-git >= "2.3.0" & < "2.8.0"
irmin-unix < "0.9.9" | >= "2.3.0"
letsencrypt < "0.3.0"
merge-queues >= "0.2.0"
mirage-http = "2.0.0"
mirage-www >= "1.1.0"
nsq >= "0.2.4"
opium >= "0.10.1" & < "0.12.0"
opium_kernel >= "0.18.0"
podge < "0.7.0"
slacko < "0.13.0"
syndic >= "1.4" & < "1.6.0"
usbmux < "1.3.2"
vhd-tool >= "0.7.6"
webmachine < "0.4.0"
websocket >= "0.9.1" & < "0.9.3"
xen-api-client >= "0.9.8"
Conflicts
js_of_ocaml >= "3.0"
lwt >= "2.5.0"
lwt < "2.4.3"
async >= "113.00.00"
async < "109.15.00"