package ppxlib

  1. Overview
  2. Docs
Standard library for ppx rewriters

Install

Dune Dependency

Authors

Maintainers

Sources

ppxlib-0.27.0.tbz
sha256=764b96121d6ffd6a73820e0ec5235176bfc42b94cf2ff97e32d068a5c4b28c62
sha512=2dcce0be6acdb3e185bfdad2785303a405c617f99949316abe6793f785d7227c10795ca49e79290bd385873da635191b44e8a5c211de114a168846d5d26f505c

Description

Ppxlib is the standard library for ppx rewriters and other programs that manipulate the in-memory representation of OCaml programs, a.k.a the "Parsetree".

It also comes bundled with two ppx rewriters that are commonly used to write tools that manipulate and/or generate Parsetree values; ppxlib.metaquot which allows to construct Parsetree values using the OCaml syntax directly and ppxlib.traverse which provides various ways of automatically traversing values of a given type, in particular allowing to inject a complex structured value into generated code.

Published: 15 Jun 2022

README

Ppxlib - Meta-programming for OCaml

User manual API documentation

Overview

Ppxlib is the standard library for ppx rewriters and other programs that manipulate the in-memory representation of OCaml programs, a.k.a the "Parsetree".

It also comes bundled with two ppx rewriters that are commonly used to write tools that manipulate and/or generate Parsetree values; ppxlib.metaquot which allows to construct Parsetree values using the OCaml syntax directly and ppxlib.traverse which provides various ways of automatically traversing values of a given type, in particular allowing to inject a complex structured value into generated code.

For more information about ppxlib and how to use it, please consult the user manual.

What is the relation between ppxlib and other ppx libraries?

The ppx world has a long historied history, and if you look around you may find other projects that offer functionalities similar to ppxlib. The following blog post gives a good overview of the various libraries that have been developed over time. At this point, ppxlib is considered as the de facto library for writing ppx rewriters.

History of the project

This repository was created by merging several older smaller projects that were developed at Jane Street. See the history for more details.

Dependencies (6)

  1. stdlib-shims
  2. sexplib0 >= "v0.12"
  3. ppx_derivers >= "1.0"
  4. ocaml-compiler-libs >= "v0.11.0"
  5. ocaml >= "4.04.1" & < "5.1.0"
  6. dune >= "2.7"

Dev Dependencies (7)

  1. odoc with-doc
  2. stdio with-test
  3. base with-test
  4. cinaps with-test & >= "v0.12.1"
  5. re with-test & >= "1.9.0"
  6. ocamlfind with-test
  7. sexplib0 with-test & < "v0.15"

  1. awsm-codegen
  2. base_quickcheck = "v0.13.0" | >= "v0.14.1" & < "v0.16.0"
  3. bisect_ppx = "2.8.2"
  4. bistro >= "0.6.0"
  5. clangml >= "4.7.0"
  6. comby < "1.3.0"
  7. commons
  8. diff
  9. ego
  10. eliom >= "8.9.0"
  11. elpi >= "1.11.0" & < "1.11.3" | >= "1.13.2"
  12. embedded_ocaml_templates < "0.3.1" | >= "0.7"
  13. extunix >= "0.3.1"
  14. flow_parser >= "0.229.1"
  15. fsml
  16. GT >= "0.5.1"
  17. gen_js_api >= "1.0.6" & < "1.0.8" | >= "1.1.1"
  18. genprint = "0.3"
  19. gospel >= "0.2.0"
  20. graphql_ppx >= "1.2.2"
  21. hack_parallel >= "1.0.1"
  22. hardcaml >= "v0.14.1" & < "v0.16.0"
  23. html_of_jsx
  24. http_async
  25. js_of_ocaml >= "3.8.0"
  26. js_of_ocaml-compiler >= "3.8.0"
  27. js_of_ocaml-lwt >= "3.10.0"
  28. js_of_ocaml-ocamlbuild >= "3.10.0" & < "5.0"
  29. js_of_ocaml-ppx >= "3.8.0"
  30. js_of_ocaml-ppx_deriving_json >= "3.7.1"
  31. js_of_ocaml-toplevel >= "3.10.0"
  32. js_of_ocaml-tyxml >= "3.10.0"
  33. jsoo-react
  34. lablqml >= "0.7"
  35. landmarks-ppx
  36. lascar >= "0.7.0"
  37. learn-ocaml >= "0.13.0"
  38. learn-ocaml-client >= "0.13.0"
  39. lens >= "1.2.5"
  40. let-if >= "0.2.0"
  41. logs-ppx
  42. lwt_ppx >= "2.0.2"
  43. melange = "1.0.0"
  44. merlin >= "4.7-412"
  45. metapp >= "0.4.4"
  46. metaquot >= "0.5.0"
  47. mlt_parser = "v0.13.0" | >= "v0.14.1" & < "v0.16.0"
  48. mutaml
  49. noCanren >= "0.3.0~alpha1"
  50. node_of_ocaml
  51. nuscr >= "2.0.0"
  52. OCanren-ppx = "0.2.0" | >= "0.3.0"
  53. ocaml-monadic >= "0.5"
  54. ocamlformat = "0.19.0~4.13preview"
  55. ocf_ppx
  56. ocsigen-i18n >= "4.0.0"
  57. ocsigen-ppx-rpc
  58. ojs_base_ppx
  59. ometrics = "0.2.0"
  60. ortac-core
  61. ortac-qcheck-stm
  62. override = "0.2.2"
  63. pacomb
  64. pgocaml_ppx >= "4.3.0"
  65. pla >= "2.0"
  66. ppx-owl-opt
  67. ppx_accessor >= "v0.14.3" & < "v0.16.0"
  68. ppx_assert >= "v0.13.0" & < "v0.16.0"
  69. ppx_bap
  70. ppx_base >= "v0.13.0" & < "v0.16.0"
  71. ppx_bench >= "v0.14.1" & < "v0.16.0"
  72. ppx_bin_prot >= "v0.13.0" & < "v0.16.0"
  73. ppx_bitstring >= "4.1.0"
  74. ppx_blob >= "0.7.2"
  75. ppx_camlrack
  76. ppx_catch
  77. ppx_cold < "v0.16.0"
  78. ppx_compare >= "v0.13.0" & < "v0.16.0"
  79. ppx_compose >= "0.2.1"
  80. ppx_const >= "2.0.1"
  81. ppx_conv_func >= "v0.13.0" & < "v0.16.0"
  82. ppx_counters
  83. ppx_css < "v0.16.0"
  84. ppx_cstruct >= "6.0.0"
  85. ppx_cstubs >= "0.6.1"
  86. ppx_csv_conv >= "v0.13.0" & < "v0.16.0"
  87. ppx_custom_printf >= "v0.14.1" & < "v0.16.0"
  88. ppx_decimal
  89. ppx_default
  90. ppx_defer >= "0.5.0"
  91. ppx_deriving >= "5.2"
  92. ppx_deriving_cad
  93. ppx_deriving_encoding >= "0.2"
  94. ppx_deriving_hardcaml >= "v0.13.0" & < "v0.16.0"
  95. ppx_deriving_hash
  96. ppx_deriving_jsoo >= "0.2"
  97. ppx_deriving_madcast >= "0.2"
  98. ppx_deriving_popper
  99. ppx_deriving_protobuf >= "3.0.0"
  100. ppx_deriving_qcheck
  101. ppx_deriving_rpc >= "8.1.0"
  102. ppx_deriving_scad
  103. ppx_deriving_yaml
  104. ppx_deriving_yojson >= "3.7.0"
  105. ppx_disable_unused_warnings < "v0.16.0"
  106. ppx_distr_guards >= "0.3"
  107. ppx_dream_eml
  108. ppx_enumerate >= "v0.13.0" & < "v0.16.0"
  109. ppx_expect >= "v0.13.0" & != "v0.14.0" & < "v0.16.0"
  110. ppx_factory = "0.1.0" | >= "0.2.0"
  111. ppx_fail >= "v0.13.0"
  112. ppx_fields_conv >= "v0.14.2" & < "v0.16.0"
  113. ppx_fixed_literal < "v0.16.0"
  114. ppx_gen_rec >= "2.0.0"
  115. ppx_getenv >= "2.1"
  116. ppx_hash >= "v0.13.0" & < "v0.16.0"
  117. ppx_here >= "v0.13.0" & < "v0.16.0"
  118. ppx_ignore_instrumentation < "v0.16.0"
  119. ppx_import >= "1.7.0" & < "1.8.0" | >= "1.10.0"
  120. ppx_inline_alcotest
  121. ppx_inline_test >= "v0.14.1" & < "v0.16.0"
  122. ppx_irmin >= "3.0.0"
  123. ppx_jane >= "v0.13.0" & < "v0.16.0"
  124. ppx_js_style >= "v0.13.0" & < "v0.16.0"
  125. ppx_jsobject_conv = "0.8.0" | >= "0.9.3"
  126. ppx_jsonaf_conv = "v0.15.1"
  127. ppx_let >= "v0.13.0" & < "v0.16.0"
  128. ppx_log < "v0.16.0"
  129. ppx_lun
  130. ppx_make
  131. ppx_map
  132. ppx_matches
  133. ppx_minidebug
  134. ppx_module_timer >= "v0.13.0" & < "v0.16.0"
  135. ppx_monad
  136. ppx_monoid >= "0.3.3"
  137. ppx_mysql >= "1.1.3"
  138. ppx_open
  139. ppx_optcomp >= "v0.14.2" & < "v0.16.0"
  140. ppx_optint
  141. ppx_optional >= "v0.13.0" & < "v0.16.0"
  142. ppx_parser
  143. ppx_pattern_bind >= "v0.13.1" & < "v0.16.0"
  144. ppx_pipebang >= "v0.13.0" & < "v0.16.0"
  145. ppx_protocol_conv >= "5.1.3"
  146. ppx_pyformat
  147. ppx_python = "v0.15.0"
  148. ppx_rapper
  149. ppx_regexp >= "0.5.0"
  150. ppx_repr >= "0.6.0"
  151. ppx_seq
  152. ppx_sexp_conv = "v0.15.1"
  153. ppx_sexp_message >= "v0.14.1" & < "v0.16.0"
  154. ppx_sexp_value >= "v0.13.0" & < "v0.16.0"
  155. ppx_show >= "0.2.0"
  156. ppx_stable >= "v0.14.1" & < "v0.16.0"
  157. ppx_string >= "v0.14.1" & < "v0.16.0"
  158. ppx_string_interpolation
  159. ppx_subliner
  160. ppx_system
  161. ppx_ts
  162. ppx_type_directed_value
  163. ppx_typed_fields < "v0.16.0"
  164. ppx_typerep_conv >= "v0.14.2" & < "v0.16.0"
  165. ppx_units
  166. ppx_variants_conv >= "v0.14.2" & < "v0.16.0"
  167. ppx_viewpattern
  168. ppx_xml_conv >= "v0.13.0" & < "v0.16.0"
  169. ppx_yojson >= "1.3.0"
  170. ppx_yojson_conv = "v0.15.1"
  171. ppxx >= "2.5.0"
  172. qcow >= "0.11.0"
  173. rdf_ppx
  174. refl >= "0.4.1"
  175. repr-fuzz >= "0.2.1"
  176. res_tailwindcss
  177. scaml != "1.2.0"
  178. sedlex >= "2.6"
  179. spin >= "0.8.0"
  180. spoc_ppx
  181. stdint-literals
  182. togglelog
  183. toplevel_expect_test >= "v0.14.1" & < "v0.16.0"
  184. tyxml-jsx >= "4.5.0"
  185. tyxml-ppx >= "4.5.0"
  186. tyxml-syntax >= "4.5.0"
  187. visitors >= "20210608"
  188. wtr < "3.0.0"
  189. wtr-ppx
  190. xtmpl_ppx