ppx_sexp_conv

Generation of S-expression conversion functions from type definitions
Description

Part of the Jane Street's PPX rewriters collection.

Install
Published
28 Apr 2016
Authors
Maintainers
Sources
ppx_sexp_conv-113.33.03.tar.gz
md5=065b0f514aee32a2dbcd9e19d98af85c
Dependencies
sexplib >= "113.33.03" & < "113.34.00"
ppx_type_conv >= "113.33.03" & < "113.34.00"
ppx_tools >= "0.99.3"
ppx_core >= "113.33.03" & < "113.34.00"
js-build-tools build & >= "113.33.04" & < "113.34.00"
ocamlfind build & >= "1.3.2"
ocaml = "4.02.3"
Reverse Dependencies
async-zmq >= "0.3.0"
biocaml >= "0.4.0"
bistro >= "0.4.0"
bookaml >= "3.1"
cohttp >= "0.20.1" & < "0.99.0"
cohttp-lwt = "1.0.0"
conduit >= "0.12.0" & < "1.5.0"
conduit-async < "1.5.0"
conduit-lwt < "1.5.0"
coq-serapi < "8.7.2+0.4.13"
datakit-ci < "0.12.3"
dockerfile >= "1.3.0" & < "3.0.0"
dockerfile-cmd >= "6.0.0" & < "6.6.0"
frenetic >= "5.0.0" & < "5.0.5"
graphql-lwt < "0.3.0"
ibx >= "0.8.1"
ipaddr >= "2.7.0" & < "2.8.0" | >= "3.0.0" & < "4.0.0"
learn-ocaml >= "0.13.0"
links >= "0.9.2"
macaddr < "4.0.0"
message-switch >= "1.4.0"
mirage-block-unix >= "2.10.0" & < "2.11.1"
mirage-conduit < "2.0.0" | >= "3.0.0" & < "3.2.0"
mirage-net-xen >= "1.6.0" & < "1.7.1"
msgpck < "1.1"
nbd >= "2.1.0" & < "4.0.3"
nocrypto >= "0.5.3"
nsq >= "0.2.5" & < "0.5.2"
obeam = "0.1.0"
opass >= "1.0.6"
opium >= "0.15.0" & < "0.16.0" | = "0.18.0"
opium_kernel >= "0.18.0"
otr >= "0.3.1" & < "0.3.5"
pgocaml >= "4.2"
pgocaml_ppx >= "4.2" & < "4.3.0"
planck >= "2.2.0"
ppx_assert >= "113.33.00" & < "v0.9.0"
ppx_bap < "v0.14.0"
ppx_cstruct >= "3.1.0"
ppx_custom_printf >= "113.33.00" & < "v0.9.0"
ppx_expect >= "113.33.00" & < "v0.9.0"
ppx_jane >= "113.33.00" & < "v0.9.0"
ppx_sexp_message >= "113.33.00" & < "v0.9.0"
ppx_sexp_value >= "113.33.00" & < "v0.9.0"
protocol-9p >= "0.6.0" & < "0.10.0" | >= "0.11.2" & < "1.0.0"
qcow-format >= "0.3"
reparse >= "1.0.1" & < "2.0.0"
routes >= "2.0.0"
shared-block-ring >= "2.3.0" & < "3.0.0"
sihl < "0.1.0"
ssh-agent < "0.4.0"
tls >= "0.7.1" & < "0.11.0"
typerep_extended >= "113.33.00" & < "v0.9.0"
uri = "1.9.2"
vchan >= "2.1.0" & != "3.0.0"
vmnet >= "1.1.0"
wamp = "1.0"
x509 >= "0.5.1" & < "0.6.3"